WordPress.org

Ready to get started?Download WordPress

Forums

Upload large files - timeout (3 posts)

  1. fr29kath
    Member
    Posted 7 years ago #

    If I try to upload large files the system disconnects. is there anyway to stop this?

  2. cent
    Member
    Posted 7 years ago #

    if WP uses PHP to handle form uploads, then there may be a limit set in the PHP.INI file of some number of MB. Normal installations of PHP has this set at 8MB I believe. Your hosting provider should be able to increase this for larger files for you.

  3. vocaro
    Member
    Posted 7 years ago #

    For those of you with shell access to your WordPress installation, there's another option.

    1. Create a small file of the same name and type as the one you want to upload.
    2. Upload the small file using WordPress as you normally would.
    3. Upload the original (large) file using a non-WordPress method so that you don't run into the PHP limit. (For instance, you can use the scp command.)
    4. Navigate to the wp-content/uploads directory of your blog and locate the file you uploaded.
    5. Copy the large file over the smaller file's location.

    My hosting provider refused to increase the PHP limit on their shared server, so I had to use this trick. Worked like charm.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.