WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upload images to post - Unable to create directory localhost/2013/08 error (7 posts)

  1. Inquire
    Member
    Posted 7 months ago #

    I am working with a localhost test setup of WordPress.

    I am using Ubuntu 12.04

    I have phpMyAdmin installed

    I am using WordPress version 3.80

    I am testing inserting images

    Within a post I clicked on the Add Media button

    then the Upload Files link

    then the Select Files button

    I have photos in the Pictures folder

    I select a photo then click on the Open button

    I receive the following error

    Unable to create directory localhost/2013/08. Is its parent directory writable by the server?

    I have researched this error and the solution are dated and all over the map.

  2. esmi
    Forum Moderator
    Posted 7 months ago #

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  3. Inquire
    Member
    Posted 7 months ago #

    I downloaded WordPress and am testing as a localhost in Ubuntu 12.04
    I upgraded from the dowmloaded 3.6 to 3.8 version
    In Files section of My Computer I browsed /home/username/wordpress
    There isn't a wp-content folder. I executed the upgrade from the link within Admin. I didn't FTP as this is a local host WordPress setup. ??

  4. Inquire
    Member
    Posted 7 months ago #

    I copied the wp-content into the wordpress folder.

    I haven't done much with the blog yet as I am testing it as a local host.

    In the terminal I entered
    chmod -v 766 /home/myusername/wordpress/wp-content

    The result was

    changed from 0700 (rwx------) to 0766 (rwxrw-rw-)

    This chmod change didn't allow me to upload images.

    Any ideas???

  5. esmi
    Forum Moderator
    Posted 7 months ago #

    Try the other chmods as suggested above.

  6. Inquire
    Member
    Posted 7 months ago #

    Under Media Settings

    in the “Store uploads in this folder” was /srv/www/wp-uploads/localhost

    I entered wp-content/uploads in the “Store uploads in this folder” text box and saved

    I deleted http://localhost/wp-uploads from the text box below “Store uploads in this folder” and this solved the image upload problems.

    Here is an online article that might help others

    How to Fix the Unable to create directory Error in WordPress

    http://www.tipsandtricks-hq.com/how-to-fix-the-unable-to-create-directory-error-in-wordpress-5264

  7. Inquire
    Member
    Posted 7 months ago #

    I looked in the wordpress/wp-content/uploads within My Computer Files section and the images aren't being uploaded to the uploads file.

Reply

You must log in to post.

About this Topic