WordPress.org

Ready to get started?Download WordPress

Forums

Upload Images - Impossible (19 posts)

  1. rubenortiz
    Member
    Posted 6 years ago #

    Hi

    since some versions of WordPress im having many troubles with upload images by Text Editor.

    The permissions are 777 in /wp-content/uploads/[year]/[month]

    And i can upload a image by FTP client. But its no a solution for a single user :(

    Before to write this post i've looke for a solution in WordPress forum and i don't find any answer. But yes many people like me, with the same problem:

    http://wordpress.org/support/topic/122162?replies=1

    http://wordpress.org/support/topic/122922?replies=6

    http://wordpress.org/support/topic/117701?replies=4

    http://wordpress.org/support/topic/134228?replies=2

    If is not a trouble of permissions, it can be an error with a owner of folders? No a problem with CHOD but a problem with CHOWN?

    Now i can't ugrade any of my 5 or 6 WordPress by is impossible to upload a image. All this trouble happens since version 2.1 i think.

    Any help will be appreciated.

    Thanks.

  2. milton martins
    Member
    Posted 6 years ago #

    Hi, I'm using de 2.3.1 wordpress version and I have the same problem. Could you help find a solution??

  3. danieleggert
    Member
    Posted 6 years ago #

    I have both wp-content and uploads writable by the web user, but upload doesn't work.

    In fact, I can't even delete old uploads. When I click Delete File it reload the page, but the upload is still there.

    I wish there was some way to debug this. Some way to tell, what causes WordPress to fail. I'm on 2.3.3 / apache.

  4. Best Parent Ever
    Member
    Posted 6 years ago #

    A lot of people seem to be having the problem.

    I got it to work by using Firefox, instead of Internet Explorer.

    USE FIREFOX -- not IE

    I was able to "upload" images into Media Libary, but it was IMPOSSIBLE to put anything into the actual post with IE. But it seems to work fine with Firefox.

    Using Firefox, click "Add Media" at the top of the Text Editor, then go into the Media Library, and click on your images. That should open up another box that will allow to get images into your posts.

  5. starbug72
    Member
    Posted 6 years ago #

    When I click add media or add an image I get a pop up that says "are you sure you want to do this" and a link that says "please try again." There's no way to upload an image. I'm using 2.5 on Firefox.

  6. Rok
    Member
    Posted 6 years ago #

    See this solution, if it works for you.

  7. irisesweb
    Member
    Posted 6 years ago #

    I'm a new WordPress user and am basically trying to use it as a CMS - but do need up upload images into my 'pages'. I'm running 2.5 and I've tried IE and Firefox and all the various 'fixes' I've found on the forum. Nothing works.

    The images actually upload into the media library even though I get the dreaded "Specified file failed upload test."

    Am I doing something wrong? Is there a solution?

    Thanks for any help!

  8. starbug72
    Member
    Posted 6 years ago #

    I upgraded to wp 2.1.5 thinking it might resolve the image issue, but alas that is not the case. I don't have this problem on other wp blogs.

    When I click on add media > add an image
    the box that pops up says:

    Are you sure you want to do this?
    Please try again.

    The uploads folder is 777'd.

    Has anyone else seen this?

  9. starbug72
    Member
    Posted 6 years ago #

    Oops, meant to say WP 2.5.1

  10. bobbyh
    Member
    Posted 6 years ago #

    I don't have a solution, but in case it's helpful, that looks like the error for the wp-nonce function.

  11. nmarques
    Member
    Posted 6 years ago #

    I could solve this problem by changing the permission.
    I really don't understand how a lot of people at getting this error and apparently we don't see announcement from wordpress.
    I can upload but when I press publish, nothing happens, every time I use a picture in my post I got this error (sometimes even with just text).
    Help

  12. pngised
    Member
    Posted 6 years ago #

    Hi all,

    I've got the same problem in my wordpress. Permissions are right but the add Media button does not work...

    In my local installation I've not this problem so I think it is an apache problem. Maybe some config, but I don't know where I find a solution.

    Are there someone who could help?

  13. jmatdrama2
    Member
    Posted 6 years ago #

    I'm using WordPressMU and have posted a solution for my users on my blog. It works for me. Hopefully it will work for you. Certainly not elegant but then WordPress hasn't made that possible. This link will take you to my blog. Hope this helps anyone out there.

  14. arminbw
    Member
    Posted 6 years ago #

  15. chucksta420
    Member
    Posted 6 years ago #

    We had a similar problem but none of the suggested solutions worked until we upgraded to PHP5 from PHP4. All hosted blogs running on PHP4 had this issues, while those running on PHP5 did not. Upgrading to PHP5 fixed their issue.

  16. jmatdrama2
    Member
    Posted 6 years ago #

    Just to let you know, My blog notes aren't a solution - only a work around - it gets the pictures loaded and usable - it doesn't make WordPress work correctly. Again - not elegant.

  17. jmatdrama2
    Member
    Posted 6 years ago #

    I've moved my work around
    to the Admin Blog.
    Again - not a solution but it works for my users.

  18. wsuschmitt
    Member
    Posted 6 years ago #

    Well... played around with a lot of things and went through the definitive WP Troubleshooting post regarding the Image/Media Uploader issue http://wordpress.org/support/topic/164999?replies=1 but none of it seemed to have worked in this case.

    I ended up logging into the blog, going to Settings>Miscellaneous and noticed under the "Uploading" Section that the "Store uploads in this folder" subsection had /../../../../../../../../../../../../../../../../../tmp in it for some reason.

    I erased the /../../../../../../../../../../../../../../../../../tmp and saved settings.

    Problem resolved for me at least.

  19. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    The ../../.. thing is usually a sign that your blog has been hacked at some point in the past. You may want to double check the site and your security.

Topic Closed

This topic has been closed to new replies.

About this Topic