WordPress.org

Ready to get started?Download WordPress

Forums

upload image (17 posts)

  1. cvera
    Member
    Posted 9 years ago #

    I just start with wordpress. Does it offer image upload service?
    Thanks,

  2. stchatterbox
    Member
    Posted 9 years ago #

    yes, it does.
    go to your admin area, click options-->micellaneous
    and click allow file uploads. that's it.
    or if you like, you can get a plugin for image gallery like lazy gallery, which is very easy to use.

  3. cvera
    Member
    Posted 9 years ago #

    thanks!

  4. cvera
    Member
    Posted 9 years ago #

    I am trying with uploading in wordpress service.I upload a picture, and it gives me this:
    <img src='wp-content/ticket.JPG' alt='ticket' >
    I paste that into my text, and it doesn't work. why is that?
    Thanks,

  5. stchatterbox
    Member
    Posted 9 years ago #

    <img border="0" src="/wp-content/ticket.jpg" />

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

    The correct xhtml would be:
    `<img src='wp-content/ticket.JPG' alt='ticket' />

    Things to check:
    The file extension - is it really .JPG ? or .jpg ?
    Use a full URL to the image, not a relative url. If WP is giving you that, go back to the Misc options and copy the suggested url that WP shows - it looks like you have not done that.

  7. cvera
    Member
    Posted 9 years ago #

    Well, I try <img src='http://www.incsub.org/wpmu/cvera/images/ticket.jpg' alt='ticket' />
    <img src='wp-content/ticket.jpg' alt='ticket' />

    They don't work.

  8. cvera
    Member
    Posted 9 years ago #

    Well, After uploading my image,
    I try <img src='wp-content/ticket.JPG' alt='ticket' />
    <img src='/wp-content/ticket.JPG' alt='ticket' />
    <img src='/cvera/images/ticket.JPG' alt='ticket' />
    None of them work.
    I don't know where i can find the full URL. The Misc option page didn't give me a list of files I uploaded.
    Can someone help me here?
    Thanks,

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Go to Options, click Misc.
    Second box down URI of this directory:
    That has /wp-content in there ? And under it a full recommended url - copy that into the box and click Update.

  10. cvera
    Member
    Posted 9 years ago #

    sorry, but this is all i could see in the Mis page:
    Miscellaneous Options
    Allow File UploadsMinimum level to upload: 1 2 3 4 5 6 7 8 9 10

    Track Links’ Update Times

    Use legacy my-hacks.php file support

    Is that because my service is free?--http://www.incsub.org/wpmu/cvera
    Or because i am using proxy?

    Thanks for your help again!!!
    Vera

  11. Mark (podz)
    Support Maven
    Posted 9 years ago #

    It could be, it could also be a wpmu problem - I don't use wpmu so I have no idea how it is structured in the admin area.

  12. yaksox
    Member
    Posted 9 years ago #

    Hi I just started using wp, and just joined this forum, but I feel it worth mentioning -- what about the wp-content folder? Do you have its permissions set to 777? Does that gotta happen - or is 755 okay?

    I was having the same problem of images not showing but then I just did what that other guy said and it werked.

  13. electrolund
    Member
    Posted 9 years ago #

    I'm not having any luck uploading images via Ecto or MarsEdit either. Here's my images folder:

    http://70.84.25.242/~electro/blogs/wp-content/images

    (don't have my domain name server set up just yet).

    At first, I wanted the images to be in the root of /blogs/, but moved it to /wp-content/ on a whim. Neither work.

    What is the Destination folder all about?

  14. electrolund
    Member
    Posted 9 years ago #

    Nevermind, got it working. I followed WP's recommendation to the letter for the Destination folder and it's working now!

  15. mcyoda
    Member
    Posted 9 years ago #

    Hi guys;

    I also having a bit of trouble uploading photos either using ecto or the upload feature of Word Press.

    At first, I would get wrong file type.

    I went through and made sure the directories (what was recommended by WordPress), permissions (7777) and file types (with a space before and after) were set correctly.

    Now I get:
    Couldn't upload your file to _01..

    I've seen some references on this problem to editing the php.ini file. However. I'm using a commercial provider (SBC Yahoo) and can't seem to find this file anywhere in my installation.

    Any thoughts?

    -- Scott D

  16. mcyoda
    Member
    Posted 9 years ago #

    And I fixed it. This one was easy. I needed to create a tmp folder for php to work with (with 7777 permissions, of course). Hope this helps someone else. -- Scott D

  17. mark79
    Member
    Posted 9 years ago #

    Question:

    Is the wp-content directory safe to be marked 777 (permission)?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.