WordPress.org

Ready to get started?Download WordPress

Forums

Upload folder is not writable. Export and file upload features will not be funct (8 posts)

  1. Joe Siegler
    Member
    Posted 2 years ago #

    I recently moved several domains from an old server to a new one using Plesk's server migration tool. Everything seems to work, except I'm getting the dreaded error in WordPress:

    "Upload folder is not writable. Export and file upload features will not be functional."

    In reading around, most people claim it's permissions of the directory, but that's not it. I have that set properly. It was running right on the old server, and everything was copied over, and on the new box, the permissions are the same.

    What else could it be? I've tried changing ownership of the uploads directory around with chown to either apache:apache or a local account name (like most of the directories are). Can't get it sorted out.

    Anyone have any other ideas? Tkx.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  3. Joe Siegler
    Member
    Posted 2 years ago #

    I have already tried 755 and 777. Neither of those make a difference. I'll try the others when I get back home.

  4. Joe Siegler
    Member
    Posted 2 years ago #

    Tried 766, that instantly resulted in WordPress disabling all my plugins because it couldn't find them. GAH!

    Checking stuff related to file ownership now. I don't think it's permissions of directory.

  5. Joe Siegler
    Member
    Posted 2 years ago #

    Just noticed with no other changes if I turn OFF safe mode, this problem goes away.

  6. roxstyle
    Member
    Posted 1 year ago #

    i have the same message, but i do not know anything about these permissions, is there something simple to do within the wordpress admin interface? or do i need to ask my host?

  7. jglovier
    Member
    Posted 1 year ago #

    I just got this issue on my local development environment I added a plugin folder called "gravityforms" to the plugin directory.

    I tried deleting it, and when I did the message went away on page refresh. So I added it back into the plugins dir again to confirm, and sure enough the message appears on my dashboard again.

    Why would a plugin directory trigger this message?

    I tried running chmod -R 755 wp-content/plugins/gravityforms/ but that didn't affect anything.

    Suggestions?

  8. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    As per the Forum Welcome, please post your own topic. Your problem - despite any similarity in symptoms - is likely to be completely different.

Topic Closed

This topic has been closed to new replies.

About this Topic