WordPress.org

Ready to get started?Download WordPress

Forums

Upload error (67 posts)

  1. baardvidar
    Member
    Posted 6 years ago #

    OK, my crach was caused by the htaccess-file. My new revised htaccess worked for some hours, before I again encountered 500 Internal Server Error. I deleted the htaccess-file and all is well again. But I can't upload pictures...

    Any other ideas?

  2. Tammy Hart
    Member
    Posted 6 years ago #

    LSRN94's answer worked for me. Seems like a pretty big error to have to be hunted down and fixed like this...

  3. shini
    Member
    Posted 6 years ago #

    LSRN94 Thanks so much for the help, being a bit of a noob I got all confused how to add the

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    into the .htaccess file. So I'll explain for those of who are here for the blogging and not the backstage pass.
    If you have that Error #2044: Unhandled IOErrorEvent:. text=Error #2038: File I/O Error. with uploading your photos in WordPress, log into your ftp and you should find a .htaccess file. Download it, open it in Notepad or any code-editing application.
    Copy Paste the code between

    # BEGIN WordPress and # END WordPress

    save and reupload. It should work. At least it did for me...

  4. joehamilton
    Member
    Posted 6 years ago #

    ahhh!!! this is doing my head it!
    When i put the code suggested into the .htaccess file i just get a
    "500 Internal Server Error"
    I already have code in there for permalinks and also "RewriteEngine off" because it is a parked domain.

    This is what it looks like before adding the code suggested

    `
    RewriteEngine off
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress`

    I have tried putting it at the end and at the start and between the rewrite engine off and wordpress code. Nothings seems to work. 500 internal errors all round. :(

    anything else to try? anyone else having this problem?

  5. tanker
    Member
    Posted 6 years ago #

    My blog fixed itself when I turned off Bad Behavior. I tried the .htaccess fix, but it didn't work. I read somebody's message bout Bad Behavior and the problem went away.

  6. noise
    Member
    Posted 6 years ago #

    I'm having this problem as well - just get the error

    An error occurred in the upload. Please try again later.
    not sure why trying later would work - strange thing to add to a error message

    This is a development blog, so there's NO PLUGINS ACTIVATED, just a raw WP install

    I've got index's turned off in the root .htaccess and in the wp directory this is my .htaccess

    AuthType Basic
    AuthName "*****"
    AuthUserFile "/****/passwd"
    require valid-user
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    # END WordPress

    hope this get's fixed soon.

  7. JonasBang
    Member
    Posted 6 years ago #

    I'm all new to WordPress, just installed the 2.5 release.

    It works fine, but I can not upload any images. I get this error:

    HTTP error
    An error occurred in the upload. Please try again later.

    I have not added any plugins, it is a raw WP 2.5 installation.

    I created a .htaccess file and uploaded to my WP root dir:

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Still does not work :(

    If I wanna edit the .htaccess file, how do I do that? I can not see any .htaccess file with my FTP program (WS_FTP)?

    My WP installation are located directly on the top domain, i.e. not under a /wordpress/ folder.

    I hope someone can help, not much fun in a blog without any images.

    Br,
    Jonas

  8. JonasBang
    Member
    Posted 6 years ago #

    This solved the 'HTTP error' for me (see my problem and setup above) :
    Read this post

    My latest uploaded .htaccess file to root dir looks like this :

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Br,
    Jonas

  9. Zhu8
    Member
    Posted 6 years ago #

    @JonasBang
    Thank You Very much! Your .htaccess works in my wordpress!

  10. AldebaranJill
    Member
    Posted 6 years ago #

    I had this issue as well...and here's how I fixed it, I disabled the password protected directory setting I had on my blog's admin directory.

    Once that was deleted, the uploading worked fine. Hope this helps someone.

  11. mtbello
    Member
    Posted 6 years ago #

    I've tried all of the solutions presented, but no luck. I'm "allowed" to upload, but I get a blank photo. I can insert the photo into my post, by no image. Help! It seems for such a major issue, wordpress would create an official help document.

  12. Dharm
    Member
    Posted 6 years ago #

    I have the same problem as everone else: HTTP error when I try to upload an Image. All the Word press files are in a directory named latest which is at root level. What level is the .htacess file that is being talked about? There is an .ht access file at root level but there is not one in my wordpress directory. I tried creating one with the lines from JonasBangs post and uploaded it to the wordpress directory but after that I could not access anything, just got a 500 internal server error message. So I quickly deleted the file and at least all the other wordpress funtions are back. Can anyone give some very specific instrutions about this .htaccess file. should it be a new file or additional lines to an existing file and what directory should it be in?

  13. jmrobins
    Member
    Posted 6 years ago #

    None of the above fixes worked for me. I have found one thing that has worked though. I have not tested this "workaround" extensively, but it looks like my problem is related to the size of the picture. My original files are 2896x1944 and I get the HTTP error when trying to upload. If I resize it to 800x537, it works fine. Anyone else run into this or anyidea if there is a size limitation?

    Edit: I was just reading another post http://wordpress.org/support/topic/164999?replies=1 and pictures that are too big are a known problem.

  14. mtbello
    Member
    Posted 6 years ago #

    I'm frustrated. I've been researching this issue on and off for two weeks and I have not had any luck. I've tried all of the solutions
    presented in this post and numerous others.

    I'm using a mac 10.4.11, and firefox or safari (same exact issue with both).

    I have three WP installs in three directories on my site (the real production one and two to test things out). Two of the installs run 2.5.1 and the other is on 2.3. The real (production) install has all its files in a /wp folder, but has a copy of the index file in the root directory. I've even done multiple installs (deleted all the files and reinstalled everything.

    When I attempt to upload an image, it crunches, but no image is presented. It doesn't save a file. Here is a link to an image. I have adjusted and readjusted the permissions on the upload folder. I've even entered the full path on the misc. screen in the settings.

    I have multiple .htaccess files (one in each directory and one in the root. I've adjusted them all.

    Any suggestions would be appreciated.

  15. khelmrich
    Member
    Posted 6 years ago #

    We were having the HTTP Error problem, and when I tried disabling the Bad Behavior plugin, it worked!!! We can now upload pictures without a hitch. I tried that fix first, cuz I am defiantly not a techie person who can deal with codes and paths and all that jazz. (-= I can't suggest any other ways to fix the problem, but before you go changing things all over, just give this a try.

  16. mr_goosey
    Member
    Posted 6 years ago #

    I have tried ALL above solutions, with no joy.

    I am on Dreamhost and used their 1-click install. Get http error when the file 'crunches'.

    Have tried adding all suggestions to htaccess, no luck

    Have CHMOD'd correctly

    AGH

    Can anyone help

  17. pumpkinslayer
    Member
    Posted 6 years ago #

  18. mtbello
    Member
    Posted 6 years ago #

    My uploads are going to the wrong directory. They are magically ending up in the /wp-admin/wp-content/uploads folder instead of /wp-content/uploads. I've tried setting the full path on the Settings > Micellaneous tab, but they still end up in the wrong directory. I'm thinking this has something to do with it. Help.

  19. iamthechosenone
    Member
    Posted 6 years ago #

    I had a similar problem with my blog. Was fine until I upgraded to 2.5.
    If you have exhausted all other avenues, I would contact your host. My host (Hostgator) was blocking the upload of images for security. I had to tell them the location of all of my blogs so that they could remove the security feature. This worked perfectly.

    When I was getting the problem I was just getting "http error", but I know some people got "crunching" instead.

    It seems that the server was logging this message: mod_security: Access denied with code 403. Pattern match "^Shockwave Flash" at HEADER("USER-AGENT") [id "***MY ID"][rev "1"] [msg "SpamBot UA"] [severity "CRITICAL"] [hostname "***MY-DOMAIN***"] [uri "/testing/blog/wp-admin/async-upload.php"]

    Hope this helps you guys. I spent hours trying sugegsted fixes. I never would have guessed that it was a security issue with my host. After contacting them it was fixed within the hour.
    At first they argued that it was 3rd party software, but I told them that I had a test blog and I also had blogs on 2 servers and it was the same on all of them. They referred me to their higher level support and they fixed it within an hour.

    Let me know the outcome. dave@isnigh.com

  20. cableboy
    Member
    Posted 6 years ago #

    LSRN94: your htaccess modification worked. thanks!

  21. dpmcalister
    Member
    Posted 6 years ago #

    JonasBang you are a star. Thanks very much, your htaccess file worked perfectly for me :D

  22. mtbello
    Member
    Posted 6 years ago #

  23. allirath
    Member
    Posted 6 years ago #

    I have been working to solve this for weeks since I updated to 2.5.1. I get the HTTP ERROR, it crunches to the end and then there is a "Dismiss" and nothing has been uploaded. I've done everything that everyone suggested, and just completed this last link info for the plug in, too...NOTHING works. I talked to my server, and they can upload an image to my blog, but I cannot, not from my own computer, nor from any other computer, yet they can. I am at a loss, and I'm most frustrated. I've done everything on each of the posts...is there anyone else who has done all of this and still having a problem, or someone who has done it all and found another resolution? I am on a server by TotalChoiceHosting, and the blog is linked to my website. Any help would be more than appreciated. Thanks so much.

  24. indiblogger
    Member
    Posted 6 years ago #

    LSRN94 - Thank you!!

  25. selfmade64856
    Member
    Posted 6 years ago #

    allirath
    I am having the same problem, but only for 2 days. I click on the "Add Media" button and the window loads fine. I then click on upload file, either flash or browser upload version and everything is fine, it uploads, crunches, it even gives me the options such as "description" or "url link" and "size" and "alignment". I choose my setting or don't choose my settings, then click on "insert into post", it inserts alright, but there aint nothin there! I have tried all the modifications to the htaccess and a plug in for the error-image-fixer, and changed the permissions on the folders and files....etc. I will be talking to my programmer in about 8 hours, hopefully he will be able to figure out the problem. When he does I will be sure to have him post the solution on this thread. In the meantime, good luck to those that the above solutions didn't work, hopefully I'll have another fix that may help.

    Cheers!

  26. cashdreamzs
    Member
    Posted 6 years ago #

    Hey Guys,

    i followed LSRN94 advise and modified the htaccess file, now not only did it not fix the problem but when i surf to my blog it says internal server eror 500. So i tried deleting the code that LSRN94 gave but the error remains.

    what should i do now?

    my email is intell.inc[at]gmail[dot]com

  27. entapir
    Member
    Posted 6 years ago #

    Same thing happends to me. WP (2.5.1) doesn't seem to have a .htaccess-file, and when I add one, there is a internal error.
    I've tried to change the permalinks, and it works fine..but no .htaccess file anywhere

    i followed LSRN94 advise and modified the htaccess file, now not only did it not fix the problem but when i surf to my blog it says internal server eror 500. So i tried deleting the code that LSRN94 gave but the error remains.

    what should i do now?

  28. andresf91
    Member
    Posted 6 years ago #

    i don't have .htaccess in my hosting account, what can i do???
    tha plugin only adds what LSRN94 said to the .htaccess file in the root, but whether it's there or not, the error remains (which is something like "The file couldn't be moved to /www/my5gb.com/g/r/e/{my user account}/htdocs/wp-content/uploads.", it's similar to that cause i have installed the Spanish and that is re-translated to English.)
    Also, I tried chmoding the wp-content folder and the uploads folder, but didn't work anyways.

    I'm using WP 2.5.1, for the record.
    If anyone can help, thanks.

  29. johnathonwilliams
    Member
    Posted 6 years ago #

    @ AldebaranJill

    I could kiss you for this fix. I could absolutely kiss you. Two days I wasted on .htaccess mods and server tweaks. I even updated to the latest nightly build of 2.6 -- to no avail.

    Just to reiterate: Password-protecting your wordpress directory will result in the same HTTP error when attempting any file upload. Removing the password protection removes the error.

  30. extrakun
    Member
    Posted 6 years ago #

    I have the same error, but strangely, it works on IE but not on Firefox 2 or 3...any idea?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags