WordPress.org

Ready to get started?Download WordPress

Forums

Upload error (67 posts)

  1. eurekaa
    Member
    Posted 6 years ago #

    Hi ,
    I have installed the wordPress 2.5 on subfolder in my site ( http://www.*****.com/wordpress

    The word press is runing fine but i can not UPLOAD any image , I get the error message : HTTP error.

    I tried to set the uploads folder that located in wp-content folder to the permission 777 & 755 and the same error message continues ..

    I contacted my host and the told me that phpsuexec is runing on our server and better to ask the WORDpress support about the right permission for phpsuexec server

    Thanks alot

  2. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    word press is runing fine

    So you can post, etc. correct?
    What is your URL?

    You get this message: HTML error when uploading an image from the wp-admin/write screen?

  3. eurekaa
    Member
    Posted 6 years ago #

    my URL is
    http://www.dollarat.com/press

    From admin panel I go to WRITE tap in order to start new post , then i click on Upload image ICON next to the word ( Add Media ) , and then i started uploading with no success

  4. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    So you are browsing to a file, giving it a title and uploading it?

    Can you see your WP files on the server? You should have, under wp-content a uploads folder and under that an 03 folder.

    Sorry, and what kind of HTML error?

  5. eurekaa
    Member
    Posted 6 years ago #

    I can not give the file a title since its not uploaded .

    I borwes my computer to upload a file ( image ) and i get the error when it tries to upload the files .

    The error is : HTTP error

  6. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    The uploads folder should be 755. The 08 folder should be 755. The month (03) folder should be 777. AFAIK.

    Phpsuexec has caused problems in the past for some but I know nothing about it.

    Also Mod_Security on the server has caused problems with images.

    I would first guess server problem.

  7. Elfebel
    Member
    Posted 6 years ago #

    I had the exact same problem and solved it. I didn't have a .htaccess file in my wordpress folder, which seemed to be the problem.

    I wasn't sure how to make one, but remembered WordPress gives you an example when you try to change the permalink structure. So I copied the example (admin panel:settings/permalinks page) made a textfile called .htaccess and uploaded it to the main wordpress folder.

    Problem fixed. Uploads working again. Hope this works for you too.

  8. Zhu8
    Member
    Posted 6 years ago #

    It seems many guys have this problem..one is me.. hope it will be resolved in WP 2.5

  9. krassonkel
    Member
    Posted 6 years ago #

    Just found this thread while searching for a solution of exactly the same problem.
    For me it was a permission problem but I think that "HTTP error." is definitely the wrong description of it!

    Also, after uploading the image (when you can enter the title and so on), there is another error:
    Warning: realpath(): Unable to access /var/www/****/httpdocs/wp-admin/wp-content/uploads in /var/www/****/httpdocs/wp-includes/functions.php on line 1056

    The media directory is set to "wp-content/uploads" which works fine except for this error! Seems that it tries to do realpath() with the wrong base directory (the wp-admin dir, not the real base path)...

    Didn't search for this last error but I hope it will be noticed by someone before the final 2.5 release! (BTW it's 2.5 RC2 running here ;) )

  10. LSRN94
    Member
    Posted 6 years ago #

    Running 2.5 as of todays release (3/29). mod_security is on and the image uploader is not working for me.

    Image upload box opens fine. Clicking browse opens my PCs dialogue box to choose an image. When uploading the image (.."crunching"..) I get a pop up error box that says:

    Error #2044: Unhandled IOErrorEvent:. text=Error #2038: File I/O Error.

    Then WP gives me the message "An error occurred in the upload. Please try again later".

    From the server error log I see this:

    ==cb6c7746==============================
    Request: XXX.com 11.222.33.444 - - [29/Mar/2008:13:08:34 -0500] "POST /wp-admin/async-upload.php HTTP/1.1" 406 363 "-" "Shockwave Flash" - "-"
    Handler: application/x-httpd-php
    ----------------------------------------
    POST /wp-admin/async-upload.php HTTP/1.1
    Accept: text/*
    Cache-Control: no-cache
    Connection: Keep-Alive
    Content-Length: 29393
    Content-Type: multipart/form-data; boundary=----------GI3Ef1ei4KM7ae0Ef1gL6Ij5ei4gL6
    Host: xxx.com
    User-Agent: Shockwave Flash
    mod_security-message: Access denied with code 406. Error processing request body: Multipart: final boundary missing [severity "EMERGENCY"]
    mod_security-action: 406

    (domain name and IP edited out)

    Running on a nix system; apache 1.x, php 4.x

    mod_security is the culprit.

    Changing the .htaccess to turn off mod_security yielded no success either. Hosts that run mod_security will have no gallery love?

    bug?

  11. LSRN94
    Member
    Posted 6 years ago #

    After a bit of troubleshooting, adding this to the .htaccess file in my WP root worked:


    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Turns mod_sec off on the async-upload.php file.

  12. McPace
    Member
    Posted 6 years ago #

    Bless you LSRN94, after two hours of searching that one did the trick. Thanks

  13. karenedwards
    Member
    Posted 6 years ago #

    I'm getting the http error as well, but am not sure what content to include in my .htaccess file. I checked the permalinks page for the example elfebel mentioned but can't find it - if anyone could post the full code that should be in the .htaccess file I'd greatly appreciate it.

  14. karenedwards
    Member
    Posted 6 years ago #

    I also contacted my server and they said that these two errors show up repeatedly in the php server log for my site:

    [29-Mar-2008 15:46:03] PHP Fatal error: Call to undefined function image_downsize() in /home/.sites/111/site30/web/blog/wp-includes/post.php on line 2326

    [29-Mar-2008 16:13:03] PHP Fatal error: Call to undefined function wp_constrain_dimensions() in /home/.sites/111/site30/web/blog/wp-admin/includes/image.php on line 173

    help anyone??

  15. francispotter
    Member
    Posted 6 years ago #

    I had the same problem. Only by changing the permissions on the wp-content directory itself was I able to get around it.

    It appears that WordPress 2.5 stores uploaded files directly in the wp-content directory, NOT in the uploads subdirectory. So changing permissions on the uploads subdirectory (which I had tried first) did nothing.

  16. sacredpath
    Member
    Posted 6 years ago #

    If WP is storing uploads in the wp-content directory, that would be really stupid.

  17. Righton
    Member
    Posted 6 years ago #

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Worked like a charm... thank you.

  18. ShustOne
    Member
    Posted 6 years ago #

    @LSRN94:

    You are my hero. This should be in the FAQ. I've been messing with this since the 2.5 nightlies started coming out and did not find a solution until now.

  19. karenedwards
    Member
    Posted 6 years ago #

    @LSRN94
    Where do you put that code - is there anything else that should be in an .htaccess file or just that??

  20. rosicrux
    Member
    Posted 6 years ago #

    I have tried putting the above .htaccess file in my wordpress directory, and yet I still can't upload.

    There's a ton of threads on this, so I hope it gets resolved soon.

    edit: I found the culprit for me. I turned off the Bad Behavior plugin and was then able to upload freely.

  21. Richie KS
    Member
    Posted 6 years ago #

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    @LSRN94 - #permalink

    Thanks, this work like charm
    i've tried more than 5-8 method mostly from discussion here and this worked for my subdomain wordpress installation
    not sure how will it work in root domain tho..

    @my-step
    create directory uploads - chmod 775 - go to option in wordpress..save the permalink setting and it will create the htaccess and add the above line before end of # END WordPress

    again thanks..

  22. ombuene
    Member
    Posted 6 years ago #

    i have tried all the tips above, but still gets 'http error' - 'an error has occoured, please try again later' when trying to upload.

    i was stupid enough to upgrade without trying this first so i had to install a plugin-uploader, but i really hope for a solution on this...

    thanks.

  23. Bjooti
    Member
    Posted 6 years ago #

    I am having these problems as well, and none of the solutions above seem to work.

  24. eibhlin
    Member
    Posted 6 years ago #

    LSRN94's solution (above) worked for me... thank you, thank you!

    I also double-checked my CHMODs on all relevant wp-content folders, to be sure that I could write to them from WP.

    That combo seemed to work just fine. HUGE sigh of relief!

  25. sweetp
    Member
    Posted 6 years ago #

    When I try to upload an image, I get this:

    "The uploaded file could not be moved to"...

    My host has confirmed that Mod_Security is turned on and that they can't turn it off. The .htaccess solution did not work for me. Is there any other way around this or do I have to wait for another version of WordPress? Bummer!!

  26. Jeff1701
    Member
    Posted 6 years ago #

    The Bad Behavior plugin was the issue for me, but the .htaccess fix was also required.

  27. LostInBrittany
    Member
    Posted 6 years ago #

    I tried this one too, the .htaccess solution didn't work for me...

    Is there any "old-style" upload plugin I could use to keep adding images to my blog?

    Thanks in advance !

  28. zk0
    Member
    Posted 6 years ago #

    I had almost the same error in the final version of 2.5.

    All it said was "crunching" nothing else. I chmod my upload folder to 775 and added the htaccess code and now it works. :)

  29. baardvidar
    Member
    Posted 6 years ago #

    I'm not a techie, so I may be missing something, but I've had the same problem as everybody else (it seems), not being able to upload pictures. I followed LSRN94's tip about the Mod_Security, and everything worked fine... for a short while. After a while my whole WordPress installation just crashed. I had to do a whole clean install, deleting everything on my server a couple of times before I got it right.

    Now, the whole thing might not have had to do with the htaccess-file, but my error log was full of mentions of the htaccess and Mod_Security. Whatever the case, I contacted my server admin, and he gave me just one line to put into the .htaccess-file:
    SecFilterEngine Off
    I did that and everything has worked fine for me since. Hope this helps someone and confuses few...

  30. blais
    Member
    Posted 6 years ago #

    LSRN94's .htaccess gets rid of the HTTP error.

    but now i'm stuck with The uploaded file could not be moved to /home [...] wp-content/uploads/2008/04.98 or wp-content/uploads/.90 (when Organize my uploads into month- and year-based folders is off)

    what's .98 and .90?

    chmodding does nothing.

    help?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags