WordPress.org

Ready to get started?Download WordPress

Forums

Upload doesn't work (5 posts)

  1. Piotrek
    Member
    Posted 8 years ago #

    After upgrading 1.5.2 to 2.0 I have noticed a problem with uploading files. As I'm trying to upload something it says

    Unable to create directory /home/piotrm_ftp/userhome/public_html/wp/wp-content/uploads/2005. Is /home/piotrm_ftp/userhome/public_html/wp/wp-content/uploads writable?

    Unfortunately directory "uploads" IS writable (chmod 757). What's more I am not able to change its properties. WinSCP ( http://winscp.net/eng/index.php ) shows such a message when I’m trying to change chmod: http://piotrm.piasta.pl/pub/winscp.png . I've also tried to create manually directories 2005/12 but then WordPress gives quite strange message:

    The uploaded file could not be moved to .

    Can you say me why my FTP server does something wrong with the directory "uploads" and how to mange with it? I wrote about behavior of “uploads? to my FTP Admin, now I’m waiting for reply.

    Sorry for any mistakes in English, I'm still learning...

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    In 1.5.2 and before, you said "Here's my directory, put it all in there" and that's where your uploads went.
    It's changed.
    Now, when you upload, WP tries to create a directory in line with the year, and another inside that in line with the month:
    /2005/12
    /2006/01
    so if your host has set restrictions on the 'mkdir' command, this new feature does not work.

    If you have manually made those directories, ask your host.
    Also, ask them if they are running php in Safe Mode.

  3. Piotrek
    Member
    Posted 8 years ago #

    My WP has problem only with making year directory. It's necessary only to create "2005" manually and set chmod for it. Then WP creates "12" inside and shows message which is quoted above.
    I’ll ask my administrator again.

  4. Piotrek
    Member
    Posted 8 years ago #

    Also interesting is that plugin Image Browser ( http://fredfred.net/skriker/index.php/iimage-browser ) without any problems uploads and deletes files to/from that directories. :)

  5. marcusv
    Member
    Posted 8 years ago #

    I had the very same problem, but I also have a fix. Delete the uploads folder entirely via ftp. Then create it manually and make it writable, then inside the upload folder create the year folder for 2005 (and 2006) and make writeable, then create the month folders inside of these years (1-12) and make writeable. WP should allow uploads now. Bit of a hassle but it works until we can figure out the real problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags