WordPress.org

Ready to get started?Download WordPress

Forums

Upgrading WP catch-22 (2 posts)

  1. Saeed
    Member
    Posted 6 months ago #

    Hi, i'm sure this has been answered somewhere else, but I couldn't find the answer anywhere.

    Given my blog version (3.1.2) it's clear I haven't upgraded for a while. The reason is that the lag time between plugins and WP versions means that there are always some plugins that doesn't support the most recent version, and so I can't upgrade. And by the time the plugins are all up to date, a newer version of WP is released.

    i.e. I'd LOVE to upgrade to 3.8 or 3.7 even, but several plugins don't support them yet.

    What is the best strategy here? How can I stay up to date given this problem? Is there a doc that already explains this? If so, please point me to it.

    Thanks

  2. Pioneer Valley Web Design
    Member
    Posted 6 months ago #

    i.e. I'd LOVE to upgrade to 3.8 or 3.7 even, but several plugins don't support them yet

    Keep WordPress up to date at all times and use plugins that are also inline with WP. Not updating a site due to lack of plugin support is a huge security issue. Running WP3.1 at this time is one issue, running plugins from that version just stacks the deck... ... ...

Reply

You must log in to post.

About this Topic