WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Upgrading to WP 2.0 (103 posts)

  1. moshu
    Member
    Posted 8 years ago #

    MAK,
    how to set up a server is beyond the scope of this forum. We do not offer support for that kind of questions. You'd be better off to try to get help from some more specialized fora, where they deal mainly with that kind of questions. Sorry.
    When your server is up and you have problems with the install of WP 2.0 - feel free to post back.

  2. sithicus
    Member
    Posted 8 years ago #

    Are the differences between 2.0 RC3 and 2.0 Final listed anywhere?

  3. These are the Changesets that were submitted since the bump to v2.0-RC3 up to the bump to v2.0:

    http://trac.wordpress.org/timeline?from=12%2F26%2F05&daysback=6&changeset=on&milestone=on

  4. bchen
    Member
    Posted 8 years ago #

    I'm attempting an upgrade from wp 1.5.2, and when I run upgrade.php and go to step 1, I get some database errors that look like this:

    WordPress database error: [Invalid default value for 'comment_approved']
    ALTER TABLE em_comments CHANGE COLUMN user_id user_id bigint(20) NOT NULL default '0'

    WordPress database error: [Invalid default value for 'auto_toggle']
    ALTER TABLE em_linkcategories CHANGE COLUMN show_images show_images enum('Y','N') NOT NULL default 'Y'

    WordPress database error: [Invalid default value for 'auto_toggle']
    ALTER TABLE em_linkcategories ALTER COLUMN show_images SET DEFAULT 'Y'

    Any ideas?

  5. bchen
    Member
    Posted 8 years ago #

    After these errors, I continued on to the admin pages for my site, and it looks like things are more or less working, though I haven't really probed things.

    One thing I did notice is that the formatting is all messed up in Firefox, but not IE. Is this intentional? The expandable boxes are in the wrong places on the page and overlaps other text on the page.

  6. warchild
    Member
    Posted 8 years ago #

    The upgrade breaks xmlrpc.php compatability with ecto and MarsEdit. Specifically with file (images, media etc)
    Are there plans to resolve this?

  7. alsoevso
    Member
    Posted 8 years ago #

    I upgraded with no problems - I thought. The only issue I'm having is with my feed. I downloaded the new Feedburner plugin for 2.0 and ever since, feedburner gives me a 500 error when I try to click on my feed - http://www.allaboute.net/blog/feed. I've activated and deactivated plugins . . . I can't figure out what's going on.

  8. martin-english
    Member
    Posted 8 years ago #

    I downloaded and installed WordPress 2.0 today.

    * I donwloaded the zip file and extracted all the wp2.0 files,
    * created a new directory wp200 on my host,
    * uploaded all the wp2.0 files to the new directory,
    * copied my old wp-config.php file to the new directory,
    * copied my theme across,
    * even remembered to copy the .htaccess file (for the mods that enable permalinks).

    mmmm not working… time to RTFM….

    Once I ran the upgrade script (look at the readme.html under the wordpress directory in the zip file and search for Upgrade), the ‘copied site’ (under martin-english.com/wp200 ) worked nicely, except some of the links referred to …./whatsup instead of …./wp200. I then renamed the old site to wp152, renamed wp200 to whatsup and here we are !!

    I've slowly introduced the plugins AFTER the upgrade - i don't use many - and all three work.

  9. limey32
    Member
    Posted 8 years ago #

    Followed the guide.

    I get this after upgrading:
    "You do not have sufficient permissions to access this page."

    Have disabled the cache even tho thats not the problem. Still no dice. Any ideas? Want to upgrade other sites, but don't want same outcome.

  10. LisaLynne
    Member
    Posted 8 years ago #

    I'm not sure if this is the right thread, but it's the closest...

    I upgraded from 1.5 (I think) to 2.0. I don't have a problem with the install per se, but on my front page, I had a post marked private, and before, it didn't show up at all. After the upgrade - same theme, plugins, everything - it showed up for all and sundry to see. Currently I have it password protected so that no one can read it, but it's still marked private.

    Can anyone tell me why I might be having this problem, and what I can to to rectify it? I hate password protecting posts, because odds are later down the road I'll forget the password.

    Any insight would be greatly appreciated.

  11. timsen
    Member
    Posted 8 years ago #

    I have encountered a little Bug, too ...
    The Comments don't count up anymore! Ive made a new posting and it has 3 comments already, the frontpage says "No Comments" still, tho :-S

  12. Mark (podz)
    Support Maven
    Posted 8 years ago #

    This thread is being closed as it is confusingly long.

    If you have any problems, please start a thread of your own so that your problem does not get overlooked.

Topic Closed

This topic has been closed to new replies.

About this Topic