WordPress.org

Ready to get started?Download WordPress

Forums

Upgrading to less than 3.4.1 (5 posts)

  1. espressoguy
    Member
    Posted 1 year ago #

    Right now the Dashboard offers to upgrade my 3.0 site to 3.4.1. Is there a way to upgrade but not quite all the way to the latest?

    I need to upgrade a site from 3.0 but I cant yet upgrade all the way to 3.4.1. I need to upgrade only to 3.3.2 -without going the manual route. I want to use the automatic upgrader but just not all the way to 3.4.1. There must be a way to do this.

    How do I do it?

  2. I don't think that there's a way to do this with the automatic upgrader. You'll have to do this manually, but you should just upgrade to the latest - saftest and most stable - version. Keeping an older version is not safe.

  3. espressoguy
    Member
    Posted 1 year ago #

    I have changes that I know work with 3.3.2 (from another almost identical site). I don't know if they work with 3.4.1 and won't have the time to test/develop that code for a while. In the meantime, I need to upgrade to 3.3.2.

  4. Saeed
    Member
    Posted 1 year ago #

    It would make a lot of sense to provide an automatic upgrade to versions less than the current. i.e. to 3.2 or 3.3 (or 3.2.1 or 3.3.1 etc.)

    Why?

    Because there's ALWAYS a lag between plugin support for the latest version of WP. And by the time your plugins all have support, WP has a new version! It's a never ending story.

    But if I could automatically upgrade to a *slightly* less than current version, then I could regularly upgrade and get the benefit of the new features, security etc. and this cycle of plug-in compatibility lag would be broken.

    Right now, I'm stuck on 3.1.2 unless I go through a manual upgrade process, which I'm not confident in doing. i.e. the risk of messing things up by doing it manually is the problem.

    I seriously think Automatic should consider it. Even 3.3.x would be a great help if it could be done automatically.

  5. I seriously think Automatic should consider it.

    That's a common misunderstanding: Automattic is not WordPress. ;)

    Right now, I'm stuck on 3.1.2 unless I go through a manual upgrade process, which I'm not confident in doing. i.e. the risk of messing things up by doing it manually is the problem.

    I'm a big fan of people doing what they want to do, but by running an older versions you're limiting your self and will either run into theme/plugin incompatibilities or remain vulnerable to security exploits.

    If you perform a full file and database backup and know how to restore both from scratch then you can upgrade without fear. You can always put it back if something goes wrong.

    If you have to choose between keeping a plugin or theme or being secure then you should lose that plugin or theme. It's just not worth risking your installation.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.