WordPress.org

Ready to get started?Download WordPress

Forums

Upgrading to 2.8.6 (8 posts)

  1. jaygoodrich
    Member
    Posted 4 years ago #

    Has anyone had trouble performing the automatic upgrade from 2.8.5 to 2.8.6? I have been able to accomplish this until now. Any advice would be greatly appreciated.

  2. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    I have upgraded and did not get any issue to automatic upgrade as well as manual upgrade. If you face any issue then provide exact error so that get solution on it.

    Thanks,

    Shane G.

  3. MoonDog
    Member
    Posted 4 years ago #

    I just upgraded from 2.8.4 and it literally killed my site. Blank pages everywhere. I'm running a VDS with plenty of memory and bandwidth so that's not a problem. Perhaps I can uninstall 2.8.6 and revert back to 2.8.4?

    What are some of the common causes? Where are the most likely places to look for the errors that created the problem?

    Thanks.

  4. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    Check with these options:

    -.> Disable all the plugins with the help of FTP.
    -> Change your theme to default in order to rules out theme level problem
    -> Remove all unwanted code from htaccess

    Thanks,

    Shane G.

  5. MoonDog
    Member
    Posted 4 years ago #

    The theme isn't the problem and the only plugin that may be an issue is WP-Super-Cache. I don't want to disable that though. Would Squid Proxy or anything involving PHP or MySQL have anything to do with it?

    Thanks for your reply.

  6. MeredithX
    Member
    Posted 4 years ago #

    1. I updated to 2.8.6 a couple of days ago. Seemed to work, although it would be nice to be able to see which plugins are (possibly) incompatible first. (And, yes, I did a backup first.)
    2. Updated PHP 5 today to 5.2.6.dfsg (no idea what from, but at least a few weeks old) and it killed WordPress. WP couldn't find all sorts of WP files, like widgets.php.
    3. Nothing else is broken with the new PHP version, including some 7-year-old code that I'm afraid to breathe on.
    4. After tons of unbelievably painful echo debugging, I went back to 2.8.5. Copied my themes over, installed the needed plugins manually to ensure compatibility. All is now working fine.

    This is on a Debian Lenny Linux box, btw, running 2.6.24-xen.

    Grumble. Guess I'll be sticking with 2.8.5 for a while.

  7. MeredithX
    Member
    Posted 4 years ago #

    I forgot something important: I should have said that before reverting to 2.8.5, I DLed 2.8.6, and copied the relevant 2.8.6 files/folders over (a copy of) my broken copy. Same result.

    I should also have noted that it made it through a few plugins before spewing PHP error code on the page. And that resetting plugins didn't help, because widgets were whinging as well.

    Mebbe its just me? Or the stars? But I think I'll wait until the plugins I need are marked as compatible with 2.8.6 or something like that.

    I was trying to set up WPMU when the dreaded phone call came...

    P.S. Duh. Didn't notice the edit post. Sorry for the two entries, although I guess it's really clearer this way.

  8. skila
    Member
    Posted 4 years ago #

    I managed to sort it by using the file from this website - possibly an old upgrade class, but it worked.

Topic Closed

This topic has been closed to new replies.

About this Topic