WordPress.org

Ready to get started?Download WordPress

Forums

eShop
[resolved] Upgrading from a paleolithic version of Eshop, won't work (4 posts)

  1. Sabinou
    Member
    Posted 1 year ago #

    Hello, I'm upgrading a friend's blog, she was stuck with WP 2.9.2 and Eshop 4.1.0, she never dared do the updates herself, it's been... quite a while already.

    While WP upgraded itself smoothly, to my relative lack of surprise, upgrading Eshop from 4.1.0 to 6.3.3 apparently broke the plugin, or part of it at least.

    The website is cactusargan.com, and one of the product pages is : http://www.cactusargan.com/?page_id=3675
    (You'll see a working sales page, I restored a backup with already WP3.5 but still Eshop 4.1.0's files and database)

    Simply, when opening a page with a product on sale, there isn't a single mention anymore of commercial operations : price, stock, adding to cart. Only remains a "0 items in the basket" in the top of sidebar.

    Frankly, if it were a small upgrade between two close versions, I'd have known where to search, but, here, Jebus, I don't have a single clue. I can't reinstall from scratch, the website already has a product and consumer base.

    Please, would you know, maybe, where I could start, or how, to find how to fix that issue ?

    Thank you :)

    http://wordpress.org/extend/plugins/eshop/

  2. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    Simply, when opening a page with a product on sale, there isn't a single mention anymore of commercial operations : price, stock, adding to cart. Only remains a "0 items in the basket" in the top of sidebar.

    Is that the only issue? if so then that's pretty good for upgrading from such an old version. And that might not even be an issue, check the settings page - those items are now bundled together to make things easier for you.

    Though on re reading I'm not 100% sure, for the add to cart, edit the page and check the details are correct.

  3. elfin
    Moderator
    Plugin Author

    Posted 1 year ago #

    Try checking the readme, and the readme.history it will tell you which version you can safely upgrade from 4.1.0 to.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    As there has not been an update to this topic for a while, I can only assume that the issue has now been resolved and I am now marking it as such. If this is incorrect, please feel free to change the topic's status and/or post a followup.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.