WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upgrading from 2.5.1.to 2.7 - wp-load.php error (4 posts)

  1. lpeterson@amda.com
    Member
    Posted 5 years ago #

    Please help. My predecessor setup our site and I am unfamiliar with PHP or how our files/directories were setup but I gather the standard defaults were used. I was attempting to do the upgrade (2.5.1 to 2.7) through the WP wizard and received the errors below. I see others have had similiar problems but I'm unclear of the resolution. Is the wp-load.php in the wrong directory? It currently resides in(/public_html/wpau-backup/wordpress/wp-load.php) and I copied it to (/public_html/wp-admin/wp-load.php) but still received the error message.

    Any help would be appreciated. Please deliver in novice language. Thx!

    Error
    Warning: require_once(../wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /home/guhhfbqk/public_html/wp-admin/admin.php on line 19

    Fatal error: require_once() [function.require]: Failed opening required '../wp-load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/guhhfbqk/public_html/wp-admin/admin.php on line 19

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    I was attempting to do the upgrade (2.5.1 to 2.7) through the WP wizard

    I don't know what the "WP Wizard" is, but whatever it did, it failed to put all the new files onto your site.

    Do the upgrade manually. And make sure that you upload ALL of the WordPress 2.7 files to the site.

  3. lpeterson@amda.com
    Member
    Posted 5 years ago #

    Thank you. It's working.

  4. billh
    Member
    Posted 4 years ago #

    Change the line

    require_once('../wp-load.php');

    to

    require_once( ABSPATH . 'wp-load.php');

    I have to change this line with each upgrade. My error shows up in the file update-links.php.

Topic Closed

This topic has been closed to new replies.

About this Topic