WordPress.org

Ready to get started?Download WordPress

Forums

Upgrading From 2.07 to 2.1 (11 posts)

  1. lisar915
    Member
    Posted 7 years ago #

    Hi,

    I just tried upgrading to WordPress 2.1 from version 2.07. However, when I tried running the upgrade, I got the following error message:

    WordPress database error: [You have an error in your SQL syntax near '.* FROM wp_posts WHERE 1=1 AND (post_type = 'post' AND (post_status = 'publish' at line 1]
    SELECT SQL_CALC_FOUND_ROWS wp_posts.* FROM wp_posts WHERE 1=1 AND (post_type = 'post' AND (post_status = 'publish' OR post_status = 'future' OR post_status = 'draft' OR post_author = 1 AND post_status = 'private')) ORDER BY post_date DESC LIMIT 0, 10

    WordPress database error: [You have an error in your SQL syntax near '()' at line 1]
    SELECT FOUND_ROWS()

    Would anyone know what I'm doing wrong?

    Thank you very much.

    Lisa

  2. foolswisdom
    Moderator
    Posted 7 years ago #

    Hi Lisa,

    What version of MySQL is on your host? WordPress 2.1 requires mySQL 4.0 and should stop an upgrade if it does not have the required version.

  3. daveamun
    Member
    Posted 7 years ago #

    Is requiring MySQL 4.0 new for 2.1? Could be a while before I get to upgrade :-{

  4. vkaryl
    Member
    Posted 7 years ago #

    I believe so.... most hosts seem to be running something in the area of 4.1.21.

  5. jpozadzides
    Member
    Posted 7 years ago #

    This is a seriously frustrating issue. My server is running a 3.X version of MySQL, which worked perfectly fine with every version of WordPress up till now.

    Obviously the requirement was switched to 4.X+ for the 2.1 release and it did not state that change anywhere on the upgrade documentation.

    This is a MAJOR oversight and it caused a lot of headache here for me.

    Someone needs to very quickly add a clear note about the database requirement change to spare all the others out there this pain. Also, it would be helpful if we could get access to the 2.0.7 download again.

    John

  6. Trent Adams
    Member
    Posted 7 years ago #

    Sorry to hear that jpozadzides. My host recently upgraded to mySQL 4.1.21 and that was a bit of a fight to get them to. I was already having issues with plugins that people were writing.

    In terms of the download link for 2.0.7, you may have to wait for someone else to provide a link because even the http://static.wordpress.org/ only has up to 2.0.2. I would provide a download link myself, but as luck would have it, I only have 2.0.6 (security risk version).

    Trent

  7. Obvious
    Member
    Posted 7 years ago #

    The minimum requirements for WordPress were updated in the Codex:

    http://wordpress.org/about/requirements/

    No need to blame someone about that except you.

    Missing former WordPress versions since 2.0.2 is known to every developer because it was mentioned several times on the hackers mailing list. Obviously this doesn't mean that they fix this in the near future. Send an mail to the hackers mailing list (http://comox.textdrive.com/pipermail/wp-hackers/) to emphasize this issue.

  8. Stephanie Leary
    Member
    Posted 7 years ago #

    Obvious: the change was not mentioned in the change log, which is where I looked for such information.

  9. spencerp
    Member
    Posted 7 years ago #

    sillybean, they are still working on updating the Codex and other places to reflect the NEW 2.1 stuff. In time, there will be new informations regarding the 2.1 stuff. ;):)

    If you want to upgrade to 2.1 please follow these instructions. Also, please make sure ALL of your plugins are compatible with 2.1.

    If they are not listed here, you might want to disable them, that's only if they give you problems. And then contact the plugin author, letting them know to update their plugins.

    And make sure you have MySql version 4.0.0 or higher! If you do not have MySql 4.0.0 or higher, you won't be able to upgrade to 2.1!

    Good luck!

    spencerp

  10. daveamun
    Member
    Posted 7 years ago #

    There is (still) nothing in the instructions stating that the requirements (for MySQL) have changed. I searched the forum to see if others were having problems and luckily found the post from foolswisdom in response from lisar915.

    Other than that ... great work :-) Works fine on my xampp installation. Waiting for my service provider to change servers for my account.

  11. lisar915
    Member
    Posted 7 years ago #

    Thanks for answering my question so quickly. And I'm sorry I haven't responded to thank you guys earlier. It's just that I am now having more complications with version 2.1. My host agreed to install MySQL 4.0, and he installed version 2.1 for me. However, all of my users comments have not disappeared. I can't even post test comments on my blog! Also my name does not show up under my posts. Would anyone know why this is?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.