WordPress.org

Ready to get started?Download WordPress

Forums

Upgrading different versions (6 posts)

  1. d0nthedragon
    Member
    Posted 3 years ago #

    Hi guys! It's my first time posting here so I'm not really sure if my question has been asked before. Here it goes. We have 6 instances of WP ranging from 2.62 - 2.85 on a vmware solaris server. We're about to upgrade our hardware and move in to a windows environment. Can someone give me an idea if it's pretty much the same steps documented on this site for upgrading even though we're moving from a solaris environment to a windows one? Can we upgrade to the latest release right away or do we have to do incremental upgrades?

    Thanks in advance!

  2. James
    Happiness Engineer
    Posted 3 years ago #

    I recommend upgrading first, then move everything following this guide:

    http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_to_a_New_Server

    Everything above WP 2.7 can be upgraded with the automated upgrader. If your version of WordPress is below 2.7, you'll have to download WordPress 2.7 and do a manual upgrade, then use the automated upgrader.

  3. Gisha James
    Member
    Posted 3 years ago #

    Can we upgrade to the latest release right away or do we have to do incremental upgrades?

    You can upgrade to the latest release right away no need ofincremental upgrades.

  4. James
    Happiness Engineer
    Posted 3 years ago #

    You can upgrade to the latest release right away no need ofincremental upgrades.

    It's best if you can get to 2.7 first before going straight to 3.0.1. I've encountered a few oddities doing manual upgrades from 2.6 to 3.0 and 2.5 to 3.0. Generally, upgrading across more than 3 major releases is not recommended around here.

  5. Gisha James
    Member
    Posted 3 years ago #

    It would be nice if it is coded here: http://codex.wordpress.org/Upgrading_WordPress_Extended

    There, I saw, I can upgrade from 2.6 to the latest.

    or Am I blind that I missed it?

  6. James
    Happiness Engineer
    Posted 3 years ago #

    Am I blind that I missed it?

    No, you aren't blind. It definitely isn't mentioned there, probably just an oversight. I've added a recommendation to the page.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags