WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upgraded to WordPress 3.5 problem (29 posts)

  1. mbenatar
    Member
    Posted 1 year ago #

    Hello,
    I upgrade to 3.5. I have no control over widgets in widget section. I am using Suffusion.

    Any ideas?

    Marten

  2. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Please read the sticky about 3.5

    It has a way to check for javascript conflicts which is most likely what is happening.

  3. mbenatar
    Member
    Posted 1 year ago #

    What is a sticky?

  4. Sergey Biryukov
    WordPress Dev
    Posted 1 year ago #

  5. mbenatar
    Member
    Posted 1 year ago #

    I appreciate the info however, it doesn't help me. That is no solution that I understand.

    Marten

  6. xecutable
    Member
    Posted 1 year ago #

    I have followed the instructions and I've got this:

    Timestamp: 12/12/2012 05:11:03
    Error: TypeError: e is undefined
    Source File: http://xxxxxxxxxxxxxxxxxxx.org/wp-admin/load-scripts.php?c=0&load=jquery,utils&ver=3.5
    Line: 2

    How do I fix it now?

    BTW to find your own error. Open the Widget page with Firefox. Got to Tools -> Web Developer -> Error Console -> Click on the Error tab.

  7. xecutable
    Member
    Posted 1 year ago #

    Figured it out. A plugin was causing this issue. Disabled it for now.

  8. mbenatar
    Member
    Posted 1 year ago #

    Plugin Widget Logic Visual. Deactivated. Problem solved.

    Thank you.

  9. lewatson
    Member
    Posted 1 year ago #

    Thank you @mbenatar.

    Deactivating Widget Logic Visual resolved the loss of widget control for me as well.

  10. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Can you please post a link to the widget?

  11. mbenatar
    Member
    Posted 1 year ago #

  12. affordablewebs
    Member
    Posted 1 year ago #

    I tried it all and nothing worked. I am not able to click on 'insert media', view the text tab, nor click on the widget areas of the widget page. I've disabled all plugins (and I only have two added: nextgen gallery and wp maintenance mode).

  13. mbenatar
    Member
    Posted 1 year ago #

    Try deleting the plugins.

  14. affordablewebs
    Member
    Posted 1 year ago #

    When I tried deleting nextgen I got this error:
    Fatal error: Using $this when not in object context in /home/content/29/5993229/html/otr/wp-content/plugins/nextgen-gallery/nggallery.php on line 540

  15. Deleting or deactivating?

  16. affordablewebs
    Member
    Posted 1 year ago #

    Deleting and saying yes, remove all files

  17. mbenatar
    Member
    Posted 1 year ago #

    Delete them. If that doesn't work you can always reinstall them.

  18. affordablewebs
    Member
    Posted 1 year ago #

    I understand. My follow-up was that I got a fatal error (white screen) when trying to delete. Should I delete from ftp, file manager?

  19. mbenatar
    Member
    Posted 1 year ago #

    You can create a folder in ftp to put the plugin files in temporarily to see if that resolves the issue.

    Did you try switching to another theme to see if it is theme related.

  20. It could be whitescreening if your theme author hardcoded some dependencies on NextGen (as some sillier ones do) -- just change to twentyeleven or twentytwelve and give that a go to get things straightened out.

  21. affordablewebs
    Member
    Posted 1 year ago #

    Ok, George, I switched to twenty ten and the widget area works. I'm able to view the text tab.
    But now what, lol?! Do I go back to my desired theme?

  22. affordablewebs
    Member
    Posted 1 year ago #

    **Update: When I tried deleting the nextgen with the twenty ten theme active, I still got the white screen.

  23. Okay, so it's the theme causing the issue.

    Your next step is to contact the Theme Author and see if they have an update to remedy the issue.

  24. affordablewebs
    Member
    Posted 1 year ago #

    Ok; thanks

  25. affordablewebs
    Member
    Posted 1 year ago #

    Meanwhile, is there a way to go back to the former version of WP?

  26. affordablewebs
    Member
    Posted 1 year ago #

    Thank you, George! I appreciate it.

  27. xecutable
    Member
    Posted 1 year ago #

    Those that are disabling plugins there will be an include line in the main plugin file:

    wp_register_script( 'sct_jquery_datepicker_slider', plugins_url('jquery-ui-1.8.13.custom.min.js', __FILE__));

    This will vary from plugin to plugin, as mine is called SCT, but as you see this is an include for a custom jquery file. I just removed it and problem solved ;).

    Credit goes to the developer that helped me out.

  28. hoosoft
    Member
    Posted 1 year ago #

    Yes, I got the same problem, here is the solution to fix this issue
    http://www.hoosoft.com/blog/fix-jquery-1-8-3-error-typeerror-e-is-undefined-in-wordpress-3-5/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags