WordPress.org

Ready to get started?Download WordPress

Forums

Upgraded to WordPress 2.8.4. Blog has disappeared (7 posts)

  1. askjack100
    Member
    Posted 3 years ago #

    My webhoster provides an automatic upgrade of WordPress within the accounts site manager. However, WordPress 3.0.1 is not yet available there, so I just upgraded from WordPress 2.5.1 to 2.8.4, which is the latest version available.However, after the update, my blog posts have dissapeared from the main blog page and category pages. Only the link to the first post on each page appears. Clicking the link does take me to the full article, though.

    The posts can be edited with the WordPress Admin area, so they are there, but they are not showing on the blog. My blog site address is visible here whe you click on my username.

    Thanks for any help.

  2. Your hosting service is very negligent in security for not offering 3.1. Upgrade yourself: Upgrading WordPress « WordPress Codex

    See Template Tags/the content « WordPress Codex and Template Tags/the excerpt « WordPress Codex Your theme must be displaying excerpts instead of full posts.

  3. askjack100
    Member
    Posted 3 years ago #

    Tank you, Sondogtech. I'm trying to edit the index page code of the them to solve th eproblem, but I'm not adept enough with php. There was a plugin (The_Excerpt_Reloaded) installed and I eliminated the function call to that in the code. Now the posts display, but only the title link, not the actual article text. I have edited the them index code so it now looks like:

    *begin code excerpt......*

    [Code moderated as per the Forum Rules. Please use the pastebin]

    *........end code excerpt*

    I'm having trouble finding where the problem is and why the posts don't display.

  4. Don't paste huge chunks of code as per the Forum Rules - use the WordPress Pastebin

    First, undo everything you did and deactivate the plugin. You're not going to get very far modifying the plugin and theme files if you don't know php very well. Switch to the default theme and see if the full content works.

  5. askjack100
    Member
    Posted 3 years ago #

    Songdogtech, my apologies regarding pasting code. I'm a newbie and should have read more before posting, but I needed to get this desperate situation fixed.

    I have switched to the default theme and the posts have all returned.

    Am I to gather that the best course now is to begin anew from here and reconfigure the blog using whichever new theme I prefer and then add plugins as necessary?

  6. Choose a new theme or go back to a new copy of the original theme; try excerpt/content plugins, and if needed, modify the template tags to support full posts.

  7. obscure
    Member
    Posted 3 years ago #

    It may be that the theme you used isn't compatible with the newer WordPress (or that you made previous changes which rendered it incompatible). Go to the theme home page to see if an update is available.

    Alternatively pick a theme like Thematic (http://themeshaper.com/thematic/ which can easily be changed by creating a Child Theme - check out their support forums http://themeshaper.com/forums/.

Topic Closed

This topic has been closed to new replies.

About this Topic