WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upgraded to 3.8: Visual editor buttons not showing (24 posts)

  1. Brian Saycocie
    Member
    Posted 7 months ago #

    I'm having an odd issue with my staging site. The visual editor buttons aren't showing, however the buttons on my text editor is.

    On my local site, I'm able to see buttons on both.

    I tried importing my local database into my staging database. Still doesn't work.

    I'm using Git as my source control, which has the core files included in the repo. Both environments should have the same code.

    Thoughts?

  2. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Do you mean the visual editor tab? Or the buttons in the visual editor?

  3. Brian Saycocie
    Member
    Posted 7 months ago #

    The buttons in the visual editor.

  4. serpentskiss
    Member
    Posted 7 months ago #

    See my post asking for answers on this at http://wordpress.org/support/topic/broken-by-design-wordpress-missing-admin-icons-and-tracking-cookies?replies=1

    It's a Yahoo tracking cookie that needs to be set

  5. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    In all browsers?

  6. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    @serpentskiss - I've not seen anyone else with this issue - sounds local to your site.

  7. serpentskiss
    Member
    Posted 7 months ago #

    @WPyogi - You are wrong. So wrong. Try it yourself. Try googling for missing WordPress admin icons.

    "Local to your site" is such a cop-out answer

  8. Brian Saycocie
    Member
    Posted 7 months ago #

    @serpentskiss - I looked at it incognito, didn't work...

    @WPygoi - Weird... looks like its working in Firefox, but not in Chrome. But my local environment works in Chome.

  9. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Try clearing any cache and cookies in Chrome.

    @serpentskiss - this isn't your thread - please discuss further in your thread.

  10. serpentskiss
    Member
    Posted 7 months ago #

    Permissions on image files? Does the 'other' octet have read permissions so the httpd process (the web server) can read them?

  11. Brian Saycocie
    Member
    Posted 7 months ago #

    My fault... its not working in Firefox, I was looking at my local environment.

    Tested it in Safari and its not showing up there either.

  12. Brian Saycocie
    Member
    Posted 7 months ago #

    Also, its my client noticing it as well.

  13. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Have you tried deactivating your plugins and switching to a default theme to see if that changes anything?

    Can you post a link to that site?

  14. Brian Saycocie
    Member
    Posted 7 months ago #

    Oh I think I found the issue.

    From this editor.min.css:

    .tmce-active .quicktags-toolbar {
         display: none;
    }

    I changed it to display block on my Chrome dev tools and now it shows.

  15. Brian Saycocie
    Member
    Posted 7 months ago #

    Actually nevermind... its displaying the text editor buttons only.

  16. Brian Saycocie
    Member
    Posted 7 months ago #

    Sorry for going back and forth...

    Anyways, here is the issue:

    After inspecting the markup, I'm missing the <span class="mceEditor"> element. And just realized my content isn't showing in the editor as well.

    I'll try disabling my plugins.

  17. Brian Saycocie
    Member
    Posted 7 months ago #

    Disabled my plugins, issue is still there. Its missing the mceEditor element.

  18. Brian Saycocie
    Member
    Posted 7 months ago #

    Also, switched my theme to twentytwelve, still not showing.

  19. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Try downloading a new copy of WP to your local machine and then replacing all files and folder except wp-content, wp-config and .htaccess from the new copy. Make sure you delete the old versions first.

  20. Brian Saycocie
    Member
    Posted 7 months ago #

    I tried replacing just the wp-includes folder with a new copy and that worked!

    Thank you @WPyogi!!

  21. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Excellent :)!

  22. marcreck
    Member
    Posted 6 months ago #

    Just solved this thanks to a tip from inmotion hosting support (after trying the other suggestions id read of disabling all plugins, reinstalling wordpress manually and changing to a different theme)

    Go to users >> profile, disable the visual editor, click save, then re-enable and click save again. Worked for all of my 5 sites. \o/

  23. BTCoombs
    Member
    Posted 5 months ago #

    Thank you marcreck! I've spent hours trying everything under the sun. Tried your fix and everything is back to normal. Not sure how that button became selected in the first place.

  24. azizddf
    Member
    Posted 3 months ago #

    thanks all my prob also solved appreciated

Reply

You must log in to post.

About this Topic