WordPress.org

Ready to get started?Download WordPress

Forums

Upgraded to 3.5, Text Editor Doesn't Work (10 posts)

  1. chufang
    Member
    Posted 1 year ago #

    Problem:
    I used WordPress Automatic Upgrade plugin to update my WordPress to version 3.5, then after that when I tried to create new post with an image, I am able to upload the image into the Media Gallery, but nothing happens when I click Insert into post to try and insert the image into the post.

    Nothing happens as well when I click on the Visual and Text tabs to try and toggle between the two.

    Browsers: Chrome, Firefox and Internet Explorer 9

    Troubleshooting Steps:
    1. Updated Theme
    2. Updated all Plugins
    3. Turned off all Plugins
    4. Changed Theme to Twenty Ten
    5. Turned on all Plugins
    6. Changed Theme back to the one I was using before
    7. Enabled SCRIPT_DEBUG - Issue is fixed

    JavaScript error from Chrome
    Uncaught TypeError: Cannot call method 'add' of undefined post.php:1602
    (anonymous function) post.php:1602
    (anonymous function) post.php:1632

    JavaScript error from IE9
    SCRIPT5007: Unable to get value of the property 'add': object is null or undefined
    post.php?post=1862&action=edit, line 1601 character 5

    JavaScript error from Firefox
    Error: TypeError: DOM.events is undefined
    Source File: http://lala.sg/wp-admin/post.php?post=1862&action=edit
    Line: 1601

  2. Roogoyle
    Member
    Posted 1 year ago #

    I am having the same problem...it was fine before our holiday break but is not working in the same way: cannot upload media, toggling between visual and text does not work!

  3. Tom Greenwood
    Member
    Posted 1 year ago #

    Yep, one of our clients sites has this same problem. Anyone know what is causing it?

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    You should create your own threads on the issue, posting me-too comments don't contribute to the original poster.

  5. How far did you get on the 3.5 Master List?

    Also I can't help but read this part by the original poster:

    7. Enabled SCRIPT_DEBUG - Issue is fixed

    Javascript errors are discussed in that master list.

    Oh yeah, and please start your own thread instead of jumping on someone elses. ;)

    Edit: Ha! Andrew beat me to it.

    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    It really is the best way for you to get support for your problem. The symptoms may be similar but the specific causes usually are not.

  6. Tom Greenwood
    Member
    Posted 1 year ago #

    Sorry Andrew, I'm simply highlighting that chufang is not the only one with this problem. No point creating another thread for the same issue when there is nothing specific that differs.

  7. No point creating another thread for the same issue when there is nothing specific that differs.

    Nope, sorry that's wrong.

    Unless your clients are using the same theme, same server, same plugins then they are having a different issue.

    Start your own thread, provide your own details and specifics and perhaps a volunteer like yourself will be able to help you out.

  8. chufang
    Member
    Posted 1 year ago #

    Actually, when I was using my usual theme, and TwentyTen, the problem persisted, so I think the theme wasn't a contributing factor.

    I don't mind me-toos in my thread, but why is it that responses providing solutions are missing?

  9. I don't mind me-toos in my thread, but why is it that responses providing solutions are missing?

    I'm guessing it's because you wrote this

    Enabled SCRIPT_DEBUG - Issue is fixed

    It's a little unclear that you have a problem when you used words like "fixed". ;)

    What's the URL to your site? How far did you get on the 3.5 Master List?

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    When you get JavaScript issues it could be a few things. It's why we insist that people start their own threads, your symptoms are similar but unless they're also on your server and are running the same theme and exact same plugins then it's not the same.

  10. chufang
    Member
    Posted 1 year ago #

    Yup, the troubleshooting steps were the steps I've gone through, and issue was fixed at step 7, so following up on step 7, I've provided the error descriptions from the various browsers as advised.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags