WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Upgraded to 3.2 Visual editor buttons missing (62 posts)

  1. bytheseaside
    Member
    Posted 3 years ago #

    Been having the same problem - FWIW - I use the WP-Optimize plugin - ran it & also reloaded 3.2 - all working fine now.

    Whether the two are connected, no idea ;-)

  2. kuzjnvn
    Member
    Posted 3 years ago #

    install json for php , i do that and now everythings ok !

  3. timchorlton
    Member
    Posted 3 years ago #

    HI AprilRobin,

    I've just fixed this problem on my blog and all seems to be working again.

    The Tiny MCE is looking for a file: wp-includes/js/tinymce/langs/en.js

    I just checked the file and on my installation the file path is this: wp-includes/js/tinymce/langs/wp-langs-en.js

    I deleted the 'wp-langs-' part of the file name 'wp-langs-en.js' and I seem to be working again.

    Let me know if this works for you.

  4. makeupchica
    Member
    Posted 3 years ago #

    I had a great guy tell me this:

    Download CKEditor. It works. I have a new and improved visual editor!

    And I am a zero code efficient girl.

  5. Jason
    Member
    Posted 3 years ago #

    NextGen Gallery appears to be causing an issue for me on a few sites. Disabling it brought back the visual editor.

    Corretion - I think it is actually to do with my serving static files from a different domain.

  6. Ronald
    Member
    Posted 3 years ago #

    Tried everything suggested here, but nothing worked. Removed 3.2 and reinstalled 3.2 and now the visual editor is back. just to see if it is an issue with the upgrade I'll install 3.14 and then try the upgrade again.

  7. rt2null
    Member
    Posted 3 years ago #

    timchorlton - tried your suggestion on a new install of 3.2 and did not have success.

    I started a new thread as my issue was not due to an upgrade - but verified the upgrade did not work as well (new install of 3.1.4 worked but failed once upgraded to 3.2)

    My post

  8. Ronald
    Member
    Posted 3 years ago #

    OK - The upgrade from 3.14 to 3.2 worked this time, actually twice - once with no plugins and once with all the plugins installed. That was on one site. So I thought maybe the reason for the issue with the visual editor to transitioning the upgrade properly might have been due to a plugin that hadn't been upgraded.

    I tried the upgrade on another site with all of the same plugins as the first site and all the latest versions of plugins. The upgrade worked. I tried the upgrade on a third site and again all plugins the latest version, this time the upgrade caused the same issue and it no longer has a visual editor.

    Back to square one - looking for a pattern if there is one. Each site has a different theme but each site had the same plugins.

  9. nhowarth
    Member
    Posted 3 years ago #

    I also had the problem of the visual editor buttons vanishing and white text in the edit area after the upgrading to 3.2 - and I noticed a couple of other issues:

    - the arrows on the buttons in the widget area had disappeared.

    - Some of my sidebar plugins failed to work on individual posts and pages (although they worked on the front page and category pages).

    I was about to follow the advice given earlier and do a manual install. But before doing so, I re-installed the 3.2 update and all the problems went away.

    It maybe worth reinstalling the update again to see if it resolves the issues before going through the lengthy process of manually reinstalling.

  10. Ronald
    Member
    Posted 3 years ago #

    If I rename the wp-includes folder and then upload the folder and all files in it, the issue is fixed. Haven't figured out why or what file in the wp-includes folder was missing or corrupted and causing the issue though.

  11. xxxxbyte
    Member
    Posted 3 years ago #

    OK, I've found the solution to the problem.

    You have to change permissions (chmod) if you can.

    By default some files get de 600 permission when you update WordPress to 3.2
    You have to change it to 644.

    What files? Well, I've found quite a few in these folders:
    /wp-admin/images/
    /wp-admin/js/
    /wp-includes/js/tinymce/themes/advanced/img/
    /wp-includes/js/tinymce/themes/advanced/

    Remeber to empty all caches (browser included) after the change of the permissions.

    Sorry for my bad english :)

  12. tomeone
    Member
    Posted 3 years ago #

    I'm having a similar issue, although I do see the buttons and all, the visual editor text box appears as the HTML one, so I'm not getting visual editing at all.

    I'm guessing my issue pertains to what has been discussed in this thread.

  13. danielwiener
    Member
    Posted 3 years ago #

    Ever since upgrading to WordPress 3.2, the Visual Editor does not work for Pages and Posts on one of my sites. Also the Admin Bar does not appear on the Post/Page Edit pages. To try to fix the problem I have done everything mentioned on this thread:
    http://wordpress.org/support/topic/upgraded-to-32-visual-editor-buttons-missing

    The site with the trouble is using mySql 5.0.90 and PHP Version 5.2.12. However everything works fine on my local dev site with exactly the same plugins and theme where I am using MySql 5.5.11 and PHP Version 5.2.9
    ---
    I have deactivated all plugins.

    I have un-installed some mu-plugins.

    I have reinstalled 3.2 automatically and manually.

    I have checked all permissions for files in the root folder, wp-admin and wp-include folders and they are all correct.

    I have changed the theme to TwentyTen and TwentyEleven.

    I have emptied my cache each time after making a modification.

    And I have tried numerous other solutions suggested.
    ----
    There are some screenshots here, so you can see exactly what I mean.
    ----
    I would really like to solve this. I am very conscientious about upgrading wordpress and upgrade all my sites at every version. This is the first time I have had a major problem.

  14. Sarah Anderson
    Member
    Posted 3 years ago #

    We've just had this problem with a client's site. On looking through the source code I found that the JavaScript for TinyMCE and other scripts wasn't loading. Compared to my own blog, which is fine, this should be in the footer. On my client's site the source code stopped with a closing div instead of finishing the page.

    Whether this is down to the sensitivity settings for PHP errors/warnings I'm not sure. Unfortunately we can't find an error log at present so we don't know what the actual error/warning is (maybe someone can check their error log if they find they have the same problem?).

    Anyway, for us, our fix was to open up wp-admin/admin-footer.php and comment out line 36

    do_action('admin_footer', '');

    Hope this helps someone.

  15. danielwiener
    Member
    Posted 3 years ago #

    Okie Dokie.

    The above suggestion worked. I commented out do_action('admin_footer', ''); in wp-admin/admin-footer and it fixed the problem.

    thank you very much.

    I am not sure but this seems like a "bug" to me, since I have to alter the "core". I don't really know how to report to the WordPress devs. If anyone know please tell me. Thanks.

    And I wanted to say, "Thank You Very Much" again, since this was a difficult problem to solve.

  16. rwilson0429
    Member
    Posted 3 years ago #

    I was having the same problem. Deleting my browser cache/temporary files solved the problem for me. Hurray!!!!

  17. aprilrobin
    Member
    Posted 3 years ago #

    Thank you so much for the investigations and suggestions everyone.
    I actually decided to step back to the previous version, stop poking at it (man did that take restraint) and let Godaddy catch up.

    Tonight I logged into godaddy and saw that they're supporting 3.2, so I went for it. 4 blogs upgraded without a single problem.

    *shrug* I guess it was something on their end. I hope everyone else has found a solutions by now, but if you're a godaddy user I think you should be OK to upgrade.

  18. debraframe
    Member
    Posted 3 years ago #

    I have a dozen sites that the same thing happened. 2 I did not update wp and the controll panel is still working. I also just set up several sited yesterday with the newest version and the panel is there and working in the new version so far. So it's just the update screwing things up. I'm at webhostingpad too, so maybe hosting doesn't matter as long as they are up dated. A few of my domains are not godaddy so that doesn't seem to matter. And I have tryed all the tricks you guys have, with plugins and cackes. I'll let ya know if I figure anything our. I sent a message to support @ wp.com and they refered me back to wp.org. Someone said that they released the update while in beta test. Can't wait till we get this solved. Thanks for sharing. Debra

  19. danielwiener
    Member
    Posted 2 years ago #

    Warning: Don't Hack the Core But Do Upgrade to WP 3.2.1
    This is an update to the "No Visual Editor" problem. If you read what I wrote above I had commented out do_action('admin_footer', ''); in wp-admin/admin-footer.php. Andrew Nacin wrote me and told me not to do that because it would screw up many things. So I have upgraded to WP 3.2.1 and put do_action('admin_footer', ''); and emptied the cache and now the Visual Editor works.

    So try upgrading to WP 3.2.1 to solve this problem.

  20. Sarah Anderson
    Member
    Posted 2 years ago #

    The suggestion of commenting out the action hook was written before the new update came out.

    The checks were explained before suggesting to comment out the action hook i.e. see if that was killing the page loading. If it was then the fact is there's no issue on commenting out the action hook because it wasn't running anyway and nor was anything further! Sorry but a daft comment really. It was already screwing up a lot of things and more.

    However, if the upgrade fixes it then it's a moot point.

  21. danielwiener
    Member
    Posted 2 years ago #

    @SarahA I appreciated your solution, since it fixed the problem for me and I knew it would be temporary. I just wanted to warn less careful and knowledgeable users that the upgrade solved the problem. Thanks for your help.

  22. Sarah Anderson
    Member
    Posted 2 years ago #

    No worries, was just pointing out the irony ;) Glad it's working for you now.

  23. debraframe
    Member
    Posted 2 years ago #

    None of these things are working for me,
    Is anyone still working with IE8???????????
    I can't update to 9 because I stll have windows xp

  24. debraframe
    Member
    Posted 2 years ago #

    I just found what was causing my problem. I use a nifty plugin called Digi and when I deactivate it my editor comes back.

  25. stribe40
    Member
    Posted 2 years ago #

    Unfortunately, I have the same problem as described by everyone here (danielweiner in particular - his visual captures are the best for showing whats going on), and upgrading to 3.2.1, turning off plugins, clearing cache and even downloading Google Chrome as a different and new browser to view my site fresh fails to fix the problem.. so there is still a bug somewhere that is not being addressed.

    I run 2 blogs. The one that hasn't been upgraded to 3.2X isn't going to to be upgraded from 3.1.4 until this issue is resolved. It's not a major bug, but it's pretty annoying.

  26. esmi
    Forum Moderator
    Posted 2 years ago #

    There are no known bugs of this type in 3.2.1. Please review http://wordpress.org/support/topic/troubleshooting-wordpress-32-master-list

  27. stribe40
    Member
    Posted 2 years ago #

    I'm aware there isn't. It isnt a bug from 3.2.1. It's an "issue" in 3.2, which 3.2.1 has failed to address or fix - at least in my case.

  28. esmi
    Forum Moderator
    Posted 2 years ago #

    OK - there are no known issues of this type in 3.2.1

  29. ditesco
    Member
    Posted 2 years ago #

    Tried everything suggested here, except for the ones that are related to coding. Unfortunately it is not my thing.

    Now here's another new thing - right after I installed 3.2.1, the visual editor was not working. Did most of the stuff that were suggested here and ultimately got it back working again after I emptied my cache. Now, everything is back again, no visual editor, go figure... It's like an endless loop. Works, and stops working, and so on... this has to be some issue with 3.2.1?

  30. No, but if flushing the cache helped, then that's probably what's wrong. Your cache is busted.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags