WordPress.org

Ready to get started?Download WordPress

Forums

Upgraded to 3.1, Now my Permalinks Dont work! (82 posts)

  1. MikeMovies
    Member
    Posted 3 years ago #

    Hey guys hope one of you can save the day. i just updated wordpress on my site and now all my news links are broken and redirecting to my index page.

    My category pages are also doing the exact same thing. I tried going into my admin and hitting the permalinks button again but im still fubar.

    Help?

  2. MikeMovies
    Member
    Posted 3 years ago #

    As a quick followup when I changed it to STANDARD ie, not /%year%/%monthnum%/%postname%/ it now works.

    Those of you who are having the same problem might consider trying this as a quick fix.

  3. MikeMovies
    Member
    Posted 3 years ago #

    just as a reference point I also tried uploading a backup htaccess file. no good. At this point im wondering if anyone knows how I can remove 3.1 till this bug is addressed.

    Hopefully somebody can settle my panic for me and point me to an easy fix!

  4. allyouneedislists
    Member
    Posted 3 years ago #

    yup, same trouble for me. Been going at it for about 2 hours now, together with my host's support chat service, but couldn't get it fixed.

    As a temporary fix I'm using the Advanced Permalinks plugin to redirect people who come in through Google, but that still doesn't fix the categories.

    I'm desperate to find a fix as soon as possible, any help would be awesome

  5. docarzt
    Member
    Posted 3 years ago #

    Big bump. This is not working for me. Does wordpress ever test this stuff before they put it out?

  6. MikeMovies
    Member
    Posted 3 years ago #

    yeah im trying everything and absolutely can not get permalinks to work. I can see alot of other stuff that is absolutely fubared but that I can live with. All my pages 404'ing I can not.

    Holy moly do I regret not having a dev site. Hopefully one of you sharp wordpress ninjas can figure a fix before we all go bald pulling out our hair.

  7. hereswhatidid
    Member
    Posted 3 years ago #

    What OS are your servers? It seems that this may be a Windows specific problem as the sites I've tried where this failed were all running on Windows.

    UPDATE: sorry, I was mistaking this for the infinite redirect issue.

  8. allyouneedislists
    Member
    Posted 3 years ago #

    im on a Linux server, so that's not it

  9. docarzt
    Member
    Posted 3 years ago #

    Linux here as well. This seems to impact structures that use %category% can anyone else confirm?

  10. allyouneedislists
    Member
    Posted 3 years ago #

    yup, i was using /%category%/%postname%/ before, all screwed up now

  11. MikeMovies
    Member
    Posted 3 years ago #

    my category pages and my news pages are redirecting. My format is as follows

    http://www.moviesonline.ca/2011/02/red-hill-movie-review/

    other pages are worse

    http://www.moviesonline.ca/horror-movies/ is redirecting to a post it looks like.

    wierder still some pages load some dont. This page DOES Load.

    http://www.moviesonline.ca/trending-movie-topics/

  12. docarzt
    Member
    Posted 3 years ago #

    Does the WordPress warranty cover Google placement destruction? NOT!

  13. MikeMovies
    Member
    Posted 3 years ago #

    lol. Just some good news guys I fixed my site. I am now able to load MOST of my content ( some glitches still need fixing )

    If you go now and try and load a news article it does work ( http://www.moviesonline.ca ).

    I am nailing down WHICH file was doing it and as soon as I do I will re-port.

  14. MikeMovies
    Member
    Posted 3 years ago #

    Ok guys its the "Top Level Categories plugin" that is messing up your urls. I have my site now back up and running with the plugin disabled. Of course that messes up some of my pages but I will figure out a fix for that soon I hope.

  15. docarzt
    Member
    Posted 3 years ago #

    It really seems to be a problem in the permalink code itself. I think the WordPress gurus are going to have to go back and revise a few beats of their 'poetry' ... the rhythm just aint working. ;)

  16. MikeMovies
    Member
    Posted 3 years ago #

    did you try what i did doca? My site is not 100%.

  17. allyouneedislists
    Member
    Posted 3 years ago #

    that's not it for me. For one, I'm not using that plugin and beside that I already tried deactivating all plugins, switching themes, etc, but nothing worked

  18. docarzt
    Member
    Posted 3 years ago #

    Sadly, I think this is it for me. I really believe eventually WordPress will be a real CMS, but I'm tired of going into emergency mode everytime they update the script. My next dev cycle is definitely pointed at Drupal ...

  19. MikeMovies
    Member
    Posted 3 years ago #

    sorry to hear that :(. I to disabled all my themes, switched settings, etc. But it was definitely the plugin that did me in it seems.

  20. MikeMovies
    Member
    Posted 3 years ago #

    just as a heads up my category pages are completely fubared still even after doing this.

    http://www.moviesonline.ca/horror-movies/ :(

    http://www.moviesonline.ca/category/horror-movies/ :(

  21. allyouneedislists
    Member
    Posted 3 years ago #

    I seem to have narrowed it down by deleting (not just disabling) the Multi-page toolkit. Posts fortunately work, so Google likes me again, but categories are still broken

  22. allyouneedislists
    Member
    Posted 3 years ago #

    ooohhh yeah! it is now completely fixed, I feel so relieved..

    After disabling and then deleting the Multipage Toolkit the posts worked, but the categories were still being screwed-up by the workaround I had in place with the Advanced Permalinks plugin. Resetting and deleting that fixed it altogether.

    Awesome.

    So: if you're having trouble with your permalinks after the 3.1 update, make sure to narrow down the problem by deleting plugins that might affect your permalinks (such as category plugins, this multipage thingy, or anything else related to it)

    Hope everyone gets it to work, because this new update is actually pretty sweet

  23. MikeMovies
    Member
    Posted 3 years ago #

    im gonna try deleting my top level categories plugin and re-installing it.

  24. MikeMovies
    Member
    Posted 3 years ago #

    deleting the plugin did not resolve my category pages not working. Everything else seems to work ok but not category pages. They are as you say fubard.

  25. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    Guys, I can confirm that there is no problem with this on a stock install. I've tested it multiple ways, and %category% works fine.

    You must have plugins or themes or some kind of custom code that is interfering or incompatible. There is no problem with a %category% in the permalink string on a base install.

  26. anamin
    Member
    Posted 3 years ago #

    Hopefully this helps the rest of you fix this. I too ran into the permlink issue after I upgraded to 3.1.

    I changed my wordpress url and site url to have a / after the domain such as: http://www.site.com/ when I saved that it removed the / after the domain, but now my permlink problem has disappeared.

  27. docarzt
    Member
    Posted 3 years ago #

    I can confirm a couple of things that seem to help.

    1) Multi-page toolkit is TOXIC. You don't have to delete it, though. Just disable it then change your permalink to default, save, then back to custom.

    2) I add this in as a last resort because it is a step that I used, although I suspect it is unnecessary: clear .htaccess completely and then save your redirect structure again.

  28. docarzt
    Member
    Posted 3 years ago #

    GOOD NEWS!

    Here is the permanent fix for this. The problem IS caused by the plugin Multipage Toolkit (Current version 2.6). The good news is, it can EASILY be fixed. For those interested in the how and why, here it goes:

    In the multipage toolkit folder in wp-content/plugins open TA_multi_toolkit.php and observe:

    add_action('init', 'allpage_permalink', -1);
    function allpage_permalink() {
    	global $wp_rewrite;
    	$wp_rewrite->add_endpoint("all", EP_ALL);
    	$wp_rewrite->flush_rules();

    You will find this block of code at line 332. When the plugin is initialized it will flush the rules. For whatever reason, it got away with this on earlier versions of WordPress - beginning with 3.1, this will obliterate certain custom structures (but, interestingly, not all).

    The easiest fix if you want to have custom Permalinks AND use Multi-page toolkit is to to remove the line:

    $wp_rewrite->flush_rules();

    From TA_multi_toolkit.php - the plugin does not need it to function normally.

  29. Ricard Torres
    Member
    Posted 3 years ago #

    @docarzt i dont have that plugin and still not working for me.

    I getting crazy.

    I tryied to de-activate plugins, change permalinks...

    Sometimes works sometimes not.

    One thing is sure: default permalinks works.

  30. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    add_action('init', 'allpage_permalink', -1);
    function allpage_permalink() {
    ...
    	$wp_rewrite->flush_rules();

    *headdesk*

    People, this is just bad, bad, super-incredibly bad, code.

    If you have any themes or plugins doing flush_rules on every single page load, then your site is probably slow as hell. Disable those plugins, ASAP.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.