WordPress.org

Ready to get started?Download WordPress

Forums

Upgraded to 3.04 w/ permalinks, can't access wp-admin (22 posts)

  1. dononeil
    Member
    Posted 3 years ago #

    I recently updated a 3.02 install to 3.04 and now my wp-admin url is not reachable.

    When I have the following in my .htaccess;

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    My Permalinks work great, but I can't access wp-admin, I get a result of "page not found".

    However, when I remove that code from my .htaccess, I can get to wp-admin, but then my permalinks are broken.

    Any ideas on how to correct this?

  2. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    The .htaccess is like this? including the <IfModule

    Emil

  3. dononeil
    Member
    Posted 3 years ago #

    Yes, I've tried exactly like that... same problem.

    It's like Apache (or wordpress) is ignoring

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    I've restarted the server to make sure it's not that. This only started popping up when I did the upgrade.

  4. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    can you show me the URL please?

  5. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    If this was working fine before 3.04 I can suggest to check plugins and make sure that all of them are up to date and of course compatible with 3.04 as well.

    I don't believe that the upgrade is in conflict with your mod_rewrite (Apache).

    Emil

  6. Did you install WordPress in a subfolder, like it's in /blog but runs from http://domain.com straight up?

  7. dononeil
    Member
    Posted 3 years ago #

    It's in the main domain/folder, not in a sub folder.... the url is http://www.troublebrothers.com

  8. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    I am looking at your first post once again and you have:

    RewriteRule ^index\.php$ - [L]
    and
    RewriteRule . /index.php [L]

    Also if this: http://www.troublebrothers.com/games/cargo-runners/ works great, I don't think that this is issue with .htaccess

    PS You did try changing my .htaccess from above, correct?

    Emil

  9. Given that http://www.troublebrothers.com/wp-login.php works but does NOT have any styling, I went to http://www.troublebrothers.com/wp-admin/css/login.css and got a 404.

    Can you double check the folder wp-admin exists? I bet it's missing, or perhaps some files are missing.

  10. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    My wild guess in that case is that in General Settings > WordPress address (URL) / Site address (URL) isn't correct and as well ipstenu stands correct about admin files :) Great catch!

  11. Nah, the wordpress URL is right otherwise the whole site would be FUBAR and not JUST the admin stuff. The wp-admin pages are only called by the admin (rename your folder and see if the site stays up ;) It's kinda neat).

  12. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    However, when I remove that code from my .htaccess, I can get to wp-admin, but then my permalinks are broken.

    So no that wouldn't be correct either, if like @dononeil says without .htaccess all works fine, even the wp-admin all files are there and not missing ;)

    Cheers,
    Emil

  13. dononeil
    Member
    Posted 3 years ago #

    @Emil Uzelac, yes, I removed the extra part of the .htaccess file;

    RewriteRule ^index\.php$ - [L]

    And have tried it with both rewrite rules for index (both singularly and together) and no difference. I found the rule above listed in the blog on how to setup the permalinks and was originally thinking that was the problem, but it doesn't seem to be.

    wp-admin exists, and is not missing files.

    Like I said... if I disable the .htaccess;

    1) I can get to wp-admin and everything there works fine
    2) I can get to 'regular' post names, but not permalinks (obviously)

    If I enable the .htaccess

    1) I can NOT get to wp-admin
    2) I can get to the permalinks

    So either something is wrong with the base code, or there is a bug somewhere in some part of the upgrade or code... I installed it with Installatron, and used Installatron to perform the upgrade. Maybe something they do broke it?

    I would think I just need to add an exclusion for wp-admin (which is what I thought one of those is supposed to do, for directories), but I don't know how to do that.

  14. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    I like to be right, but I hate when my right doesn't help you :(

    Don't know my friend, the last resource that I could suggest is to grab the fresh WordPress download and upload them manually.

    Sorry because I wasn't much of the help, maybe some of the WordPress Support will jump in to assists you further.

    Emil

  15. govpatel
    Member
    Posted 3 years ago #

    Have you tried to rename .htaccess file and login and reset you permalinks from fresh see if that solves your problem.

    As I have updated and I did not have any problem with mt=y wordpress.

  16. If there is absolutely nothing else in your htaccess outside the normal WordPress stuff, and I mean nothing but that, then something is seriously jacked in either a plugin, your theme, or your server.

    Standard debugging ensues.

    1) Turn off ALL plugins
    2) change your theme to the twenty ten theme.

  17. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    Just want to share something else. I opened your site in IE and via IE Developer tool I changed your domain to mine, only for stylesheet and your login came back in normal view:

    http://postimage.org/image/1j381b4as/

    And when I check your site headers, everything came back normal as well:
    http://network-tools.com/default.asp?prog=httphead&host=troublebrothers.com%2Fwp-login.php

    Everything is in place. You can try @Ipstenu and @govpatel first, however also try getting in touch with your hosting provider just to rule out .htaccess issues along with apache mod_rewrite.

    My last suggestion (I think) is this:

    1. Set your permalinks to default
    2. Delete your .htaccess
    3. Clean your cache, plugin caching also if any
    4. Set new permalink structure
  18. dononeil
    Member
    Posted 3 years ago #

    Well, I am the hosting provider, so I know there aren't any issue with the apache config... the problem only popped up when we upgraded to 3.04. I think it may be a plugin issue. I am going to try what others suggested, perhaps installing a fresh version and then seeing if everything works ok, then puttng the plugins in one at a time until it breaks.

  19. Just remember, even if you built the server with your own two hands does not exculpate you from a bonehead maneuver :) (I tell folks to always assume they made the mistake and not the code ;) )

  20. dononeil
    Member
    Posted 3 years ago #

    @Ipstenu... I agree, however if there was a server issue I would have seen it LONG ago and with the previous version of WP... I'm thinking it's an incompatibility with one of the plugins and the new version that is causing this. I have dozens of other users using the older version of WP without issue, this was the first customer to upgrade.

  21. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    Oh in that case if you are the hosting provider you would know if something was wrong. I personally always go back to basics sometimes that's where the problem is.

    Good luck and keep us posted,
    Emil

  22. jgates
    Member
    Posted 3 years ago #

    I just had this same problem...

    404: "can't find the page" while showing me the correct the correct permalink path...

    I HIGHLY recommend the :30 second htaccess refresh...
    rename .htaccess, re-set to "ugly" links, re-set it back... WORKED!!!

    I had added:
    RewriteEngine On
    php_value post_max_size 1000M
    php_value upload_max_filesize 1000M
    php_value max_execution_time 6000000

    to allow for +2mb audio/video media upload

    it worked for the filesize increase
    guess it "broke" it otherwise

    any ideas on how to make the increased filesize work????

    THANX
    John

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.