WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upgraded to 2.7, now can't post/delete article or draft (3 posts)

  1. kReEsTaL
    Member
    Posted 5 years ago #

    Good afternoon,

    I upgraded from 2.6.4 to 2.7 this morning, and now I can't delete articles nor drafts. I also can't publish new articles.

    When I try, I get this message:

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 500001 bytes) in /homez.20/lalunema/www/wp-includes/class-snoopy.php on line 894

    I re-uploaded class-snoopy.php to be sure it's working fine, but it didn't solve the problem.

    I've got another WP installation and it works just fine.

    Any idea? Thanks in advance for your help.

  2. MichaelH
    Member
    Posted 5 years ago #

    Methods for increasing the amount of memory a PHP script may consume

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 8M try 16M:
    memory_limit = 16M ; Maximum amount of memory a script may consume (16MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 16M

    3. Talk to your host.

  3. kReEsTaL
    Member
    Posted 5 years ago #

    Thanks a lot for your help.

    Finally it seems it was the Google XML Sitemap plugin which did cause the memory problem.

    The problem got fixed thanks to the plugin's author, here:
    http://wordpress.org/support/topic/224204?replies=3

    I first tried the .htaccess method you suggested, but it did cause an "Internal server error" on my server :-/ My host doesn't allow it I guess.

    Thanks again :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.