WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] upgraded to 2.7 and internal links not working :( (12 posts)

  1. jogden
    Member
    Posted 5 years ago #

    I upgraded my wordpress to 2.7 and now none of my "pages" will load. I set the default load page to be static and the default post page to be recent posts... those are the only two links that work. The rest result in the recent posts being called rather then the appropriate link clicked.

    my htaccess looks like this

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    RewriteRule ^post/([0-9]+)?/?([0-9]+)?/?$ /index.php?p=$1&page=$2 [QSA]

    # END WordPress

    I have tried it with and without this line

    RewriteRule ^post/([0-9]+)?/?([0-9]+)?/?$ /index.php?p=$1&page=$2 [QSA]

    I have no idea how to fix this, someone please help :)
    website is http://www.designedyesterday.net
    thank you

  2. diecastfast
    Member
    Posted 5 years ago #

    Same issue I just reported here.

  3. jogden
    Member
    Posted 5 years ago #

    I looked at your post, I also attempted resetting my permalinks, gave 666 permissions to my htaccess, reset again permalinks, back to 644 permissions in htaccess... still not working...

    It appears as though allot of people are experiencing this problem yet no solutions I have searched have fixed the problem. I'm looking like a total gubber here... my portfolio is unaccessable and my brain is turning into mush... I would really appreciate someone looking at the site, and telling me what I can do.

    thanks so much

  4. diecastfast
    Member
    Posted 5 years ago #

    Yeah, we're not going to get much help here, as is obvious from all the similar threads with no solution. My blog is a Google authority site and I'm sure I'm going to lose that. I'm going to try uninstalling WP and going with a pre-2.7 version. Will report back.

  5. Samuel B
    moderator
    Posted 5 years ago #

    looking at the sites - sure seems to be a permalinks problem

    what I would try
    rename or delete current .htaccess
    open notepad and save a blank file
    upload it - rename it to .htaccess - chmod 666
    go and set to desired permalinks - save
    clear browser cache and site cookies
    chmod .htaccess back to 644

  6. diecastfast
    Member
    Posted 5 years ago #

    I had no .htaccess and permalinks was set to default. Nonetheless, I uploaded a blank .htaccess, set permissions, reset permalinks, no change.

  7. diecastfast
    Member
    Posted 5 years ago #

    After checking diligently for assistance with this topic or the several other similar topics with the same issue, I've come to the conclusion that this forum has no one actually providing assistance, it's just helpless people seeking information but none is provided. Frustrating that this is held out as a help forum.

  8. jogden
    Member
    Posted 5 years ago #

    samboll... I have done what you suggested and still no change. Can someone copy and paste what the .htaccess should look like? Do I need to revert (oy) to an earlier version of wordpress? The server it is hosted on is powweb if that somehow helps. I asked their cust service if they had any ideas and they suggested I contact wordpress... yet here is sit in limbo with no resolution.

    Thanks diecastfast for the info... I wish I had a host to fix mine.

  9. iridiax
    Member
    Posted 5 years ago #

    For creating/editing an .htaccess, see: Using "Pretty" permalinks

    diecastfast: Your permalinks are now the default ones and they appear to work. To use pretty permalinks, see the link above.

  10. accidentalamazon
    Member
    Posted 5 years ago #

    I found it easier to just punt the pretty permalinks & set them to default after upgrading to 2.7. Otherwise nonw od my internal links would work. Then today once again my internal links would not work for no apparent reason. So, I visited my web hosting panel -- I have a WordPress blog through Yahoo Small Business -- then the blog control panel & found I had to "update" my blog name to ensure that the entire URL was typed accurately, then go back into WordPress into my settings & make sure that my blog's URL was typed out completely & accurately. It was not ("www" left off the beginning). Now, why my blog worked just fine for this entire past month, but suddenly did not work today because of missing it's "www" is a mystery, but perhaps Yahoo or my browser are getting fussier about their X/HTML code & URL's. Good luck.

  11. jogden
    Member
    Posted 5 years ago #

    well foo... I just found out that my server does not support permalink structures and suggested I delete the .htaccess file, upload a new one, permissions to 666, default links in wordpress admin panel, permissions of htaccess to 644, and then it worked... that just just just just sucks. At least my portfolio is viewable now, I just look like a goober that I dont know how to name my files correctly and instead have the icky links displayed ?p=123 bla bla bla...

    thanks for the info everyone, and to anyone else having this same problem, contact the host server to make sure they support the permalinks before you turn grey as you sit.

    hopefully one day soon /next update for wordpress/ will include a better way for permalinks to work so that servers who dont support the current format can support the new one.

    and thanks iridiax, but i already tried that page too...

  12. jogden
    Member
    Posted 5 years ago #

    just an update on this problem... my host helped me fix this fix I didnt see anywhere on this site so thought I would add it to help those future issues others may experience.

    We have corrected the rewrite_rules in the wp_options table of the WordPress Database from s:12:"robots.txt$" to s:11:"robots.txt$". Permalinks should now be working fine.

    hope that helps anyone having this permalink problem.

Topic Closed

This topic has been closed to new replies.

About this Topic