WordPress.org

Ready to get started?Download WordPress

Forums

Upgraded to 2.0.4 and get fatal error (8 posts)

  1. NewSaga
    Member
    Posted 8 years ago #

    I just upgraded to 2.0.4 from .03 and now get 'fatal error' on http://www.profectio.com. I tried to delete all the files and do it again with no luck.

  2. joshuagatcke
    Member
    Posted 8 years ago #

    try deleting your .htaccess file and your wp cache

  3. Kgrrl
    Member
    Posted 8 years ago #

    I am upgrading from 2.02 to 2.04 and getting this error when trying to upgrade:

    Fatal error: Call to undefined function: wp_get_referer() in wp-admin/upgrade.php on line 70

    Line 70 is: $goback = wp_specialchars(wp_get_referer());

    I tried reinstalling the wp-admin and the wp cache is deleted but I am still getting this error. Anyone know why? I am totally stumped.

  4. NewSaga
    Member
    Posted 8 years ago #

    joshuagatcke - thanks for the suggestion, I tried deleting both and it still doesn't work.

  5. gallanwood
    Member
    Posted 8 years ago #

    I have this problem too. My site displays OK (http://alllanwood.co.uk) but I get the error you describe plus:

    Fatal error: Call to undefined function: wp_get_referer() in /homepages/45/d119121075/htdocs/allanwood/gawp/wp-admin/edit-form-advanced.php on line 214

    at the bottom of wp-admin/post.php

    HELP!

  6. schellack
    Member
    Posted 8 years ago #

    I'm running WordPress and receive the same error when I go to ../php-admin/upgrade.php:
    Fatal error: Call to undefined function: wp_get_referer() in www\jonathan\wp-admin\upgrade.php on line 70

    I installed a clean 2.0.4 in another place on my shared-hosted server (with different database tables) and that install worked fine.

    Now I see the "Fatal error: Call to undefined function: wp_get_referer()" message all over the admin portion of my site (the one I upgraded), just referring to different line numbers.

    Does anyone know what the wp_get_referer() does? I searched through all the files on my site and could not find any text of 'wp_get_referer', though I may be looking for the wrong thing.

  7. bilderboy
    Member
    Posted 8 years ago #

    I had the same problem. This is what I did. Removed the cache. Downloaded the latest version (I had it allready from a few weeks back, but downloaded it again). Then I just copied all the files over the files that were there and it worked.

  8. schellack
    Member
    Posted 8 years ago #

    An update to my previous post: I had to delete everything and then re-upload the 2.0.4 version and it then let me do the upgrade page, so I think I'm good to go.

Topic Closed

This topic has been closed to new replies.

About this Topic