WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[W3 Total Cache] Upgraded to 0.9.2 - BROKEN in Firefox 4.0.1 and IE 9 (48 posts)

  1. desertgeek
    Member
    Posted 2 years ago #

    I was testing a brand new install on my development Blog of the prior version of 0.9.13 and everything was working great.

    THEN I upgraded and that broke Firefox 4.0.1 and IE 9. Ive turned off the Mobil Theme plug in and deleted the tables for same and checked my DB. No luck. Iv'e also turned off all the Browser Cache options except gzip and still no luck. Iv'e also played with the User Agent theme settings and no luck.

    This is certainly a "show stopper" and I hate to say that. Did I miss anything?

    SEE for yourself using Firefox 4.0.1 or IE 9 at:

    http://www.g17.com which is a test/development blog. :)

    It looks like a Mobil theme but NONE are installed or even in the DB.

  2. desertgeek
    Member
    Posted 2 years ago #

    sorry...The thread title should have said:

    w3 total Cache

  3. Ryan
    Member
    Posted 2 years ago #

    I have the same problem on my site. I just updated and it's doing the same thing for me.
    It seems the minify is broken. The minified .css and .js files are bad...

    "http://www.g17.com/wp-content/w3tc/min/c107d60f7f8096b68f1295ea893bcfbf.1437762405.css" contains this:
    "Bad file param format."

  4. Gary Bairead
    Member
    Posted 2 years ago #

    I'm getting the same error for the minifed files.

    You can disable auto-minifying in settings.

    The minify wizard is also unusable in FF4.0.1

  5. desertgeek
    Member
    Posted 2 years ago #

    rryyaanndd

    :) Fantastic catch. I left Minify enabled so the developer can see it but turning it off is the fix as you pointed out.

    Also broken in Safari for the iPhone 3gs - latest os and browser.

    Can't test in IE 8 yet but I'm sure it's broken.

    HOW do I reach the developer directly? I would like to provide a heads up since minify is enabled by default. Hope you saved the previous versions zip?

  6. Daniel_N
    Member
    Posted 2 years ago #

    Same problems as mentioned above with minify,

    Also getting wrong charsets in different browsers.
    Using UTF-8 as standard:
    In firefox it loads with UTF-8
    Chrome us-ascii

    Disabling the plugin makes the charset load correctly.

    /Daniel

  7. desertgeek
    Member
    Posted 2 years ago #

    OK, I uninstalled and deleated from my site and also sent the developer a contact us form submission. We have plenty of evidence :) from experienced WP GEEKS :)

  8. Ryan
    Member
    Posted 2 years ago #

    You can get older versions of the plugin here:
    http://wordpress.org/extend/plugins/w3-total-cache/download/

  9. vexite
    Member
    Posted 2 years ago #

    I had to disable minify settings to get my theme working for the moment. Really a show stopper :(

  10. SlowClicksDotCom
    Member
    Posted 2 years ago #

    Same here. Disabled Minify - it was fine in Chrome, but FF and IE were totally broken. Only weird thing is that I still DON'T see the "unminified" css files when I try to load the site on Pingdom Tools.

  11. kfawcett
    Member
    Posted 2 years ago #

    This is most likely a user configuration issue. While auto-minify might work for some people, if you're running many plugins and/or lots of JS files that are potentially written improperly, you could possibly break something leading to problems with the site loading properly.

    To alleviate this try switching to minify to manual and using the Help function to "help" find all of your JS and CSS files. Add all of them, making sure to take care in deciding where to add the JS files and what blocking to use. If you're unsure try adding them to the section (head or end of body) that they are already located at in your code and use blocking.

    For the first round of testing do not use any of the advanced check boxes for the JS settings.

    If after adding all of the JS files and CSS without any advanced features you can try to enable comment removal and line space removal if you like.

    If either of these rounds of settings breaks your site, try only adding one JS file at a time. Once one JS file has been added and you have tested it on your site add another and test again. Do this until you find the file(s) that are not working when minified. You can then try to run them through JSlint to find errors or contact whoever developed the files to help with fixing them. If you are unable to fix a file that is not working while minified then don't minify that file. You can select as few or as many files to combine and minify as you like.

    W3TC is an advanced plugin that requires time, experience, and tweaking in order to use it properly. I am personally running the development plugin on WP 3.1 Multi-site with about 10 sites. It works fantastically with no major issues.

  12. inParisTexas
    Member
    Posted 2 years ago #

    This issue started with our site on updating the plugin today as well. I do understand the issues listed, but nothing I did fixed any of them. To keep our site live after the update I had to deactivate the plugin.

  13. desertgeek
    Member
    Posted 2 years ago #

    For ---> kfawcett

    Respectfully, I appreciate your tips and myself and others are hardly what you would call plugin newbies, including but not limited to every major caching plugin available. :)

    Having said this, YOU MISSED the point which is all about default settings. PERIOD. Install and activate. Don't touch a setting and see how it works.

    --> The prior version 0.9.13 worked great out of the box. PERIOD.

    ---> The latest version 0.9.2 is BROKEN out of the box. PERIOD.

    Whatever options you turn on via a default install/activate need to be rock solid and work accross the majority of sites. Unfortunetly, thats NOT the case and although I'm not really a coder, first iompressions are everything.

    I would respectfully suggest that if you can't fix the code then you turn the "minify" options all OFF for a default install and then warn the user. Since they all worked in the prior version perhaps more testing and help accross your user base would be inorder.

    Good luck :)

  14. baptiste
    Member
    Posted 2 years ago #

    Same here - CSS completely broken after the upgrade to 0.9.2. Disabling minify wouldn't get it back (source showed the minify link still being inserted) Finally had to disable the plugin after having used it for quite some time. Will try disabling gzip compression as noted in another thread to see if I can at least get the plugin half working again...

  15. baptiste
    Member
    Posted 2 years ago #

    Interesting. I disabled the plugin entirely - ensured htaccess was clean. Re-enabled the plugin and ensured Minify was disabled - now things are working again. Disabling minify before didn't work. I had to cycle the plugin. Now it seems OK without Minify (and gzip compression is enabled along with General, Browser, DB, and Object caches enabled)

    Fingers crossed - went a number of hours with no CSS - whoops!

  16. kfawcett
    Member
    Posted 2 years ago #

    @desertgeek Sorry I should of read more.

    So I was thinking *whats the big deal* and I upgraded my W3TC and I bricked my server. I'm getting 500 errors. I guess there is something to everyone posting on here. :)

    I do have these two warnings in my logs.

    [Tue May 10 01:08:33 2011] [warn] mod_fcgid: stderr: PHP Warning: Invalid argument supplied for foreach() in /wp-content/plugins/w3-total-cache/lib/W3/Plugin/Minify.php on line 393

    preg_match() expects parameter 2 to be string, array given in //wp-content/plugins/w3-total-cache/inc/define.php on line 323

  17. desertgeek
    Member
    Posted 2 years ago #

    ----> @kfawcett

    No problem. Iv'e bricked a server or two myself. :) Found the CTO on Twitter. Finally a valuable use of a tweet.

    Sent this tweet:

    @w3edge SEE ---> http://tinyurl.com/3vmds4l [W3 Total Cache] Upgraded to 0.9.2 - BROKEN in Firefox 4.0.1 and IE 9 DEFAULTS break sites

    Always a little harsh with Tweets but Frederick Townes CTO, I'm on your side of this and happy to help anyway I can. :)

    NOTE: the uninstall and deleate is pretty clean from what I can see. .htaccess is clean. Left one setting php file in /wp-content and tables are also clean.

  18. sebastien.barre
    Member
    Posted 2 years ago #

    Same here, minify part is broken (in manual mode, since I need CDN).
    Getting a "Bad file param format." when pulling the minified CSS file.
    In the "CSS minify settings" I had to uncheck "Enable".
    The rest seems to be working fine.

  19. rosidnet
    Member
    Posted 2 years ago #

    Hoping someone kind enough to explain the solution. Or maybe already knows the configuration techniques for W3TC 0.9.2 can work optimally, it is expected to be able to share his knowledge here. :)

    Heheheheeee .... head was getting tired after doing some trial configurations :-D

  20. vexite
    Member
    Posted 2 years ago #

    As mentioned above, out of the box -- it's broken, unlike the previous version which worked flawlessly without doing much manual configuration.

    I am also expecting it will re-use my existing configuration and because the previous worked I thought it should work with 0.9.2... But it didn't.

    I tried different settings on minify and none of them worked. Tried auto. Tried manual... in manual I specified selective css only but I still "get bad file param format" just like most of the users here.

  21. Andrej Mihajlov
    Member
    Posted 2 years ago #

    Same error! Any suggestions from the plugin's author how to solve this?

  22. ThijsNL
    Member
    Posted 2 years ago #

    Same problem here......

    Removed new version, reinstalled the old.
    Lets hope the update will be/get fixed.

  23. jibby38
    Member
    Posted 2 years ago #

    ThisjsNL - is everything working okay with the previous version?

  24. jibby38
    Member
    Posted 2 years ago #

    I just removed W3 Total Cache, and installed Quick Cache (highly recommended by a friend), and the ratings look very good.

  25. kmarizo
    Member
    Posted 2 years ago #

    Total rookie to W3 Total Cache: I received the new version notice, downloaded v. 0.9.2, activated it, it broke my site. (looked like a mobil wesbite theme). I panicked, deactivated it, site was still jacked. I uninstalled it, still had a problem. Had to clear .htacess as well as a .php folder that was still in my root wp content folder. My site is back to normal. Thing is, I don't remember what my previous version of W3 was. I went to the changelog for w3 http://tinyurl.com/29qdag8, I tried previous v. 0.9.1.3, it broke my site again. I turned off Minify, still no go. I guess I will try v. 0.9.1.2. / It's a learning lesson for me.

    Newbie question: Do I have to check any database/tables in mySQL for remnants?

  26. obrun
    Member
    Posted 2 years ago #

    From @w3edge on twitter, the same fix as Gary suggested below "users need to switch minify to manual minify mode".

    The fix seemed to work for me.

    I think the variations from browser to browser are partly because authenticated users can be set not to receive the minified version (The browser you are logged into the wordpress site from may not see the error) and the browser cache.

  27. sebastien.barre
    Member
    Posted 2 years ago #

    No, switching to manual mode won't help either.
    I tested from a non-authenticated browser, which is supposed to receive the fully-cached version of the page.
    Disabling minify does the trick for now until a fix is committed.

  28. robnalexpress
    Member
    Posted 2 years ago #

    Just upgraded to 0.9.2 and got NO THEME CSS on both sites. Under General Settings - Minify - Minify Mode, I switched to manual and it fixed it for me. Will be watching for a permanent fix.

  29. Fisnik
    Member
    Posted 2 years ago #

    Same problem.. it crapped my site.. I've deactivated it and wait for a solution

  30. wellbeingtips
    Member
    Posted 2 years ago #

    After upgrade my site loading become very very slow as 7sec. Before i HAD 2,5. Google page speed shows me 93/100 but anyway my site get slowed down.

    can anyone say me if this is something broken or I have to check it somewhere? W3 Total

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic