WordPress.org

Ready to get started?Download WordPress

Forums

WP Publication Archive
[resolved] Upgraded plugin and now not working (7 posts)

  1. dgrcomms
    Member
    Posted 1 year ago #

    Hi,

    i upgraded the plugin and now they links to my document don't work. I am being http://www.xxxx.org/publication/youth-council-calendar/wppa_download instead of the document link.

    Any ideas why this is happening now?

    Appreciate your help. Great plugin by the way!

    http://wordpress.org/extend/plugins/wp-publication-archive/

  2. Eric Mann
    Member
    Plugin Author

    Posted 1 year ago #

    Please provide a link to your site so I can see what is happening, but that link (with the slug of the publication and wppa_download is the correct URL).

    The idea is to mask the actual link to the file so that a future version can enable password-protected downloads. The end user should never see the actual file URL.

  3. dgrcomms
    Member
    Posted 1 year ago #

    Hi Eric,

    Thanks I understand that and I did read that in your other posts. My website is password protected at the moment as I in the process of building it. I don't want to put the password here if possible, can I email it to you?

    Thanks

  4. Eric Mann
    Member
    Plugin Author

    Posted 1 year ago #

    Please contact me privately. There is a contact form in the footer of my website -> http://eamann.com

  5. dgrcomms
    Member
    Posted 1 year ago #

    Thank you so much. Will email you shortly!

  6. welchtima
    Member
    Posted 1 year ago #

    Hi Eric

    I am having the same issue.
    http://www.stmichaelandallangels.ca/sermons/

    Shortcode on the Sermons page is [wp-publication-archive categories='sermon']

    Clicking on Open or Download gives me a 404. The first link on the page that you see should point to
    http://www.stmichaelandallangels.ca/wp-content/uploads/2012/12/Advent_4C.pdf

    Thanks for your help.

  7. Eric Mann
    Member
    Plugin Author

    Posted 1 year ago #

    When you upgrade the plugin rather than do a fresh install, its not flushing your permalinks. To do this manually, you need to:

    1. Log in to your site.
    2. Navigate to Setting » Permalinks

    That's it. Just viewing the permalinks page will flush your settings and fix the 404.

    If not, please start a new discussion topic because that means you're facing a different issue. This is the same process we used to resolve the problem above.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.