WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials by Aihrus
[resolved] Upgraded and new width issue (8 posts)

  1. peterash
    Member
    Posted 1 year ago #

    I just upgraded the plugin and can't figure out why the width is now scrolling crazily to the right.

    I've tried assigning css to it but can't get it working.

    http://www.sanjosepetsit.com/faqs/

    Any thoughts?

    http://wordpress.org/extend/plugins/testimonials-widget/

  2. ChrisFord
    Member
    Posted 1 year ago #

    Interesting... I've been trying to resolve an issue all day. The Read More link isn't showing up on my widget. Then a few minutes ago, I discovered that the link IS actually on my page - just showing up on the left side toward the bottom of my website (which is not a sidebar, either). It's like the Read More just wrapped outside the widget and ended up across the page. I wonder if our issues are related.

    http://myfordassociates.com/wp-content/uploads/2013/02/readmore.png

    Though... I'm also suspecting that my issue may have to do with some kind of conflict with the genesis child theme I'm using. The Read More link is formatted the way my child theme formats read-more links.

  3. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Looks like you've both not updated for a while.

    @Peterash, the problem is that your theme is styling .hentry. See line 116 of styles.css.

    .page .hentry, .single .hentry {
      width: 620px;
      float: left;
    }

    If you add an entry like the following, you should be fine.

    .hentry . testimonialswidget_testimonial {
      width: 100%;
    }

    @ChrisFord, probably similar issue.

  4. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    @ChrisFord, .more-link is display: block; You might try the following to fix.

    . testimonialswidget_testimonial .more-link {
      display: inline;
    }

    For you and others, weird presentation issues like this are almost always related to theme CSS. Use your browsers right-click Inspect Element option to trouble-shoot.

  5. peterash
    Member
    Posted 1 year ago #

    Hi Michael! It's still not working. I've played with the inspect element, and I'm usually pretty good at this stuff, but for the life of me I can't figure it out.

    Do you know what changed in the update that would affect this?

    -P

  6. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    @peterash,

    My testing shows that the following CSS update should do the trick.

    .hentry.testimonialswidget_testimonial {
      width: 100%;
    }

    You might try placing it after the .hentry CSS entry in your wp-content/themes/jpmm/style.css file.

    Do let me know if you're still having trouble.

    The fun styling is coming in because of get_post_class. That adds the class .hentry besides other classes regarding post type, categories and tags. I've added a TODO to create an option to remove the .hentry.

  7. peterash
    Member
    Posted 1 year ago #

    You're the man! Thank you very, very much!

  8. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Wonderful news to here. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.