WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Upgrade tot 3.1 leaves website blank: Fatal error! (52 posts)

  1. Martijnchel
    Member
    Posted 3 years ago #

    Hi,

    I got this fatal error when I upgraded to 3.1:

    Fatal error: Class 'WP_List_Table' not found in /usr/home/deb18228n2/domains/homecinemamagazine.nl/public_html/wp-admin/includes/list-table.php on line 76

    Restoring my backup does not even help..

    What can I do?
    Please help!

  2. qbano
    Member
    Posted 3 years ago #

    Me too help....

  3. wideblueyonder
    Member
    Posted 3 years ago #

    Same boat - upgraded to 3.1 and wordpress site, including admin sections completely blank white screen

  4. krispy_b
    Member
    Posted 3 years ago #

    Windows server 2003 for my wordpress (my rented server).

    just updated one of my several wordpress sites to 3.1 - just killed it

    the admin still works, but the public visible side won't load up.

    The page isn't redirecting properly

    http://www.pdc-darts.co.uk

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    * This problem can sometimes be caused by disabling or refusing to accept
    cookies.

  5. krispy_b
    Member
    Posted 3 years ago #

    i'll add i tried renaming the plugin directory to plugins.hold, and creating a new plugins directory - refreshed admin, and all the extras disappeared, but still same error on front end of site.

    then changed to default theme - still same error. so it doesnt't appear to be plugin or theme related?

  6. Martijnchel
    Member
    Posted 3 years ago #

    Anyone who has the pluging WPeMatico installed!!
    Delete it from your FTP server.. WP 3.1 does not like it! And it causes the error I had.

  7. qbano
    Member
    Posted 3 years ago #

    I had WPeMatico on that site. Delete it and is working all good. Great job Martijnchel!

  8. AardvarkGirl
    Member
    Posted 3 years ago #

    krispy_b
    I had the same exact issue. We have control of our server.

    See my other posts about everything I have done. I ran the auto update on one of our clients sites and the site went blank (actually got an error in Chrome and FF that it is in a loop). Then I ran the auto update on our WP test site (used to just develop themes). It killed that one too.

    So with the test site I tried a manual update - didn't work. Then I killed all the files and the database and tried a brand new, fresh install of 3.1 and got the same thing (full access to admin area but the front end hung in a loop / blank page).

    I finally killed the entire thing and just reinstalled 3.0.5 with a clean database and it works fine.

    My clients site that is still in 'upgrade-loop-limbo' is still there. I've given up, only two people have replied to my two threads. I'm digging into the server back ups of the database from yesterday and I'm going to kill everything and just totally reinstall the 'limbo' site again using 3.0.5 and just import the backed up 'pre update' database. :-\

    Cameback to edit that my limbo site does not have that plug in installed - and actually from the admin area it let me deactivate all my plug ins, but it still won't function on the front end.

    I tried to go in and change the plug in folder name, not just via FTP but via remote desktop, and it would not give me access (seriously?). I even started/stopped the website in IIS.

  9. wideblueyonder
    Member
    Posted 3 years ago #

    Are you folks able to see/get to the admin pages? I currently get nothing at all - everything is blank/white whatever I try.

    I have tried renaming the plugins folder in wp-content but this made no difference.

    Anyone have any other suggestions.

  10. krispy_b
    Member
    Posted 3 years ago #

    I see the admin pages at least.

  11. AardvarkGirl
    Member
    Posted 3 years ago #

    I can get to my admin side and do things, like disable plug ins, and even pre-view pages.

    I just can't get to the site from the front end.

  12. mikerm
    Member
    Posted 3 years ago #

    I managed to get this to go away by commenting out the function that was causing the error. I then found that one of the plugins I had installed (backWPup) was trying to call the same code and also failing.

    Removed the whole plugin (by deleting the directory) and my site came back up.

    Obviously this is a temporary fix, but at least the site is there again.

    Two of my sites (recently created with minimal content and up-to-date WP installs) upgraded with no problems, but my third one had this issue. Will be waiting to upgrade the fourth and most important!

  13. AardvarkGirl
    Member
    Posted 3 years ago #

    I upgraded two sites.

    One only had Google Analyticator and was in deactivated mode, and My Page Order.

    The other site had... deactivated Akismet and uh... I don't believe anything else?

    Didn't matter. I could get in and deactivate all plug ins but both sites still tanked on the front end.

  14. wideblueyonder
    Member
    Posted 3 years ago #

    My Issues are now SOLVED.

    Recap of Problem - used auto-update from WP dashboard
    After update whole site went blank - plain white page with no access to either front or backend.

    Solution: Downloaded 3.1 from wordpress.org and used .ftp to do a manual update which has brought the site back to life.

    Instructions for manual upgrade can be found here: http://codex.wordpress.org/Updating_WordPress

  15. BigFeat
    Member
    Posted 3 years ago #

    I'm unable to get into my dashboard. I get this message Fatal error: Call to undefined function is_network_admin() in D:\Hosting\7352934\html\wp-admin\includes\menu.php on line 10

    How do I fix this?

  16. esmi
    Forum Moderator
    Posted 3 years ago #

    Try:
    - switching to the Twenty Ten theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides. You may need to access /wp-login.php to get this to kick in fully.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-running the upgrade manually

  17. BigFeat
    Member
    Posted 3 years ago #

    The website loads just fine after the update http://www.inceptionradionetwork.com. I did disable all plugins prior to this and was running an ajax login plugin. The only issue is that I can not get into the dashboard at all when I put "/wp-admin" at the end of my url. I just get the error message that I got.

  18. Vibranthealthsolution
    Member
    Posted 3 years ago #

    I have had the same down site issue since upgrade, though my error is different.

    Fatal error: Cannot redeclare class wpdb in /home/aware1/public_html/wp-content/db.php on line 54

    I'll try some of the helpful steps above.. *finger-crossed*..

  19. Stephen
    Member
    Posted 3 years ago #

    I used this plugin to fix this problem...

    Wp htaccess Control

    However, you have to leave it turned on. I'd like a real fix myself if possible. Thanks.

  20. Vibranthealthsolution
    Member
    Posted 3 years ago #

    Hey everyone, try following this fix : http://wordpress.org/support/topic/fatal-error-upgrade-to-wp-31?replies=14#post-1959778

    All that was needed was to change the name of the file where the errors were coming from. easy-peasy for now!

  21. MarkWalter
    Member
    Posted 3 years ago #

    Serious bug in this upgrade that needs to be fixed. We did one site and had to re-install 3.0.4 (I don't have c copy of 3.0.5) to get it back up and running. We should not have to use any 'tricks' to make this work.

  22. Dax Davis
    Member
    Posted 3 years ago #

    As an FYI for others still having issues. My host auto-upgraded my install but didn't update the plugins first. BackWPUp was the module that caused me to get the error:

    Fatal error: Class 'WP_List_Table' not found in .../wp-admin/includes/list-table.php on line 76

    and on another installation be stuck in the upgrade loop.

    I just removed the plugin, downloaded the latest, and reinstalled it (after upgrading any other plugins as well). All is good.

  23. Mateo1041
    Member
    Posted 3 years ago #

    wideblueyonder's solution worked for me. Both my website and admin area was blank.

    1) Downloaded newest 3.1.

    2) Deleted wp-admin and wp-include directories and replaced all files with those from the download. Also replaced all other files except for those in wp-content.

    3) For wp-content, I was more selective and manually overwrote old files.

    4) The admin area then asked me for database details again because wp-config.php was not found. I entered my DB details again (thankfully I remembered them). When I got to the install portion, I closed all browser windows and went back to the admin area. It then asked to upgrade the DB, so I did.

    All working ok now finally. Phew.

  24. ramit
    Member
    Posted 3 years ago #

    Tnx soo much for this thread.
    I have 5 wp sites I run.
    3 of them, I had upgraded all the plugins 1st, just out of luck, and then did the upgrade on WP through my my hosting software management panel... and no problem.

    #4, didn't go into WP and update the plugins 1st, just pushed the WP update through my hosting software management panel, and it failed.
    Tried again, failed.
    Went to the site, tried to get into the WP admin for that site...
    and got:
    " Fatal error: Class 'WP_List_Table' not found in ...... line 76 "
    Some pages worked, some didn't ,some had the same error, others slightly different.

    Ugh,, did a search found this thread.
    FTPed into that site, deleted the directory for BackWPUp , and from my hosting software management panel, pushed the WP update again, and it worked. And now I can get back into #4 site's WP admin panel...
    Wheeeeo...

    Now #5, the biggest most important one I manage, did a back up, made sure all plugins are up to date first, and with fingers crossed, pushing the update....... wheeoo, that worked fine !!!

    Lesson learned, update plugins first!

  25. plusvision
    Member
    Posted 3 years ago #

    @ramit:

    I learned another lesson. I understand now that wordpress is not an industry strength platform, it's a hobby platform.

    First of all wordpress should have the possibility to determine if an update can take place looking at the versions of plugins installed. Secondly how can it happen that I install wp 3.1 all works fine but the next day the admin login AND the site itself are blank.

    I must say that I am VERY angry about that. It means 3.1 had not gone through enough testing and wp is not sophisticated enough to be reliable.

    My income is depending on my web site but it went all blank behind my back for no reason and without any incompatibility notice. Thats completely unacceptable.

    Now I have to start fiddling around with database or ftp tricks on my free saturday to get my site back up but without success. Its still blank!

    I begin to regret I moved to the wp platform.

  26. plusvision
    Member
    Posted 3 years ago #

    Also, I have latest versions of plugins installed. I am 100% sure I did nothng wrong and to be honest, THAT worries me most. I think wp needs to come up with some sort of verification / repair app to analyse whats wrong because I have no clue whatsoever. Dont know what to do really as proposed remedies dont work. Standing here and lookin at blank pages.

    Anybody any advise? Go back to printed media for promotions?

  27. wideblueyonder
    Member
    Posted 3 years ago #

    @Plusvision - whilst I have complete empathy for your situation having experience something the blank pages initially with one of my sites - there are some huge flaws in your criticisms of WP.

    If your business relies entirely on this website then:
    1. Why did you upgrade so early as opposed to keeping your install of WP at a version you knew was working - either wait and watch the forums to see what other peoples experiences are or have a second install of wordpress you can use as a sandbox - to play with and test out upgrades before upgrading your mission critical site.

    2. If you resent putting time into your website system at the weekends (or evenings or whenever) then is an open source piece of software that inherently requires input from the user into it's up keep, maintenance and troubleshooting really the right solution for you. There are plenty of other options on the market that you could be paying for which provide the type of support you are looking for.

    3. WP should provide a repair tool for you??? Read my point number two again - what have you paid WordPress.org to date - I suspect nothing, therefore what do they owe you? The type of support you are looking for in this is what I would expect if I had paid a company for a software solution NOT from an open source project.

    4. Did you create a backup of both your database and website before you upgraded? If so, you could reinstall back to your previous installation and all would be fine. If you haven't backed up, why did you install the upgrade?

    5. Go back to printed media for promotions - er, no - just don't rely on a system you can't support and manage yourself if it is so critical to your business.

    6. Plugins all up to date - by this do you mean simply the latest version or do you mean you checked they were WP 3.1 compatible before upgrading. Even if they were 3.1 compatible you should have them disabled when installing an upgrade and then activate each one individually to check they work properly.

    Sorry my friend, it just seems you are lashing out at WP out of frustration and I feel it is a tad unfair.

    I sincerely hope you resolve your issue - see my post earlier in this thread for how I resolved the issue on my site. i am also aware for some folks the upgrade seemed to work, then the site vanished later - by changing their permalinks back to default then switching back to their chosen permalink structure also resolved issues.

  28. Mateo1041
    Member
    Posted 3 years ago #

    It's really no different than fixing a car. Sometimes cars break down. You can either do it yourself or pay to have them repaired. It was inconvenient in my case and scared me a little, but the automated update process *did* warn me to back everything up, half of which I did. Websites take work. :-/

  29. plusvision
    Member
    Posted 3 years ago #

    @wideblueyonder:

    Opps, seemed to have touched a sensitive string here. Are we friends yet? So quickly? Welcome! I appreciate some of your replies, however, I did pay for several plugins but that won't change your mind I guess. Anyway, when starting with wp and reading the info everywhere I looked on the wp sites I get basically the same massage: its fantastic, its very easy, its a breeze.. Well, my experience is quite different, and yes its for free but I lack a bit of relativation here and there. It would do the platform good. Thats my opinion. And yes, to my opinion its a hobby platform, but nothing wrong with hobbies, but I wanna have something rock solid.

    re point 6. Well, I think wp should determine installation requirements are met, or is wp fully aimed at pro's? Guess its not gonna get real big than. And Oh yea, I am sorry I am not a code warrior. I am just a average novice who probably took the words "easy" and " breeze" or whatever a bit too serious etc.

    Problem is I cannot approach the admin hence login, left alone I can reach any plugin pages. Public page are completely blank. Just like that, yesterday it was working great. next day its gone, like magic, I did nothing. Absolutely nothing to the site. The only access I have left is FTP and currently restoring my pure html based site.

    Yes did did backup of database and site. So to restore the 3.0.5. version I can just delete all and ftp it back on? Or do I need to keep anything there???

  30. ramit
    Member
    Posted 3 years ago #

    I have to agree , WP is a hobbyist platform that had taken hold even with many professional designers, my bro who is in the business talked me into it, to get away from DW and notepad....

    I'm only running 5 sites via WP, the rest are still good old DW/notepad.

    I found a lot of advantages with WP... BUT..

    With the updates, I start with the pure hobby sites I have and try the updates on them, and then work my way up to the couple that are very important.. so I have an idea of what I'm getting into.

    I've noticed with WPSuperCache, seemingly strange things happen with even the the smallest changes to pages or the site.
    I'd guess it's the reason you saw your site just fine and dandy that night and the next day - pooof, all gone.

    There's a lot of little quirks in WP that I've learn to live with.
    Including, I'm soo use to backing up and running a site local on my HD with pure html and basic structure I've been using since 1995 , that running a site out of a DB with so much underpinning to make it happen, is just unnerving - LOL .. Ah, for the simpler days.

    As my mom always said, "you play - you pay" ....

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags