WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upgrade to WP 3.2 lost permission to Network Settings (17 posts)

  1. Vernon Fowler
    Member
    Posted 3 years ago #

    From Network Admin when I choose Network Settings from the left menu, the message I get is:

    You do not have sufficient permissions to access this page.

    Do I require a simple chmod for some reason? Or is there some other fix?

  2. No.

    Check your database. Under the wp_usermeta table, look up your ID and see what the value for wp_capabilities is.

    Mine is a:1:{s:13:"administrator";s:1:"1";}

  3. Vernon Fowler
    Member
    Posted 3 years ago #

    Mine is a:2:{s:13:"administrator";s:1:"1";s:10:"can_runPHP";s:4:"true";}

    What needs to change?

  4. creativelasso
    Member
    Posted 3 years ago #

    @Vernon - I'm having the same issue. See my thread http://wordpress.org/support/topic/32-mu-setup?replies=27

  5. I've flagged this one for more help as well. This is me, hitting my head against the wall.

  6. Check your wp-config.php file.

    Did you remove define('WP_ALLOW_MULTISITE', true); ?

    The whole thing should be

    /** MultiSite **/
    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'domain.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    Remember, define( 'SUBDOMAIN_INSTALL', true ); will be FALSE if you're using subfolders :)

    Also from Otto:

    In your wp_sitemeta table, what do you have for the site_admins value? It should be something similar to this: a:1:{i:0;s:4:"otto";}

  7. Vernon Fowler
    Member
    Posted 3 years ago #

    Checked wp-config.php file and it contains the code as above (obviously my domain though).

    In the database wp_sitemeta table I have a site_admins value of a:1:{i:0;s:5:"my_admin_name_here";} - so a 5 instead of a 4 - is that a problem?

  8. Mine's 7 so ... I don't think so. But make sure your admin name is correct.

  9. Vernon Fowler
    Member
    Posted 3 years ago #

    Yes, my admin name is definitely correct and not my_admin_name_here. This is painful. I guess my work around in the meantime is to update the values directly in the database - yuck!

  10. Did you update both your wp-config AND your .htaccess correctly?

    Also ... does your username have capital letters?

  11. Vernon Fowler
    Member
    Posted 3 years ago #

    I wasn't aware I should make any changes to wp-config.php or .htaccess - the later file hasn't changed for months and my wp-config.php file has everything as described above. This is the weirdest problem in that I can do everything else as Super Admin in the Network Admin (change plugins, add themes, etcetera). Everything except change the Network Settings. Bizarre - I must admit, I don't change these settings very often and this could very well be a pre-3.2 issue and it sounds particular to just my and @creativelasso setups.

  12. You know... *headdesk* You two have slightly different issues, and I'm kicking myself for misreading!

    Turn off ALL your plugins. All of 'em.

  13. Vernon Fowler
    Member
    Posted 3 years ago #

    Not sure where we're going with this.
    As can't do this from Network Admin, I'm going through my sites 1 by 1 and deactivating all plugins - probably bring down the sites as I do it.
    And what do you propose next?
    Thanks for trying to help me out here @Ipstenu

  14. Eyecool
    Member
    Posted 3 years ago #

    How did you upgrade to 3.2? SVN, Automatic Upgrade (through wp-admin) or manual ftp?

    Did you back everything up? If you haven't, back up now!

    Depending on how you upgraded, I might try re-upgrading again. On most of my multisite upgrades to 3.2, it upgraded the database (and I got an 'upgrading database' message). On a few, I didn't see that message and a few wonky things happened.

  15. Vernon, rename the plugins folder via FTP to plugins-old. Ditto your mu-plugins folder. That turns them ALL off right as you hit your site.

    Also, is your user ID that you use to admin the site one with uppercase or all lower case?

    For some reason I was thinking you had a different access issue. Some people are getting that one in INSTALL not UPGRADE. I blame vacation brain.

  16. Vernon Fowler
    Member
    Posted 3 years ago #

    At last, I have access again! Awesome. Thank you so much @Ipstenu - the old renaming the plugins folder to force deactivation did the trick. Hooray! Thank you for your perseverance.

  17. Yeah, I would have said that earlier but I had a brain fart. My bad! Glad you're up and running!

Topic Closed

This topic has been closed to new replies.

About this Topic