WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade to v2.0.2 on Win/IIS server, links are not working (9 posts)

  1. TheSmircher
    Member
    Posted 8 years ago #

    Hi,
    I've recently upgraded my main site to v2.0.2 from 1.5 and at first glance everything seemed fine. However, when I click on any archived post links it pops me back to the index page. Also, if I try and edit a post it pops me straight to the index page.

    I've rebuilt permalinks, re-installed, installed on a fresh database, disabled plugins, used default theme but I just can't get it to work.
    The site is hosted on Win2003/IIS.

    The strange thing is that I have some other WP driven sites on the same server that are using the same MySQL database to run version 2.0.2 and they are running fine for me.

    I've read and re-read a lot of the threads on this forum but nothing I've tried has worked.

    If anyone has any ideas I'd be only too glad to hear them!
    Thanks.

  2. TheSmircher
    Member
    Posted 8 years ago #

    Stranger and stranger...wordpress is installed in the root of my site. I've installed another copy in a subdirectory (content) and that works perfectly. Am I missing something completely obvious here?

  3. Chris_K
    Member
    Posted 8 years ago #

    Ok, that IS really weird.

    I wonder if it is related to the way wp2 internally handles rewrites vs. some interesting quirk of IIS.

    I might have to plug my win2k3 server back in and experiment with this.

  4. TheSmircher
    Member
    Posted 8 years ago #

    Both sites (root) and (content) are using the same database table.
    I've cleared all php files and wp folders from my root site and re-installed WP from scratch but still no joy in the root folder.

  5. Chris_K
    Member
    Posted 8 years ago #

    Both sites (root) and (content) are using the same database table.

    Same tables? Or just same db? If same tables, it'll definitely be wonky considering those URI fields in Admin (Options - General).

  6. TheSmircher
    Member
    Posted 8 years ago #

    Yeah, I see what you mean alright. It's really frustrating as I need WP to be installed in the root but no matter what I do , it doesn't work correctly. I've deleted the (content) WP install and am going to go through the (root) WP install with another fine toothcomb.

  7. Chris_K
    Member
    Posted 8 years ago #

    Perhaps... just perhaps...
    Suppose you install it to \content, but do a custom home page in the root that "refers" to the blog? There are some good threads on that topic here in the forums and over in the codex (codex.wordpress.org).

    Unfortunately, she-who-must-be-obeyed just mentioned it is supper time, so I can't dig out some useful links. ;-)

  8. TheSmircher
    Member
    Posted 8 years ago #

    Help me Obi Wan...oh sorry....flashbacks ;)

    It's funny, I was reading http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory just before I checked this thread, so I'll give this a try.
    Thanks for your help :)

  9. TheSmircher
    Member
    Posted 8 years ago #

    OK, I've had the site running with the index.php page in the root and the rest in a content folder for the past few days without any problems. It's weird though that I just can't get it all working in the root directory. WP1.5 worked fine from the root.

Topic Closed

This topic has been closed to new replies.

About this Topic