WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upgrade to 3.7 stuck at "Unpacking" (10 posts)

  1. Pricetx
    Member
    Posted 10 months ago #

    I run a few WordPress instances with the following setup:

    - php 5.4.20 (including zlib for auto updating)
    - nginx 1.4.2
    - mariadb 5.5.33a

    All of my WordPress instances upgraded flawlessly from 3.5 to 3.6 using the automatic updater. And currently, I can install / update plugins and themes without any issues on all of my WordPress installations.

    However, when I attempt to upgrade from 3.6.1 to 3.7, I get blank WordPress admin screen until eventually it displays the following:

    Downloading update from http://wordpress.org/wordpress-3.7-no-content.zip…

    Unpacking the update…

    I checked the nginx logs (which includes PHP), and I get the following with each attempt:

    2013/10/26 18:18:53 [error] 9102#0: *97669 upstream timed out (60: Operation timed out) while reading upstream, client: 81.157.3.49, server: [removed].com, request: "POST /wp-admin/update-core.php?action=do-core-upgrade&_wpnonce=3f9a9cb3be HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "[removed].com", referrer: "https://[removed].com/wp-admin/update-core.php?action=do-core-upgrade"

    I have tried increasing the timeout from the default value of 30 seconds to 600 seconds, but it still triggers the built in timeout of 60 seconds of the ssh-sftp-updater plugin.

    It is a dedicated server and is running on almost idle. I have checked in the wp-content/upgrade folder, and it is downloading and extracting the files to this location, it just isn't progressing beyond this stage.

    I have tried deleting the upgrade folder a couple of times to make the upgrade re-generate it. This didn't work.

    I have also tried disabling every plugin except for the sftp plugin, and this hasn't worked either.

    Does anybody have any suggestions I can try? I know somebody who runs Apache, and had no issues with using the ssh-sftp-updater, so I don't think it's that.

    My nginx configuration has not changed since the successful update from 3.5 to 3.6.

  2. Tara
    Member
    Posted 10 months ago #

    - If the auto update did not work, try manually re-uploading all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones. Read the Manual Update directions first!
    - Always backup everything (including your database).

  3. Pricetx
    Member
    Posted 10 months ago #

    - If the auto update did not work, try manually re-uploading all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones. Read the Manual Update directions first!
    - Always backup everything (including your database).

    I just attempted a manual update on one of my wordpress installations, and it worked fine.

    However, i'm still unsure as to why the automatic updater isn't working, and would like to get to the bottom of the issue still.

  4. Tara
    Member
    Posted 10 months ago #

    manual update on one of my wordpress installations, and it worked fine. However, i'm still unsure as to why the automatic updater isn't working, and would like to get to the bottom of the issue still.

    Are you self-hosting? No? Try contacting your hosting provider.

  5. Pricetx
    Member
    Posted 10 months ago #

    Are you self-hosting? No? Try contacting your hosting provider.

    I am hosting this myself on a dedicated server. :)

  6. Pothi
    Member
    Posted 10 months ago #

    When you host yourself, why would you need ssh-sftp-updater plugin (or any plugin) to let automatic updates work?

    Since you use nginx, I assume, you run php-fpm that can be configured to run as SFTP/SSH user.

  7. Pricetx
    Member
    Posted 10 months ago #

    When you host yourself, why would you need ssh-sftp-updater plugin (or any plugin) to let automatic updates work?

    Since you use nginx, I assume, you run php-fpm that can be configured to run as SFTP/SSH user.

    I run SSH SFTP Updater as it allows me to update / install things over SFTP instead of having to run an FTP daemon.

    When updating, I always SFTP into whichever account owns the wordpress files. However, i'll go test setting everything to chmod 777 temporarily on one of the sites and seeing if it fixes the updater.

  8. Pothi
    Member
    Posted 10 months ago #

    I run SSH SFTP Updater as it allows me to update / install things over SFTP instead of having to run an FTP daemon.

    Why not just leave it to the default method ("direct")?

    http://core.trac.wordpress.org/browser/tags/3.6/wp-admin/includes/file.php#L857

    As per the official docs, this can be done, if your PHP runs as SFTP user, which is possible with PHP-FPM. If your PHP runs as "www-data" or "nobody" or similar, you are right in doing what you've been doing so far.

  9. Pricetx
    Member
    Posted 10 months ago #

    Why not just leave it to the default method ("direct")?

    http://core.trac.wordpress.org/browser/tags/3.6/wp-admin/includes/file.php#L857

    As per the official docs, this can be done, if your PHP runs as SFTP user, which is possible with PHP-FPM. If your PHP runs as "www-data" or "nobody" or similar, you are right in doing what you've been doing so far.

    Thanks! Really!

    I've known for over a year now that there is some mysterious way you could get WordPress by default to use SFTP, so I've always used the SSH SFTP Updater plugin.

    To get PHP to execute as the correct user, I had to create a folder fpm.d, and in there have a config file for each site on it's own port. Then, in nginx I gave the specific PHP-FPM port for that site instead of the generic one.

    Now, instead of asking for details, it does it automatically, and WordPress updated flawlessly. This is great as it means that I don't even have to give my WordPress users shell access anymore, as PHP-FPM itself handles the authentication.

    Still doesn't explain why I couldn't update using the plugin, as it had worked for previous updates, and for a friend for this update, but I can't really complain, as this solution is far better than getting that working!

  10. Pothi
    Member
    Posted 9 months ago #

    Glad to know it worked.

Reply

You must log in to post.

About this Topic