WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade to 3.1: it keeps asking the database to be updated (15 posts)

  1. flapane
    Member
    Posted 3 years ago #

    Hi,
    after having upgraded from 3.0.2 to 3.1, it keeps asking:
    ----------
    Database Update Required
    WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.
    The update process may take a little while, so please be patient.
    -------------
    THEN:
    -----------
    Update Complete
    Your WordPress database has been successfully updated!
    ------------------------------------------------------------------

    The blog itself is working (http://www.albertoboccalatte.it/blog/) but it keeps asking for a database update if I log in into administration panel, so I can't write new posts or do anything.

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Try:
    - switching to the Twenty Ten theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides. You may need to try logging into your site to get this to kick in fully.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-running the upgrade manually.

  3. flapane
    Member
    Posted 3 years ago #

    Hi,
    I've just done what you wrote, and nothing changed.
    Thanks

  4. scythe944
    Member
    Posted 3 years ago #

    Do you have database backups? You might try dropping your wordpress database (be sure you have a working backup before you do that though!) and restoring the backup file.

    Then try to do the database update again.

  5. spenserbaldwin
    Member
    Posted 3 years ago #

    Had the same issue. Logging out then back in fixed it for me.

    Probably just a caching issue.

  6. flapane
    Member
    Posted 3 years ago #

    I've already logged out, but nothing changed :(

    @schyte
    The owner has a 10 days old backup, I'll keep it as the last try, because he'd loose a lot of posts.

  7. scythe944
    Member
    Posted 3 years ago #

    Log out, clear your browser cache, then try.

  8. flapane
    Member
    Posted 3 years ago #

    Yes I've cleared the Firefox cache before logging in.

  9. l7world.com
    Member
    Posted 3 years ago #

    I had the same problem on 1 of my sites but not the other (different hosts).

    After waiting a couple minutes and trying it again it worked.

    I'd guess wordpress is just having problems accessing your DB, just try again later.

  10. flapane
    Member
    Posted 3 years ago #

    Yes, I think that there's a problem in connecting with the sql db, too.
    I'll try later (I can't access phpmyadmin right now).

  11. RAMilewski
    Member
    Posted 3 years ago #

    Esmi,

    You're posting the same three steps for this problem everywhere.

    For many of us, they don't work.

    What's the procedure when those three steps fail?

    Thanks!

  12. flapane
    Member
    Posted 3 years ago #

    There was a problem connecting with the sql db ;)

  13. franklinbrew
    Member
    Posted 3 years ago #

    I'm having the exact same issue ... how did you correct the problem connecting with the sql db?

  14. flapane
    Member
    Posted 3 years ago #

    I just told the hosting farm that there were connection issues, and they fixed them.

  15. franklinbrew
    Member
    Posted 3 years ago #

    Thanks ... I'll try that.

Topic Closed

This topic has been closed to new replies.

About this Topic