WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade to 3.0 IMPLEMENTS a file upload limit of 2Mb (9 posts)

  1. caldwell
    Member
    Posted 4 years ago #

    Upgrade two different sites to WP 3. Once upgraded, when trying to add new media, a new warning shows up that file uploads are limited to 2Mb:

    Maximum upload file size: 2MB

    This is NOT a local server php.ini setting. That setting is 20Mb. (I run the server and have access to php.ini and can verify the settings there.)

    Sites running 2.9.2 do NOT have this issue on the same server with the same php.ini file.

    OK. What changed? I don't want to hack a bunch of sites to put .htaccess file entries just to fix something that should not have been broken by an upgrade.

  2. Andreas Mauf
    Member
    Posted 3 years ago #

    Having the same issue...

  3. xuxa
    Member
    Posted 3 years ago #

    Same here...

  4. bradee
    Member
    Posted 3 years ago #

    Same here.

  5. webgirl
    Member
    Posted 3 years ago #

    Same here. Changed the setting in php.ini and could see that it was changed on my server via phpinfo and then tried to add it to wp-config and still the uploader showed 2MB.

    3.0.3

  6. xuxa
    Member
    Posted 3 years ago #

    Sorry everyone... I got mine working and forgot to post my solution. If I remember correctly, I simply changed the upload_max_filesize and post_max_size lines in /etc/php5/apache2/php.ini . They now look like this:

    post_max_size = 80M
    upload_max_filesize = 20M

    I might have needed to restart apache with "/etc/init.d/apache2 restart" on my debian-based wordpress server.

    I hope that's helpful! I'll be happy and to try and reverse engineer if people have questions.

  7. Andreas Mauf
    Member
    Posted 3 years ago #

    Did you checked the upload settings in /wp-admin/ms-options.php? There is a max file size limit too.

  8. coupee36
    Member
    Posted 3 years ago #

    did you ever correct your problem ?? i need help i am trying to post blogs on a self hosted site.. but i cant upload any media that is greater than 2mb its frustrating.. thanks.

  9. gabrielamarquescosta
    Member
    Posted 3 years ago #

    Hi there.
    I was having the same issue. I have wordpress 3.1.2 and I was able to get arround with this problem by changing my php.ini like "xuxa" said.

    I hope all of you that are having this problem can get it fixed.

    Cheers.

Topic Closed

This topic has been closed to new replies.

About this Topic