WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upgrade to 3.0 Fails (41 posts)

  1. ronblaisdell
    Member
    Posted 4 years ago #

    Receiving the following error message:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2964967 bytes) in /home/content/.../html/wp-includes/http.php on line 1363

    And the upgrade process stops.

    Any ideas other than doing a manual update?

  2. Not unless you can allocate more memory to PHP. It's the size of the upgrade, IIRC. They're working on trimming it down, but not every host is happy with it.

  3. DavidLari
    Member
    Posted 4 years ago #

    I got the same error on the same file on the same line number doing the automatic upgrade. Hosting on 1and1.com. I had to resort to upgrading the old fashioned way and that worked.

  4. fendeanson
    Member
    Posted 4 years ago #

    I am hosting one 1and1 too. I'm running RC3 and when I tried to upgrade to 3 it just gets stuck at the "downloading .zip file" step.

  5. quicksound
    Member
    Posted 4 years ago #

    same here =(

  6. fendeanson
    Member
    Posted 4 years ago #

    I'm thinking this must be a bug in RC3... either that or a problem with 1and1.

  7. drokkon
    Member
    Posted 4 years ago #

    I'm on 1and1, but I'm pretty sure I can change the allocation. What lines in what file do I have to change to what amount in order to have enough memory for the auto install?

  8. Twolanz
    Member
    Posted 4 years ago #

    I had the same error on one of my updates. I tried disabling all of my plugins and the auto-update worked flawlessly.

  9. DavidLari
    Member
    Posted 4 years ago #

    Okay, found a solution for 1and1 hosting:
    1. Create a file called php.ini
    2. Put this text in it: memory_limit = 64M
    3. Save it and upload it to the /wp-admin directory.

    Now you should be able to do the automatic upgrade.

  10. Andrew Nacin
    Lead Developer
    Posted 4 years ago #

    We're in the process of pushing out a plugin for this: http://wordpress.org/extend/plugins/memory-bump/

    In the meantime, you can also add this to your wp-config.php file:

    define('WP_MEMORY_LIMIT', '256M' );

    The issue is that WP *may* need more than the default 32 MB to upgrade to 3.0, due to the increased package size over 2.9. This is a "known issue".

    3.0 handles this by always bumping you to a very high memory limit in the admin area, so you won't see this once you've hit 3.0.

  11. AlwaysWorking01
    Member
    Posted 4 years ago #

    Nacin If you would please, cause I know you all have your brains together on things :) Please tell us where to put the define('WP_MEMORY_LIMIT', '256M' );
    On the phone with IX now trying to resolve this so our other blogs don't have the same goat rope.

    Thanks

  12. Andrew Nacin
    Lead Developer
    Posted 4 years ago #

    The plugin I linked to is now packaged, so it'll work: http://wordpress.org/extend/plugins/memory-bump/.

    For the constant, see http://codex.wordpress.org/Editing_wp-config.php.

  13. AlwaysWorking01
    Member
    Posted 4 years ago #

    FIXED IT!!!

    1. PRIOR to upgrading to 3.0 first do the below.

    2. Deactivate all plugins, install the "MEMORY BUMP" Plugin http://wordpress.org/extend/plugins/memory-bump/

    3. Activate it, and then activate all other plugins, takes about a minute.

    Upgrade to 3.0 and it works!

    Tried this first without deactivating plugins and it didn't work.

    Thanks!

  14. fendeanson
    Member
    Posted 4 years ago #

    It's still not working for me. I'm not having errors about running out of memory, the update process is just stopping at the downloading zip file stage. Any thoughts on what this is?

  15. williemanillie
    Member
    Posted 4 years ago #

    I appreciate all the information. I am waiting to perform the upgrade until there seems to be a good fix.

  16. Andrew Nacin
    Lead Developer
    Posted 4 years ago #

    fendeanson: that might be because your server is hiding errors. If it is hanging at the download, this is almost surely your issue. I will update the plugin description to account for hidden errors making it look like you're stalled at the download step.

    williemanillie: the plugin *is* the fix, so I would test it out. We've known about the potential for this issue when upgrading to 3.0 for a few months now. We mitigated it the best we could and we further prepared for it by readying this very simple plugin.

    Hope that helps.

  17. youradu
    Member
    Posted 4 years ago #

    To people who want to know where to post the

    define('WP_MEMORY_LIMIT', '256M' );

    statement in the wp-config.php file, you can put it anywhere. It is a file that has definitions. You can put it anywhere in the file.
    I just put that for my site
    Short Articles and it works like a charm.

  18. revivetv
    Member
    Posted 4 years ago #

    thank you SO much for that plugin, nacin! installed it and it worked like a charm! you saved a bunch of headaches for a wordpress amateur.

  19. Andrew Nacin
    Lead Developer
    Posted 4 years ago #

    youradu: To be fair, it needs to be before the line that says "That's all, stop editing! Happy blogging."

    revivetv: Glad we could help!

  20. AAYUSLASH
    Member
    Posted 4 years ago #

    since i have upgraded to version 3, i cant upload or install new themes or plugins, i cant even upload wordpress version 3 again, i get this message -Incompatible Archive. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

  21. stork123
    Member
    Posted 4 years ago #

    I'm where you are... I'm in the middle of a failed upgrade.
    What to do from here?

  22. Zazoh
    Member
    Posted 4 years ago #

    I'm with Fendeanson, did the plug in and no go. Still at downloading zip, or that is what dashboard says. I have two hosts, on one it installed fine, on 1and1 it didn't, so there is something different there. Most likely permissions and not memory, but there are no errors either, which is bad, there should at least be a timeout error.

  23. Account Cancel
    Member
    Posted 4 years ago #

    I had the same problem (stuck at downloading...). I'm on 1&1. The plugin did not work. The problem turned out to be that 1&1 defaults to PHP4 instead of PHP5. I found the fix here: WordPress on 1&1

  24. vboogieman
    Member
    Posted 4 years ago #

    Only a couple of my users are reporting problems with the wordpress 3.0 upgrade.

    One of my editors always gets the error message

    Fatal error: Call to undefined function is_multisite() in /home/site10/public_html/wp-includes/wp-db.php on line 505

    I've tried adding define('WP_MEMORY_LIMIT', '256M' ); to my wp-config.php

    tried http://wordpress.org/extend/plugins/memory-bump/

    this really sucks that I am stuck with people unable to login

  25. estern23
    Member
    Posted 4 years ago #

    I was getting this issue too with 1and1 hosted sites:

    In my case when i clicked the upgrade link from wp-admin i got a 500 error from 1and1.

    Error 500 - Internal server error An internal server error has occured! Please try again later.

    Things i tried:
    - disabled all plugins (didnt work)
    - I added the plugin for memory (didnt work)

    This method did work for me:

    Added "AddType x-mapp-php5 .php" to the .htaccess (in the main wp folder) file right before the </IfModule>, Saved and then clicked the upgrade link again.
    Worked like a charm.

    Just had to do a db update when the screen promoted me to. I think this is standard with the upgrade though.

    Hope this helps people that are still having issues.

    -estern

  26. vboogieman, most people report that a manual update fixes this.

  27. cashalerts
    Member
    Posted 4 years ago #

    For estern23, thanks for your advice. I am with 1and1 and it just gets stuck on the downloading screen. I have tried the memory bump plugin but did not have any result.

    I am interested in trying your technique but can't find the .htaccess file. I am using a theme - is this why?

    If you can tell me how I get to that folder I would be most grateful,

    Thank you very much,

    Jon

  28. birdnesty
    Member
    Posted 4 years ago #

    Did what Alwaysworking01 advised. and it worked!!

    1. PRIOR to upgrading to 3.0 first do the below.

    2. Deactivate all plugins, install the "MEMORY BUMP" Plugin http://wordpress.org/extend/plugins/memory-bump/

    3. Activate it, and then activate all other plugins, takes about a minute.

  29. cashalerts
    Member
    Posted 4 years ago #

    Thanks Birdnesty

    Unfortunately I am still having trouble. I have deactivated all my plugins except the memory bump plugin. I click on Automatic Upgrade and after a few seconds it just freezes.

    Perhaps it's because of my theme?

    Anyway, thanks for trying to help. Does anybody else have any other ideas or the same issues?

    Thanks,

    Jon

  30. cashalerts
    Member
    Posted 4 years ago #

    Another thing I could try is by manual install. However, as I am new at this, I don't now how to install it with all my existing content - I do not want to re-do all my posts.

    Any advice would be greatly appreciated.

    Jon

Topic Closed

This topic has been closed to new replies.

About this Topic