WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade to 2.6 OK but now it won't 'remember me' (13 posts)

  1. MooMag
    Member
    Posted 6 years ago #

    I upgraded to 2.6 this morning with no apparent problems, everything seems to be working fine except the 'remember me' on the admin panel login, doesn't actually remember me anymore.

    Anything I can do to fix it?

    All help gratefully received, thanks.

  2. 7milesdown
    Member
    Posted 6 years ago #

    I have this issue as well aside from the permalinks woes.

  3. Anonymous
    Unregistered
    Posted 6 years ago #

    I'm having the same issue.

    wp-login.php isn't redirecting me to wp-admin after having checked 'Remember me'. However, I know the cookie is there becauseI'm not required to login if I type the url to wp-admin out manually.

    Is this a bug with web servers not incorporating SSL or something else?

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    1. Clear your cookies.
    2. Make sure you're using the same URL that you have on the Settings->General page.

  5. mikejandreau
    Member
    Posted 6 years ago #

    I noticed this happened, but only on one of my blogs.

    The others all remember me correctly, with or without the SSL support.

    Not a big deal, since Firefox does all the remembering for me. Just gotta click the login button.

  6. Anonymous
    Unregistered
    Posted 6 years ago #

    I've tried clearing my cookies and I'm using the same url as on the settings-> general page.

    I've also noticed that users who don't have access to do anything but modify their profile and see posts in categories pertaining to them are being sent to the dashboard when wp-login.php is supposed to send them to their profile page?

    I'm using wordpress as an internal employee website and there are hundreds of people in this organization who rely on the 'Remember me' functionality of WordPress.

    Yesterday I upgraded to 2.5 and none of us had an issue with the redirection so I think it has something to do with the new SSL stuff that was put in 2.6?

  7. Anonymous
    Unregistered
    Posted 6 years ago #

    I know the 'Remember me' cookie is there because if I type in the wp-admin url manually it doesn't ask me to login. However, in using wp-login.php it brings up the login box regardless.

    Edit: I've also tried using a completely different browser (one that I never use to view this site) and I get the same problem.

  8. Anonymous
    Unregistered
    Posted 6 years ago #

    Well I've put a bandaid on my problem by using wp-admin/profile.php for the 'login' link. It acts the same as what wp-login.php used to for most of the site's users

    I think 2.5's wp-login.php was smart enough to determine if someone was 'remembered' as logged in and if not, asked for usr/passwd. It could also determine whether or not a 'remembered' user had access to edit or review posts and if they did, it would redirect-to the dashboard, and if not, it would redirect-to the profile page. Because of this functionality, one only had to link to wp-login.php as the 'login' link to enable admins to get to the dash or regular subscribers to get to their profile. That functionality was removed for some reason or the default case for the $action switch is borked. This issue seems to occur on fresh installations as well.

  9. DouglasVB
    Member
    Posted 6 years ago #

    The same thing is happening to me. I keep getting kicked out to the "please log in again" wp-login page. Once I cleared my cookies and cache, it started dumping me there without any error messages or requests for me to log in, only showing me the standard login screen.

    Like with others, I too can access the admin panel by typing in [myblog.com]/wp-admin/. However, I have found that trying to save changes to widgets or any changes under the settings tab dumps me back out to the wp-login page. That issue could be due to the tilde problem, though. (My site is hosted on a [biguniversitydomain.edu]/~[mysite]/ address which has given me problems ever since upgrading to 2.5.0 with redirect loops while performing certain tasks that change between 2.5, 2.5.1, 2.5.2, and now 2.6.)

    Looking forward to a full solution!

  10. johnoz
    Member
    Posted 6 years ago #

    Try adding a '/' after wp-admin
    eg 'http://www.yourblog/wordpress/wp-admin/'

    Worked for me.

  11. NickCorcodilos
    Member
    Posted 5 years ago #

    Hey, johnoz, you da man! :-) Simplicity. I was using wp-login. Your solution is correct! Now I login with:

    http://yoursite.com/blog/wp-admin/

    It remembers.

    Thanks for taking time to post and help us out!

  12. pureananda
    Member
    Posted 5 years ago #

    hi

    i faced this problem, then i came here and figured it out.

    i had changed settings-->general-->blog address.

    i went back, made sure that the address matches the wp address.

    bob's my uncle

    cheers

    ananda

  13. BionicDrew
    Member
    Posted 5 years ago #

    I have tried all of the above methods and I still have no joy. I have tried upgrading, moving around, changing the url. Is there anything I am missing? Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic