WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade to 2.6 - Admin Login Problem (63 posts)

  1. Anonymous
    Unregistered
    Posted 5 years ago #

    I'm having the same problem, tried all the listed solutions from 2.5.1

    This version could break the reputation of wordpress - I'm really disappointed. Having tried everything I've reverted to backup and even that was hard to get working.

    Back to the drawing board guys!

  2. catsudon
    Member
    Posted 5 years ago #

    I'm having this same exact problem and have tried clearing cache, cookies, even used a machine I've never used to browse my blog before but same problem. I knew I turned off all my plugins on my 2nd upgrade attempt but the behavior remains. Will keep checking this thread for a solution!

  3. AdultFilmLegend
    Member
    Posted 5 years ago #

    I am using Safari 3 and Firefox 3 on a Mac. Doesn't work. I then tried IE7 on a Vista machine and it doesn't work.

  4. SirKillelort
    Member
    Posted 5 years ago #

    I am using Opera 9.51 on a Vista machine, and I also tried Firefox 3 - I have the same problem and cannot log in anymore. I'm really unhappy.

  5. turtletrax
    Member
    Posted 5 years ago #

    I manage three blogs. The first one (my test blog) upgraded with no issues. The second one resulted in the damned redirect back to the login page loop. I looked here and saw that someone had solved the problem by deleting cookies. I did this (Opera 9.5) and got back in.

    Today I upgraded the third blog. Same bloody loop. Aha, says I, I can fix this. I deleted cookies. Same loop. Deleted cookies, cache, restarted Opera. Same loop. Tried Firefox 3.0. Got on without a problem. Went to my second machine, used Opera 9.5. Logged in without a problem! Back to the machine where I need to login. Same &$&#@&* loop. Read some more here. Tried the wp-admin.php?logout trick. Doesn't work.

    I tried carefully checking cookies after each step. First I deleted the cookie. I tried to login, got a cookie. Deleted it. Did not work, wound up with a new cookie. Tried the logout fix, checked the cookies: logged in cookie was gone, test cookie still there. Tried to login, same [expletive deleted] loop. Cookie from hell was back.

    I'm out of ideas. Clearly this is Opera fighting with WordPress, but I can't tell who's at fault. Thought about hacking wp-login.php but after looking at it, gave up on that idea unless I get really desperate. That could be any time now, this is my wife's blog and she's getting really impatient.

  6. turtletrax
    Member
    Posted 5 years ago #

    AHA! Folks, when deleting cookies in Opera, DO NOT use the cookies|manage cookies button. Instead, go to the Content dialog and use Manage Site preferences. Edit or add your site there, then use the cookies tab to find and delete the cookies. Once I did that, everything worked again.

    Hope this helps some poor soul. There seem to be a lot of variations on this problem, but it's clear to me that many of them are caused by persistent cookies.

    We hatesss cookieses.

  7. SirKillelort
    Member
    Posted 5 years ago #

    That doesn't change anything. And it also doesn't work with Firefox, so I don't think it is a problem of Opera. I really don't know what to do anymore.

    edit: I tried with IE7, also doesn't work. :-(

  8. DenisLafont
    Member
    Posted 5 years ago #

    Same problem while upgrading my site on Enterprise open source softtare.

    The "clear private datas" trick did not work.
    The problem was that I did not desactivate plugins.
    To solve the problem in in such cases:

    - Connect to your database ( via PhpMyAdmin for example)
    - Find the wp_options->active_plugins row
    - Edit it, and put:
    a:0:{}

    in that row.

    Solved the problem for me.

  9. turtletrax
    Member
    Posted 5 years ago #

    As I said:

    There seem to be a lot of variations on this problem, but it's clear to me that many of them are caused by persistent cookies.

    I think you missed that, SirKillelort ;)

    Anyone who sees the loop back to wp-login in only one browser probably has a cookie problem. That was my case and in reading the threads on this, that's the case for a lot of other people too. There are clearly similar but different problems. Obviously, if it fails in more than one browser then it's not a cookie issue. Not sure why anyone would think it was.

  10. SirKillelort
    Member
    Posted 5 years ago #

    Well, the problem is, it didn't work in all THREE browsers, so I don't think it is about cookies. ;-) I will try to deactivate the plug-ins.

    edit: It worked! Woooooohaaaa!!! :D

  11. julieannevz
    Member
    Posted 5 years ago #

    My logging in problem seems to be different from most listed here. I've deleted my .htaccess file and edited the database wp_user file.

    I've also deleted all the files in wp_admin and wp_includes, then copied all the files over from 2.6.1 download, and the upgrade ran through okay.

    Here's what happens for me when I attempt to log in.:

    This URL is Not the same as the normal log in screen:
    http://scubadiving-blog.com/wp-login.php

    When I fill in my username and psswd, the URL displays like this:

    http://scubadiving-blog.com/index.php/wp-login.php

    and, because the "index.php" shows up, I get an ERROR 404

    Can someone please tell me which file causes that redirection and how I should fix it?

    I have deleted .htaccess so it can't be that which is redirecting.

    Thanks very much in advance.

    Julieanne

  12. julieannevz
    Member
    Posted 5 years ago #

    BTW, what I described above happens in IE, Flock and Firefox

  13. julieannevz
    Member
    Posted 5 years ago #

    The following fix might help some people:

    http://trac.wordpress.org/ticket/7322

  14. julieannevz
    Member
    Posted 5 years ago #

    sorry to keep writing but I've been unable to log in for 5 weeks now. My blog has a PR of 3 but has a lot of broken links I need to fix.

    I read somewhere that the index.php is not necessary for 2.6.1 version, so I renamed the index.php and the blog doesn't appear.

    I can't work out what to do.

    This is still what's happening:

    This URL is Not the same as the normal log in screen:
    http://scubadiving-blog.com/wp-login.php

    When I fill in my username and psswd, the URL displays like this:

    http://scubadiving-blog.com/index.php/wp-login.php

    and, because the "index.php" shows up, I get an ERROR 404

    Can someone please tell me which file causes that redirection and how I should fix it?

    Thanks in advance!

  15. computerpeach
    Member
    Posted 5 years ago #

    I have a fresh install and this is happening... running vista and firefox3

    I have no plugins activated on the fresh install.

  16. julieannevz
    Member
    Posted 5 years ago #

    I finally found the solution - it's right here on the forums, I just had to hunt a lot to find it.

    Here's the thread
    http://wordpress.org/support/topic/194159?replies=6

    And, here's the site that has the instructions:
    http://www.tamba2.org.uk/wordpress/site-url/

    The name of the URL and the siteurl in the wp_options table in the database was my problem

  17. bitchinmona
    Member
    Posted 5 years ago #

    This is a screencap of what I'm getting. I just want to make sure this is the same problem others are experiencing or if I'm on the wrong track:

    http://pixelrelish.com/images/screencap.gif

    Can someone please point me in the right direction?

  18. RossGoodman
    Member
    Posted 5 years ago #

    I have just checked the instructions given at http://www.tamba2.org.uk/wordpress/site-url/

    Didn't work for me:

    When I follow the instructions.
    I then go to http://www.RossGoodman.com/wp-login.php
    I can log in and it takes me to the admin pages - great !
    I then click on View Site, I can see my site and I am logged in - great !
    I then click on "site admin" (it claims I am logged in) but it sends me to the login screen.

    Arggghhhh !!!!

    I can still click on "Write a Post" and get access to the admin pages so that's what I am still using.

    Ross

  19. ccpyle
    Member
    Posted 5 years ago #

    I was ready to pull my hair out after a live upgrade, and after trying 20 different solutions, finally realized that Zonealarm was blocking the cookies. D'oH! Shutdown Zonealarm and logged right in.

    Just in case anyone else is running a security suite/firewall on their PC.

  20. henriqueu
    Member
    Posted 5 years ago #

    I can't login because when I put the user and pass and click enter...the page stay blank...Anyone can help me?

    Thanks

  21. gamini
    Member
    Posted 5 years ago #

    Denis lafont's solution above

    - Connect to your database ( via PhpMyAdmin for example)
    - Find the wp_options->active_plugins row
    - Edit it, and put:
    a:0:{}

    in that row.

    worked for me

  22. mangozilla
    Member
    Posted 5 years ago #

    Fixes after days of frustration!!! CCpyle's fix above worked for me. DISABLE FIREWALL. I use CA Etrust, and I can now login if I close the Etrust firewall (leave the windows firewall in place). Don't know why, and I'm not sure of teh security risks, but at least I can access my admin panel. I hadn't seen that solution on the multiple other posts regarding login issues. Glad I found this one!

  23. mores
    Member
    Posted 5 years ago #

    drluckyspin's solution helped me with my problem with safari.
    go to http://www.domain.com/wp-login.php?action=logout
    Then log in again. Works prefect with WP 2.6.2

  24. simonr
    Member
    Posted 5 years ago #

    I had a really wierd one! The failure for me only happened several weeks after my upgrade, between one longin and the next. I tried all the usual stuff, then deleted ALL the plugin files using my ftp program and things were fine.

    I've no idea why, because putting the plugins back in place hasn't screwed anything up.

    Odd!

    Simon

  25. hit1million
    Member
    Posted 5 years ago #

    I ran into the same problem when upgrading from version 2.0.2 and 2.3.1 to 2.6. I spent a few days working on this so I thought i'd share my fixes.

    I had two seperate issues.

    1. I was unable to login. Even resetting the password and logging in with the new password kept reverting to the login page. It didn't display any error messages.

    FIX: The fix that I used was to rename the wp-content/plugins folder to something like wp-content/plugins.old. Then login and rename the folder back to the original name.

    Even though I followed the instructions to disable all the plugins this didn't help. Renaming the folder was the only way that I could fix this.

    2. The second problem was that I kept getting a blank homepage. I could get into the admin panel but the homepage showed nothing.

    FIX: Login to the wordpress admin panel. Click on design and check to see what Theme wordpress is using. In my instance it was totally blank, even though the wp-content/themes had a theme installed. All I did was uploaded and activated another theme. This then fixed the problem. I was also able to revert to my previous theme.

    Hope this helped someone.

  26. patsar
    Member
    Posted 5 years ago #

    I had the same problem after upgrading from 2.6 to 2.6.2.

    Denis lafont's solution worked also for me

    - Connect to your database ( via PhpMyAdmin for example)
    - Find the wp_options->active_plugins row
    - Edit it, and put:
    a:0:{}
    in that row.

    Panagiotis

  27. apolaine
    Member
    Posted 5 years ago #

    I found the easiest way to deal with this is just to rename the plugins folder in wp-content (I rename mine to plugins_). It kills the plugins, which enables you to log in and upgrade. Then rename it back again to plugins. No need to mess around in PHPMyAdmin.

  28. Booh
    Member
    Posted 5 years ago #

    apolaine's trick worked for me.

    just to rename the plugins folder in wp-content (I rename mine to plugins_). It kills the plugins, which enables you to log in and upgrade. Then rename it back again to plugins.

    All of my plugins were deactivated. I don't get it.

    I'm Surprised this problem is not addressed by WP. In 3 1/2 years I've never encountered anything like this. There should be a note about the problem in the install instructions.

    It took 24 hours to research and solve.

  29. pinkfrankenstein
    Member
    Posted 5 years ago #

    Plugins not being deactivated was the problem for me.

    I went into the database via phpMyAdmin and reset the plugin activation via this post from above:

    - Connect to your database ( via PhpMyAdmin for example)
    - Find the wp_options->active_plugins row
    - Edit it, and put:
    a:0:{}

    This worked for me and i was able to reactivate plugins after this.

  30. barry.timm
    Member
    Posted 5 years ago #

    I tried this all...none of it worked until I used FTP to delete all the CACHE files in my /WP-CONTENT/ directory.

    As soon as I deleted the cache, I was presented the admin login screen which had been blank, and was able to login, and my site is also back up.

    It may have been corruption from me not deactivating the plug-ins prior to my last upgrade....lesson learned!

    NOW, to re-install the plugs which I'd also deleted.

Topic Closed

This topic has been closed to new replies.

About this Topic