WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upgrade to 2.1 FAILED (6 posts)

  1. blork
    Member
    Posted 7 years ago #

    I did everything right -- verified my SP was using the right versions of PHP and MySQL, did all the appropriate backups, deactivated the plugins, and followed the directions exactly (although they aren't very clear).

    When I got to the part about running the install script I knew I was in trouble. I couldn't even log in. All I got was a blank page. My blog was hosed too -- just a blank page.

    I tried a few other things, re-uploading the wp-config from my backup, etc., but all I could get was the blank page.

    Fortunately, I had my backup, so I restored the previous version and it works. But does anyone reading this have any idea what went wrong? It's pretty frustrating to not even have an error message, just a blank page!

    BTW, does anyone know what the heck this means: (From step 3) "Get the latest and greatest WordPress and upload it to the WordPress directory, overwriting all the files that exist there only after you have delete the old files"

    Uh... if you've deleted the old files then there is nothing to overwrite. Is that just badly written, or am I missing something?

  2. Chris_K
    Member
    Posted 7 years ago #

    When I got to the part about running the install script I knew I was in trouble. I couldn't even log in.

    I'm not quite following this part -- you don't need to log in to run the upgrade script. Did you run it?

  3. blork
    Member
    Posted 7 years ago #

    Well, I typed in the address in my browser (...MYBLOG/wp-admin/upgrade.php), hit enter, and all I got was another blank page.

  4. blork
    Member
    Posted 7 years ago #

    Follow up: I tried again tonight, and the upgrade SUCCEEDED. I think the original problem was probably due to "pilot error." I might have missed a critical folder when I was uploading the new version.

    Sorry about that!

    Consider this one RESOLVED. (In fact, you can even delete it, if possible.)

  5. sbyasak
    Member
    Posted 7 years ago #

    What did you do differently the second time around? I'm having the exact same problem where I get a blank page when I try to run upgrade.php.

  6. Stagecoach
    Member
    Posted 7 years ago #

    Yes, I'm having the same problem. Please tell us what you did

Topic Closed

This topic has been closed to new replies.

About this Topic