WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] Upgrade to 2.0.16 wiped store settings (6 posts)

  1. lickthespoon
    Member
    Posted 9 months ago #

    I'm not entirely sure how or why this happened...but when Mike announced 2.0.16 I duly upgraded having regressed back to 2.0.14.
    Now I don't don't know if it was how I did it, I did upgrade via the plugin panel, but all of my shop settings were reset, all pages vanished, payment gateways, shipping, everything wiped.

    I'm now attempting to restore everything including database from last night's backup. So I would caution people upgrading pending more regression testing as I believe this release needs more testing. Or at least make sure you've got a backup before upgrading!

    http://wordpress.org/plugins/woocommerce/

  2. mikejolley
    Member
    Plugin Author

    Posted 9 months ago #

    Th only reason this would happen is if you used wp admin to delete a version. There is an uninstall script which cleans up settings when uninstalled.

  3. lickthespoon
    Member
    Posted 9 months ago #

    Hi Mike, I got my host to restore a backup last night, so i'm now on 2.0.14.
    As you say I think it may have happened as I had two Woocommerce versions in the directory as I was switching between 2.0.14 and 2.0.16. On the plugins page I clicked 'delete' on the the older version, so maybe this stripped out my database settings in some way. It certainly appeared that I lost a lot of database settings related to store setup.

    I'm now back stable after the restore and will let the dust settle a bit before updating again to 2.0.16. I guess the moral is always keep a site and database backup before upgrading just in case!
    Thanks for your prompt replies.

  4. nshriyan
    Member
    Posted 9 months ago #

    Hello Mike
    I have WordPress site and was using woo commerce plugin to sell my jewellery. I recently upgraded to ver. 2.0.16 and my entire shop got wiped out! The plugin won't activate now and cites a fatal error. I am using catch everest theme and this is my site: http://www.naynastudios.com
    Would really appreciate your help !

  5. mikejolley
    Member
    Plugin Author

    Posted 9 months ago #

    @nshriyan need to tell us the fatal error

  6. nshriyan
    Member
    Posted 9 months ago #

    Hello Mike thank you for replying this is what I am seeing:

    Fatal error: Class 'WC_API' not found in /home/thewhite/public_html/wp-content/plugins/woocommerce/woocommerce.php on line 145

Reply

You must log in to post.

About this Plugin

About this Topic