WordPress.org

Ready to get started?Download WordPress

Forums

WP Security Audit Log
[resolved] upgrade to 0.6 = infinite DO loop in Refresh Alerts List (4 posts)

  1. friedVol
    Member
    Posted 7 months ago #

    I have a single-site WP site and have greatly appreciated your WP Security Audit Log (WPSAL) plugin.

    I upgraded today to v0.6 and found the Audit Log Viewer is in a continuous refresh/loading mode. It's been refreshing for a half-hour now. That is, a continuously rotating circle is to the immediate right of the "refresh security alerts" button. It never stops.

    I logged out, closed my browser and logged in. The Audit Log page still continuously refreshes. The Audit Log did not show my logging out and logging in action.

    I read the "Upgrade to 0.6 = empty log in viewer" posts. I understood the update deleted the old log - no problem. I deactivated and then deleted the previous WPSAL plugin version (data and all files) and then fresh-installed v0.6. The audit log is still continuously refreshing. It still does not show my logging in or logging out or that I installed the plugin.

    Per the "Upgrade to 0.6 = empty log in viewer" posts, I went into my database.

    In the wp_wordpress_auditlog table, there is the alert, "The following indexes appear to be equal and one of these should be removed: PRIMARY, EventNumber.

    In the wp_wordpress_auditlog_events table, there is the alert, The following indexes appear to be equal and one of these should be removed: PRIMARY, EventID."

    I'm guessing PRIMARY should be removed from both tables because it does not appear in either table while EventID and EventNumber do, but I'd rather hear it from the plugin authors.

    http://wordpress.org/plugins/wp-security-audit-log/

  2. friedVol
    Member
    Posted 7 months ago #

    Sorry, I just realized I hadn't actually asked for help.

    Would you please tell me what is making the Security Audit Log continually refresh without end, thus never showing log activity?

    Would you please tell me what I need to do to fix this problem? Should I remove the PRIMARY index from both of the WP database tables?

  3. WPWhiteSecurity
    Member
    Plugin Author

    Posted 7 months ago #

    Hi friedVol,

    I'd recommend a total cleanup and a new install of the plugin by following the below procedure. Unfortunately it is quite difficult sometimes to troubleshoot such issues without having access.

    1. Uninstall plugin
    2. Ensure these two tables are deleted:

    2.a. wp_wordpress_auditlog
    2.b. wp_wordpress_auditlog_events
    (note: the prefix of the tables depends on the prefix you use)

    3. Run the below query to return all of the plugin options stored in the wp_options table in the WordPress database (again, the prefix of the table depends on your database prefix):

    SELECT * FROM wp_options WHERE option_name like 'WPPH%';

    Once the values are returned, delete all of them.

    4. Download and re-install the plugin.

    If the issue persists, if possible we would like to have a look ourselves. This will help us identify the problem and fix your issue as soon as possible.

    So if the problem persists, drop us an email on plugins@wpwhitesecurity.com.

    Thank you again and sorry for any inconvenience caused.

  4. WPWhiteSecurity
    Member
    Plugin Author

    Posted 6 months ago #

    Hi Friedvol,

    Just to let you know that we fixed all database issues with the latest update.

    Please upgrade your version of the plugin and thanks for the support.

    Should you have any queries, do not hesitate to contact us.

Reply

You must log in to post.

About this Plugin

About this Topic