WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade Problems :( (7 posts)

  1. mynameisdanmorris
    Member
    Posted 8 years ago #

    Hello!

    I attempted an upgrade to WP2.0 today, long story short it went wrong. I made a backup of my previous installation before attempting the upgrade, I installed 2.0 fresh after it went wrong and that went fine, but when I restore the backup and view my site it is giving me the message "looks like you haven't installed WordPress yet". Any ideas would be greatly appreciated. Thanks.

  2. MOBINKC
    Member
    Posted 8 years ago #

    I think I had a similar problem at one point.

    Try /wp-admin/upgrade.php - sounds like you may need to re-run your upgrade process in 2.0

    Alternately - double-check the information in your wp-config.php file as well.

  3. mynameisdanmorris
    Member
    Posted 8 years ago #

    I have checked wp-config, and that's fine. I have just tried /wp-admin/upgrade.php and that said everything is done and is fine, I returned to my site and still none of my previous posts are visible. I have deleted my Database, created it again with the same details, installed the backup and that's not working either

  4. MOBINKC
    Member
    Posted 8 years ago #

    If you can somehow get into the Administrative interface, try changing your theme to the default temporarily. That may help...

  5. moshu
    Member
    Posted 8 years ago #

    Hmmm...
    I have deleted my Database, created it again with the same details, installed the backup and that's not working either
    If you did it in this order it will not work. You cannot import a 1.5.x database into a 2.0 install. Import works properly only between the same versions.
    So, the proper order is:
    upload /install previous version's files
    import backup db
    delete old files, upload new files
    upgrade

  6. Ryan Duff
    Member
    Posted 8 years ago #

    moshu: if he has a backup of his 1.5 db, he should be able to upload the 2.0 files and just run upgrade.php again.

  7. moshu
    Member
    Posted 8 years ago #

    Yes, that's right - it's just after uploading the 2.0 files they always want to "see it", before the upgrade, LOL

Topic Closed

This topic has been closed to new replies.

About this Topic