WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Upgrade Problem in RC3 (33 posts)

  1. rprins
    Member
    Posted 8 years ago #

    When pointing my browser to upgrade.php after uploading all of the RC3 files, I get the following errors:

    WordPress database error: [Table 'rprins_wordpress.wp_usermeta' doesn't exist]
    SELECT meta_key, meta_value FROM wp_usermeta WHERE user_id = '1'

    Warning: Cannot modify header information - headers already sent by (output started at /home/.sacko/rprins/lazyi.net/wp-includes/wp-db.php:102) in /home/.sacko/rprins/lazyi.net/wp-admin/upgrade.php on line 10

    I am currently running 1.5.2. I saw that somebody else had this problem, but it was buried in an unrelated thread, and I thought I would open this one to give it more visibility. If you have any ideas, I'd love to hear them.

    Thanks!

  2. MichaelH
    Member
    Posted 8 years ago #

    It does complete the upgrade, even with those messages, right?

  3. abrazell
    Member
    Posted 8 years ago #

    Did you delete User ID 1 from your 2.0 database?

  4. zqw
    Member
    Posted 8 years ago #

    Hey, I just posted about the the same problem (http://wordpress.org/support/topic/52798). I clicked upgrade regardless of these error messages and it works fine. :)

  5. argentine
    Member
    Posted 8 years ago #

    Nice update, no problem on
    http://perso.argentine-news.com/
    Anyway I will wait before updating the other one

  6. schestowitz
    Member
    Posted 8 years ago #

    I hope you made backups. See if it works regardless. I would only be worried about:

    WordPress database error: [Table 'rprins_wordpress.wp_usermeta' doesn't exist]
    SELECT meta_key, meta_value FROM wp_usermeta WHERE user_id = '1'

    Keep an eye on users to spot bugs early on, if at all.

  7. K
    Member
    Posted 8 years ago #

    I got this errors after upgrading to the latest version & cannot log-in to admin.

    WordPress database error: [Table 'knoizki_index.wp_usermeta' doesn't exist]
    SELECT meta_key, meta_value FROM wp_usermeta WHERE user_id = '1'

    Thanks for your help.

  8. zqw
    Member
    Posted 8 years ago #

    WP's upgrade.php creates wp_usermeta table and works fine regardless of the error message.

  9. rprins
    Member
    Posted 8 years ago #

    I was able to backup to 1.5.2 just fine, so I'm safe :)

    But, like K said, I couldn't log in to the admin panel at all with my old user name.

    Also, when I upgraded, so, step 1, there was a lot of errors, more than I am accustomed to with a WP install. Some had to do with comment counts and the rest had to do with the wp_usermeta table, which in my 1.5.2 install doesn't exist.

    Now, like zqw said, even after the install completed, it worked fine on the exterior (minus some custom queries I need to fix), but I couldn't log into the admin panel at all.

    So, would I say that it completes the upgrade? No, not successfully at least. I'd say that the script ran, but that that the upgrade did not run as expected.

  10. K
    Member
    Posted 8 years ago #

    It is so depressing, been re-uploading, deleting & now I lost all my backup. How am I gonna be able to fix the problem? Can I redowngrade it back to 1.5 version?

    Thank you.

  11. K
    Member
    Posted 8 years ago #

    Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/wp-db.php:102) in /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-content/themes/squible/comments.php on line 21

    That's another error found just now. What is going on??

  12. K
    Member
    Posted 8 years ago #

    I guess no one likes to reply and explain what causes this problem.

  13. zqw
    Member
    Posted 8 years ago #

    There's a session_start command after the stream has already received header information. As far as I know, this message shouldn't have any influence on the installation process. Just go with that. :)

  14. normad
    Member
    Posted 8 years ago #

    I am having the same problem...I can't log into my admin with my usual admin user name and password. I just keep getting the errror: "You do not have sufficient permissions to access this page." Everything else look fine on the exterior.

  15. normad
    Member
    Posted 8 years ago #

    I just tried to reset my password by entering my user name and e-mail address. It sent me a new password, but when I tried to log in with it tells me it is incorrect. The old one, however, still gives me the error message "You do not have sufficient permissions to access this page."

  16. patrickw
    Member
    Posted 8 years ago #

    This is probably the 5th or 6th time I've backed up, reloaded, upgraded and installed wp2.

    Finally it's working. Here's what I did.

    Leave your 1.5.2 WP intact. Make sure that the 1.5 wordpress install is in the directory that you want WP2 to be installed to.

    Backup your database just in case. In fact, back it up twice or three times just to make sure you always have a copy.

    Make sure you are still logged into your 1.5.2 install. It will have the cookies and such still intact so there is no need to login again. Do not logout.

    Move the 1.5.2 contents into a directory that you create. (Mine happened to be named /old/).

    Upload WP2 to the / directory where 1.5.2 was installed. Now your directory structure should look like: /wp-content/, /wp-admin/, /wp-includes/, /old/

    Navigate to [Wordpress install here]/wp-admin/upgrade.php

    You might (probably will) recieve the error:

    WordPress database error: [Table 'yourdbname.wp_usermeta' doesn't exist]
    SELECT meta_key, meta_value FROM wp_usermeta WHERE user_id = '1'

    Ignore it. Click upgrade.

    You will probably still see that same error on the second page. Just ignore it. If you see no other errors then click continue to go to your site.

    Now, you might possibly see a totally blank page. I did. Now, go to /wp-admin/. No need to login since you were already logged in. Hopefully this should stop the password issues you had.

    Click on the presentation tab and since your old theme isn't compatible (at least mine wasnt) wordpress will default to the default theme.

    Now go to your site homepage and everything should be fine.

    I was having lots of trouble and this is what solved it all for me. (Note: This is exactly what I did, if it doesn't work for you, sorry, I can try to help but I can't promise that what I say will work).

    Also, if you screw up your database and you didn't backup, it's not my fault.

    If you still are having password issues, you can always manually change the password by hand in the database.

    (This is in phpMyAdmin)

    Navigate to:
    wpdatabase > wp_users
    Click Browse and find the user 'admin'.
    Click on the little 'Pen' icon.
    Go down until you find the user: user_pass

    Use this little tool:
    http://pajhome.org.uk/crypt/md5/

    To MD5 hash your new password and stick it in that field.
    Save the changes and relogin to your wordpress with your new password.

    Enjoy. Once again, if you screw up your database and you didn't backup, it's not my fault.

    Edit: I realize the reason my theme wasn't compatible was because I forgot to move it to the new WP install.

  17. normad
    Member
    Posted 8 years ago #

    thanks for the advice. Don't worry...I learned my lesson about backing up long ago. That is the first thing I do now. I'll try this and see what happens.

  18. vkaryl
    Member
    Posted 8 years ago #

    One other thing that can sometimes help: before you backup your database, move files, etc. while logged in go to the Presentation tab and change BACK to the default theme from whatever theme you currently have selected.

  19. K
    Member
    Posted 8 years ago #

    There's another error.

    WordPress database error: [Table 'knoizki_index.wp_usermeta' doesn't exist]
    SELECT meta_key, meta_value FROM wp_usermeta WHERE user_id = '1'

    Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/wp-db.php:102) in /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/pluggable-functions.php on line 217

    Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/wp-db.php:102) in /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/pluggable-functions.php on line 218

    Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/wp-db.php:102) in /hsphere/local/home/knoizki/knoizki.com/wordpress/wp-includes/pluggable-functions.php on line 190

  20. K
    Member
    Posted 8 years ago #

    Thanks for the help. I'll just leave it for now.

  21. moshu
    Member
    Posted 8 years ago #

  22. rprins
    Member
    Posted 8 years ago #

    Wow! Thanks for the great replies!

    @patrickw: I was still logged in (cookie set and all) and did the steps that you outlined and I'm still getting the "You do not have sucifficent privelages" message. I think I might wait until 2.0 goes Final to test this on my main site, but I hope that I can set it up clean on a different part of my site.

  23. patrickw
    Member
    Posted 8 years ago #

    rprins: Have you tried modifying the password in the database? If that doesn't work then you can always install fresh and import your comments/posts via WP2's import function.

    Or you can also do it manually with the database. This is what I recommend simply because it imports everything. Here's how:

    Backup these tables in their own files (as in each table has their own file):

    NOTE: This is from your UPGRADED wordpress install. Just backup the posts comments and such I listed from your UPGRADED WORDPRESS 2 Install. Not the wp1.5 one.

    wp_categories
    wp_comments
    wp_post2cat
    wp_posts

    Assuming you kept the default prefix. Then, open each file (notepad isn't great, so I recommend Notepad2 from http://www.flos-freeware.ch/notepad2.html.

    Once each file is opened, use the replace function and replace 'wp' or whatever the old prefix was and then have notepad2 search and replace 'wp' with the new prefix.

    Then delete the 'wp_categories, wp_comments, wp_post2cat, and wp_posts' tables from your database and then import each of the modified files back into the new fresh install database.

    This will import your posts/comments/categories and such into the new install with a working password. Your settings will be lost but you can easily fix those via wordpress's admin interface.

    Hope that helps.

  24. rprins
    Member
    Posted 8 years ago #

    @partickw: Thanks for that response, I'll have to check it out later tonight or tomorrow.

    Thanks!

  25. patrickw
    Member
    Posted 8 years ago #

    Yep, no problem. Let me know how it goes.

  26. jhummel
    Member
    Posted 8 years ago #

    As patrickw posted above, the upgrade does seem to work even though you get the error noted. I got a blank page when attempting to go to my blog page, but after clearing cache and cookies was able to get to the site page and the error about the presentation being "broken" (with the default being reverted to) went away.

    I'm just starting to play with it and I like it a lot. Most everything seems to be working OK.

    I did notice that the import page did not list MovableType as a blog to inport from, yet there is an mt.php page in the wp-admin/import directory (along with b2, GreyMatter, and LiveJournal).

    When attempting to run the page (I had to paste: /wp-admin/admin.php?import=mt as the URL), I got the following error returned: "Warning: call_user_func(): First argument is expected to be a valid callback in /home/username/public_html/blog/wp-admin/admin.php on line 97" which is a comment.

    Since I'm pretty much of a noob when it comes to prgramming I have not been able to decipher where the actual error is being thrown.

  27. rprins
    Member
    Posted 8 years ago #

    @patrickw: Yea, man... I don't get it. I just did the upgrade again and it worked perfectly. Man, so strange. But, seriously, thank you for all your help, I really appreciate it and I'm sure others do as well.

  28. xy77
    Member
    Posted 8 years ago #

    I have to check on that, but I think this error can be caused, if you installed wordpress2 and did not only do an upgrade.
    From the Readme:
    1. Delete your old WP files, saving ones you've modified
    2. Upload the new files
    3. Point your browser to /wp-admin/upgrade.php
    4. You wanted more, perhaps? That's it!

    There's nothing about doing an install. If you did, it creates the admin user (UID 1) and thus your old user is gone and the password is random.

    Just my idea what could cause this. As I said, this must be approved.

    - David (xy77)

  29. themack
    Member
    Posted 8 years ago #

    I am in the same boat, upgrade gave me all those errors and now I cannont log in. Site looks ok, but I can't access the admin "You do not have sufficient permissions to access this page."

    I am guess the users table didn't get updated correctly? Also my catergories seem to not be working correctly

    I tried to create a new account to login to and got this error message:

    WordPress database error: [Table 'mackersl_peterdorsi.wp_usermeta' doesn't exist]
    SELECT meta_key, meta_value FROM wp_usermeta WHERE user_id = '2'

    When checking in phpmyadmin I can see that there is no "wp_usermeta" table in the DB.

  30. ergate
    Member
    Posted 8 years ago #

    I am having permission problems after upgrade. (see this post 52806) After the upgrade to rc3 I do not have permission to post or edit.

    While trying to figure out what the problem is I have found an anomoly in the wp_users table. When using myphpadmin I am given this message about the table.

    UNIQUE and INDEX keys should not both be set for column user_login

    Advice please.

    Aaron

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags