WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade: post.php and themes.php failing (1.2 -> 1.5) (7 posts)

  1. deirdre
    Member
    Posted 9 years ago #

    When I click on the Write link in the admin tab, the cursor shows busy while the file appears to load, but the screen does not change from the prior page (e.g. if it was on a Dashboard page, that's what it shows). No errors were given.

    For themes.php, I'm getting the following error:

    Fatal error: Call to a member function on a non-object in /www/htdocs/deirdreorg/blog/wp-includes/functions.php on line 1377

    I've searched, but I don't see anything similar for either of these quirks.

  2. deirdre
    Member
    Posted 9 years ago #

    Well, I fixed one problem: the themes problem was related to a broken theme I'd downloaded.

    However, even with a fresh 1.5 install, double-checking ALL the database tables were upgraded properly, well, the blog worketh not from an admin perspective.

    Oh, it displays great. But:

    1) The Write tab loads NOTHING.
    2) Links loads NOTHING.
    3) Plugins loads NOTHING.
    4) Users loads only the current user page, but none of the other user info, even when logged in as admin.

    The following admin pages work:
    1) Dashboard
    2) Manage
    3) Presentation
    4) Options

    Obviously, something is borked.

    Does anyone have an idea of what may be broken?

  3. deirdre
    Member
    Posted 9 years ago #

  4. carthik
    Member
    Posted 9 years ago #

    This is a strange problem. I tried helping at #wordpress. New files don't help. Nothing seems to be wrong with php or mysql.
    There are instances of php running out of 8 MB of memory.

    get_settings(); doesnt seem to be working, since a lot of variables are not set. functions.php is in fine shape though.

    The system is a debian machine.

    If someone has experienced these problems, and has a solution, please help.

  5. Michael
    Member
    Posted 9 years ago #

    You might like to try repairing your database, mysql can go screwy every now and then.

  6. deirdre
    Member
    Posted 9 years ago #

    Done that -- twice now -- along with pulling down a new copy of WP 1.5. Carthik and I spent an hour trying everything he could think of today.

  7. deirdre
    Member
    Posted 9 years ago #

    Apparently, the problem was some of the database options and comments. When I pared them down, the blog recovered.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.