WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade of WP 2.0 RC-1 (9 posts)

  1. petit
    Member
    Posted 8 years ago #

    Just wanted to tell you about a successful upgrade from WP 1.5.2 to WP 2.0 RC-1.

    System: My blog resides at an ISP ( web hotel ) running Apache and MySQL. This is how it went:

    1. Unpacked the distribution locally.
    2. Copied the database connection strings from wp-config.php to wp-config-example.php and saved it as the new wp-config.php.
    3. Deleting everything from my blog except the themes and plugins I've added.
    4. Uploaded the new WordPress bunch to the server
    5. Reached for the /wp-admin/upgrade.php from my browser
    6. Clicked the link Upgrade WordPress>>

    ( After getting an introductory error message "WordPress database error: [Table 'petitpub.wp_usermeta' doesn't exist] - SELECT meta_key, meta_value FROM wp_usermeta WHERE user_id = '1'" )

    That's it!

    It all worked like a breeze, including my themes and user and my permalinks.

    I'm happy :-)

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Moved to the Beta forum.

    'Upgrading' is when an official release happens.
    'Testing' is what happens up until then ;)

  3. moshu
    Member
    Posted 8 years ago #

    I just said the same 2 hrs earlier: :)
    http://wordpress.org/support/topic/51442

  4. petit
    Member
    Posted 8 years ago #

    Aha!
    I didn't think Release Candidates were betas.
    Thanks!

  5. Usayd
    Member
    Posted 8 years ago #

    I tested rc-1 works fine didn't even get any errors :)

  6. tedfox
    Member
    Posted 8 years ago #

    I've goten that usermeta data error too while upgrading. Sometimes the rest ofthe process went fine, sometimes it didn't. Thankfully it did most of the time though.

  7. miketrain
    Member
    Posted 8 years ago #

    How do I get the beta version

  8. MichaelH
    Member
    Posted 8 years ago #

  9. bornfamous
    Member
    Posted 8 years ago #

    I'm getting the usermeta error too. How do I fix it?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags