WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade Mandatory? (6 posts)

  1. brogers2
    Member
    Posted 5 years ago #

    I am running WordPress 2.3 on my website. My webhost is telling me that I need to update it to 2.6.1. They are saying that there are security issues in this version of WordPress and that I need to keep it up to date. They even mention that my blog may be disabled if it is not updated.

    Is it absolutely mandatory to update to version 2.6.1? I'm afraid that if I update that it will break my blog.

    Thanks

  2. NC@WP
    Member
    Posted 5 years ago #

    It seems like you're in a bind... Yes, there are security issues. And yes, upgrading to 2.6.1 may break your blog, if your theme and plugins are not compatible with 2.6.1.

    What I don't understand, however, is why your security is any concern of your host... Under a proper server setup, even if you do get hacked, it should affect only your account.

  3. whooami
    Member
    Posted 5 years ago #

    thats a great host -- who are they?

    when youre done upgrading drop them an email and thank them for looking out for you.

  4. brogers2
    Member
    Posted 5 years ago #

    My webhost is telling me that if my blog is hacked into it can cause the entire web server to be blacklisted. Wouldn't the blacklist just affect my website? Has WordPress 2.3 been hacked into before?

  5. Jeremy Clark
    Moderator
    Posted 5 years ago #

    No it would most likely affect other people using the same server as well if it is a shared host which I imagine it is.

    Yes 2.3 has been hacked before, and has very well known exploits by now.

  6. brogers2
    Member
    Posted 5 years ago #

    To upgrade, do I just replace all of my files with the files from 2.6.1 and run the upgrade.php page?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.