WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade issues (remove wordpress from end of domain) (27 posts)

  1. RRTeam
    Member
    Posted 5 years ago #

    I upgraded to new wordpress, and cant figure out how to remove the wordpress from the end of my domain, plus, i cant find my blog..

    http://www.bedford-ny-real-estate.com/wordpress

  2. On that site this URL http://www.bedford-ny-real-estate.com/blog/ works.

    Also you have a index.html file in your root. It's getting hit before index.php.

    Rename that index.html or delete it and try http://www.bedford-ny-real-estate.com/

    That should work then.

  3. RRTeam
    Member
    Posted 5 years ago #

    I deleted the index.html file and now i get error message.

    Any advice?? I really need to get this back up and am regretting the upgrade. Thanks!!!

  4. RRTeam
    Member
    Posted 5 years ago #

    plaese help someone!

    I checked mysql and made sure it was set to correct page.

    Now, it says:

    Directory has no index file.

    Browsing this site or directory without an index file is prohibited.
    If you are the site's webmaster, you can remedy this problem by creating a default HTML page with one of the following names:

    index.html
    index.htm
    default.htm
    Default.htm
    home.html
    Home.chtml
    NOTE: Filenames are case sensitive, i.e., Home.html is not the same as home.html

  5. I just looked, even the /blog/ no longer works, getting a 500 error message. Just removing that file should not have caused that.

    Can you re-upload the wordpress files? That 500 error should not have happened.

  6. RRTeam
    Member
    Posted 5 years ago #

    why does my site still sort of work under http://www.bedford-ny-real-estate.com/wordpress? I didnt save my files, but i think i can get this back b/c it did a similar thing when i originally installed.

  7. RRTeam
    Member
    Posted 5 years ago #

    Question- can i reupload wordpress w/o losing my content? if i remove the other files, is the content file where the blog info and other are located? i only had this blog for a few weeks so its not the end of the world, but my homepage had a lot of links etc since i use this site as a CMS and dont want to have to redo all that. Thx!

  8. RRTeam,

    If you just re-upload the WordPress files then your posts should not be effected. You're posts are stored in your MYSQL database.

    I do not think that will work though. You are getting errors on the web server.

    What did your host provider say? If this is your WordPress install at http://www.bedford-ny-real-estate.com/index.php then you should get some output not just a 500 error.

    The web server error log should say something about why it's generating that error.

    Also when there is an index.php in the directory, that should be a valid file in replace of index.html.

  9. RRTeam
    Member
    Posted 5 years ago #

    I honestly dont know what to do. They said wordpress was installed incorrectly. I feel clueless, lol. This is what my site says on the http://www.bedford-ny-real-estate.com

    Directory has no index file.

    Browsing this site or directory without an index file is prohibited.
    If you are the site's webmaster, you can remedy this problem by creating a default HTML page with one of the following names:

    index.html
    index.htm
    default.htm
    Default.htm
    home.html
    Home.chtml
    NOTE: Filenames are case sensitive, i.e., Home.html is not the same as home.html

  10. RRTeam
    Member
    Posted 5 years ago #

    What would your advice be? Should i remove it completely and do a complete re-install? will i lose anything? or just reinstall upgrade again? I am redirecting my site to http://www.bedford-ny-real-estate.com, fyi, and am not using wordpress after it. I really need to get back up, any help appreciated!

  11. Well they're probably right. Your WordPress is not installed correctly.

    If you have a backup of both your files and your database, and if you know and are confident you know how to restore your backup, then yes you should restore your files.

    At this point replacing your files with a fresh copy from http://wordpress.org/download/ can't hurt. Just replacing the files will not hurt your database entries.

  12. RRTeam
    Member
    Posted 5 years ago #

    Im just going to restore the whole thing to a few days ago and forget about the upgrade! my host is going to have tech support do it for me. thanks for your help.

  13. fodo
    Member
    Posted 5 years ago #

    Was there ever a resolution to this? I am having the exact same problem, I have been trolling the forum all night and have yet to find a resolution...is any one working on this?

  14. SevereSociety
    Member
    Posted 4 years ago #

    I am having the same problem too and cannot find any answers. I've been getting the same "no directory" error from the beginning. My index.php file seems to be a blank php file.....

    I have tried unistalling and re-installing 5 times and the same exact problem is still happening. I have no idea how to view my blog, but I can "publish" from my admin area.

    If I don't get answers soon I will use another blogging product in order to finish this for a client.

  15. brainycat
    Member
    Posted 4 years ago #

    It sounds like what's happening is that you are downloading the entire /wordpress directory into the DOCROOT, or top level directory for your server eg:
    /home/user/yourdomain.tld/wordpress/index.php
    Your host's server is no doubt configured with DOCROOT /home/user/yourdomain.tld, so to access wordpress you need to go to http://yourdomain.tld/wordpress. See how subdirectory on the disk map to different URLS?

    What you want to do is upload the <b>contents</b> of the wordpress directory after you unzip the package you downloaded. This puts owrdpress right at the top of DOCROOT, so http://yourdomain.tld will bring up index.php from the WP package.

    If you already have an installation in a subdirectory, don't delete the database. Just put the files in the right place, then you'll need to change a couple of records in the 'options' table in your wordpress database. On my dev machine records 1 and 34 contain the URL that WP should be accessed at.

  16. SevereSociety
    Member
    Posted 4 years ago #

    I have WP installed in a subdirectory called 'blog' already. Using http://severesocietyfilms/wordpress or http://severesocietyfilms/blog return a roadrunner error page.

    There is an index.php in my 'blog' directory. Where is it supposed to go?

    How do I know what URL WP should be accessed at - and how do I find my "records 1 and 34" if I don't have an "options" table anywhere?....

  17. SevereSociety
    Member
    Posted 4 years ago #

    sorry I meant to add a ".tld" to the urls up there. They don't work. If I tryf http://www.severesociety.com/blog/index.php it says the file has been deleted or not found although I see it sitting right there in the folder on my server....

  18. brainycat
    Member
    Posted 4 years ago #

    It appears that you don't own that domain. You'll need to contact brokerage@buydomains.com to discuss purchasing it.

    Checking server [whois.domaindiscover.com]
    Results:

    This WHOIS database is provided for information purposes only. We do
    not guarantee the accuracy of this data. The following uses of this
    system are expressly prohibited: (1) use of this system for unlawful
    purposes; (2) use of this system to collect information used in the
    mass transmission of unsolicited commercial messages in any medium;
    (3) use of high volume, automated, electronic processes against this
    database. By submitting this query, you agree to abide by this
    policy.

    Registrant:
    RareNames, WebReg
    738 Main Street, #389
    Waltham, MA 02451
    US

    Domain Name: SEVERESOCIETY.COM

    Administrative Contact, Technical Contact, Zone Contact:
    RareNames, WebReg
    738 Main Street, #389
    Waltham, MA 02451
    US
    (781)839-7993
    (781)839-2801 [fax]
    brokerage@buydomains.com

    Domain created on 21-Dec-2004
    Domain expires on 21-Dec-2009
    Last updated on 18-Dec-2008

    Domain servers in listed order:

    NS.BUYDOMAINS.COM
    THIS-DOMAIN-FOR-SALE.COM

  19. SevereSociety
    Member
    Posted 4 years ago #

    sorry, it's severesocietyfilms.com - but that's beside the point

    I have WP installed on my server with all of the files there but when I type the url the http://www.severesocietyfilms.com/blog/index.php URL changes to http://severesocietyfilms.com/blog/ and gives me the message "Directory has no index file.
    Browsing this site or directory without an index file is prohibited.
    If you are the site's webmaster, you can remedy this problem by creating a default HTML page with one of the following names:

    index.html
    index.htm
    default.htm
    Default.htm
    home.html
    Home.chtml
    NOTE: Filenames are case sensitive, i.e., Home.html is not the same as home.html"

    Any idea how to fix this problem?

  20. brainycat
    Member
    Posted 4 years ago #

    severesocietyfilms.com seems to work, and I get the 'dir listing forbidden' error. As the rest of the pages are .html, I would check to make sure that PHP is enabled on the server and that that httpd.conf or .htaccess includes
    DirectoryIndex index.php

    You will have to consult your host's documentation to enable PHP if it isn't. You can try putting a file called test.html in the top directory that has this in it:
    <?php phpinfo() ?>

    There's only an outside chance that will work though.

  21. SevereSociety
    Member
    Posted 4 years ago #

    Yes my server has the latest php version enabled - the people who originally made this site do not know how to use php so it is all static html. The website works but I can't seem to access the WP blog by going to the above url, nor can I view it from the "view site" button in the admin...

    The index.php file is what came with the WP installation, there aren't any html files in the WP directory...

    I've tried uninstalling and re-installing but the same thing happenes every single time. I don't know why the url http://www.severesocietyfilms.com/blog/index.php is not accessible... When I open index.php I see the following code:

    "<?php
    /**
    * Dashboard Administration Panel
    *
    * @package WordPress
    * @subpackage Administration
    */

    /** Load WordPress Bootstrap */
    require_once('admin.php');

    /** Load WordPress dashboard API */
    require_once(ABSPATH . 'wp-admin/includes/dashboard.php');

    wp_dashboard_setup();

    wp_enqueue_script( 'dashboard' );
    wp_enqueue_script( 'plugin-install' );
    wp_enqueue_script( 'media-upload' );
    wp_admin_css( 'dashboard' );
    wp_admin_css( 'plugin-install' );
    add_thickbox();

    $title = __('Dashboard');
    $parent_file = 'index.php';
    require_once('admin-header.php');

    $today = current_time('mysql', 1);
    ?>

    <div class="wrap">
    <?php screen_icon(); ?>
    <h2><?php echo wp_specialchars( $title ); ?></h2>

    <div id="dashboard-widgets-wrap">

    <?php wp_dashboard(); ?>

    <div class="clear"></div>
    </div><!-- dashboard-widgets-wrap -->

    </div><!-- wrap -->

    <?php require('./admin-footer.php'); ?>"

    Why doesn't the file show up? I can't view any of my pages I create in the admin either, same thing happens...

  22. brainycat
    Member
    Posted 4 years ago #

    Perhaps a permissions error? The server process doesn't have permission to read the files the ftp user is writing? Do you have shell access?

    put a file called test.php in the TOP directory, the same directory where the .html files are located. The file contains:
    <?php phpinfo() ?>

    When you access that file, you should get a detailed listing of the PHP and Apache configuration parameters. If you don't, there's something wrong with PHP.

    I checked around on the site, and I see that the images are in the top directory with the .html.

    Try making a new subdirectory, mytest. Put index.html in there with something like <html><head></head><body>test</body></html> and see if you can access that, just to make sure your host is setup to serve out of subdirectories. I can't imagine why they wouldn't, but it's worth testing.

  23. SevereSociety
    Member
    Posted 4 years ago #

    Yep, everything is set up perfectly adn the php is working. I am only having problems accessing the index.php file in the main WP directory. I can access the index.php file in the wp-admin folder just fine.

  24. brainycat
    Member
    Posted 4 years ago #

    I'm sorry I think I misunderstood you earlier. When you access /blog/wp-admin/index.php you get the rendered page, not the raw contents of the file as you posted above? When I attempted to access /blog/wp-admin I got the 403 error, identical to /blog.

    You are able to access files in another subdir?

    This is looking more and more like a permissions error.

    You're hosting with ipowerweb? Are you doing the automagic install or uploading the source via ftp?

  25. SevereSociety
    Member
    Posted 4 years ago #

    I did the automatice install through iPowerweb. I am able to access my admin area (the place where you make new posts and new pages and edit the appearance of your blog, etc.) by going to the index.php file contained in /blog/wp-admin/index.php.

    The following happens when I go to http://www.severesocietyfilms.com/blog/index.php or click the "view site" link in my wordpress admin area:

    "Directory has no index file.
    Browsing this site or directory without an index file is prohibited.
    If you are the site's webmaster, you can remedy this problem by creating a default HTML page with one of the following names:

    index.html
    index.htm
    default.htm
    Default.htm
    home.html
    Home.chtml
    NOTE: Filenames are case sensitive, i.e., Home.html is not the same as home.html"

    Once at that page I see that the url in the address bar of my browser changes to http://www.severesocietyfilms.com/blog/ - leaving off the index.php.

    If this is a permissions error (by this do you mean priviledges in mySQL?) then do you know how to fix that? As far as I know I am the only user, the administrator, and I have all priviledges....

  26. SevereSociety
    Member
    Posted 4 years ago #

    I have pointed the DirectoryIndex to index.php via .htaccess file. Now WordPress is working fine without any issue.

    Problem solved - hope this helps others!

  27. EmmaW
    Member
    Posted 4 years ago #

    I have the same problem here.
    Testing SevereSociety's method in .htaccess.
    test blog

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.