WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Podcasting Plugin by TSG and WordPress 3.0 (34 posts)

  1. talgalili
    Member
    Posted 4 years ago #

    I got the error:

    Fatal error: Call to a member function add_rewrite_tag() on a non-object in /home/humus101/public_html/r-statistics.com/wp-includes/taxonomy.php on line 289

    Help :(

  2. dkmccue
    Member
    Posted 4 years ago #

    Same Here!

    How do we fix this?

  3. markhawkins
    Member
    Posted 4 years ago #

    Also...

    Error Code: php_code_error:1:/home/sites/amanzi-media.com/public_html/wp-includes/taxonomy.php:289:Call to a member function add_rewrite_tag() on a non-object

    Any ideas please?

    Many thanks

  4. quicksound
    Member
    Posted 4 years ago #

    Same here...

  5. webjac
    Member
    Posted 4 years ago #

    Same here.... don't know what to do

  6. talgalili
    Member
    Posted 4 years ago #

    Friends,
    until this is fixed.

    I created a
    index.html
    file
    with "site is down"
    (change your index.php to something like "temp.php)

    And redirected all pages to it, using this:

    http://www.daniweb.com/forums/thread223831.html

  7. webjac
    Member
    Posted 4 years ago #

    Found a temporary solution:

    I commented out lines 289 & 290 in taxonomy.php and the site came back up , still waiting on a official fix however .

  8. webjac
    Member
    Posted 4 years ago #

    Some people is saying that "Upon further investigation ,
    The plugin that caused my crash was Podcasting Plugin by TSG "

    all this info is taken from: http://wordpress.org/support/topic/411364?replies=5

    (It worked for me)

  9. webjac
    Member
    Posted 4 years ago #

    I confirmed that I have the: Podcasting Plugin by TSG

    I deactivated it and uncommented the lines 289 & 290 in taxonomy.php and the site worked normally.

    apparently Podcasting Plugin by TSG breaks the site. Deactivate before you upgrade and wait for an update

  10. talgalili
    Member
    Posted 4 years ago #

    I also had
    "Podcasting"
    On.

    I'll check it out.

  11. dkmccue
    Member
    Posted 4 years ago #

    Confirmed. I deleted the folder with that plug-in and my site is now back up.

    Don't know why I still had it, as I haven't podcasted in over a year! LOL

  12. talgalili
    Member
    Posted 4 years ago #

    Double confirmed.
    I also deleted the podcasting folder and the upgrade went smoothly.

    Cheers,
    Tal

  13. markhawkins
    Member
    Posted 4 years ago #

    Anyone using the Builder set of themes and plug-ins with v3.0.

    I tested the RC3 with this and all was ok, but I think it has broken WP3 upgrade.

    thanks

  14. nibb42
    Member
    Posted 4 years ago #

    Had this same problem folks, alas, we use the podcasting plugin quite a lot, and some other plugins too - does anyone know if the issue is limited to just the podcast plugin?

    best wishes

    Steve Nisbet

  15. markhawkins
    Member
    Posted 4 years ago #

    the taxonomy fix worked great thanks webjac

  16. ddarby14
    Member
    Posted 4 years ago #

    Hey everyone, I don't recommend changing the WP code (taxonomy.php) as that may break other plugins/functionalities.

    I checked out this plugin and the offending line I found was line 15 in /plugins/podcasting/podcasting.php

    register_taxonomy('podcast_format', 'custom_field');

    I changed this to a function call

    function build_taxonomies() {
    	register_taxonomy('podcast_format', 'custom_field');
      }
      add_action( 'init', 'build_taxonomies', 0 );

    and the plugin worked perfectly for me. Hope this helps, looks like a great plugin.

    Thx

  17. Andrew Nacin
    Lead Developer
    Posted 4 years ago #

    The taxonomy "fix" cripples a decent amount of WordPress functionality when used correctly. http://wordpress.org/support/topic/411435?replies=14

  18. If you run into this error, reset your plugins and do not reactivate the Podcasting Plugin by TSG until you have modified the code per ddarby14's instructions.

    See this reply from nacin for an explanation.

  19. glennbennett
    Member
    Posted 4 years ago #

    Sorry guys, I've been on vacation. Thanks for the hint ddarby14. Very much appreciated. Upgrade is now ready and seems to work.

  20. ddarby14
    Member
    Posted 4 years ago #

    np, glenn glad to help - I've never seen it til tonight - as it turns out it uses both audio/video players I prefer to use, so I am now using the plugin :) - thx for getting it officially updated for everyone so quickly

  21. katefoy
    Member
    Posted 4 years ago #

    HI Glenn
    I was wary of upgrading Podcasting plugin after following ddarby14's good advice re the function call. I have deactivated it for now. I see there is an upgrade, so is it OK to do so?

    Thanks!

  22. The upgrade includes ddarby14's fix, so it's safe to upgrade now.

  23. spreadsheetninja
    Member
    Posted 4 years ago #

    Mailpress_mailinglist also causes this error.

  24. ntbw
    Member
    Posted 4 years ago #

    Okay, crazy question. How do I get to the wp-admin /plugins if I cannot get onto my blog?

  25. ntbw
    Member
    Posted 4 years ago #

    Thanks! I completely forgot about my hosting and was looking "ON" my computer.

  26. You're welcome!

  27. ntbw
    Member
    Posted 4 years ago #

    OH MY GOODNESS!!!
    I have spent hours trying to fix this problem! Went onto Godaddy.com, hosting, wp-admin, plugin's to the problem then delete and....
    voila!

    I cannot thank you enough.

  28. No trouble! You're quite welcome.

  29. fraynelson
    Member
    Posted 4 years ago #

    Thank you, everybody. My blog is again back and running. Special thanks to you, ddarbi.

Topic Closed

This topic has been closed to new replies.

About this Topic