WordPress.org

Ready to get started?Download WordPress

Forums

upgrade from 2.6.1 to 2.7.1 results in error: wp-includes/widgets.php (10 posts)

  1. pkids
    Member
    Posted 5 years ago #

    I followed all the instructions to upgrade and received this error when I tried to view my blog following the upgrade:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/pkids/public_html/pkidsblog/wp-includes/widgets.php on line 1045

    I then tried:

    * using the new wp-config.php file, putting in my DB info
    * commenting out/changing the character set from utf8 to something else
    * deleting all plugins from my server and uploading the ones in the 2.7.1 package
    * deleting all themes and uploading the themes file included with 2.7.1
    * manually setting the theme to "default" in phpmyadmin

    I can't even get to the admin panel. As I mentioned, I followed all instructions, including disabling plugins and backing up files prior to backing up.

    I've been searching the web and these forums for help and can't figure it out. Any help will be appreciated.

  2. mrmist
    Forum Janitor
    Posted 5 years ago #

    Does it relate to this ?

    http://core.trac.wordpress.org/ticket/9214

    If so you could potentially get around it by applying the patch to your installation.

  3. pkids
    Member
    Posted 5 years ago #

    Thanks for replying. :)

    I looked at that for several minutes trying to see any way it might be related, but I can't. We definitely have tons of tags in use.

    I got to looking at the code on that line 1045, which I know nearly nothing about, and messed with it a little, then tried to change it back, and now am getting new error messages.

    I suppose I should just download the entire package again, fresh, and delete everything, and start over, like it's a new install, and edit my config file w/ my current database info.

  4. pkids
    Member
    Posted 5 years ago #

    ok, this is making me batty! <pulling hair out>

    I uploaded everything again, and still get the same error message. At least I'm not getting the other ones. I don't understand what it's looking for. When i Google the above error message, I get a lot of foreign language stuff. I was using a translator widget, but those files are GONE -- I deleted *everything* before uploading freshly.

    Here's the plugin: http://wordpress.org/extend/plugins/global-translator/ -- it says it does not alter the database.

    I'm at a loss. Any more help or suggestions would be greatly appreciated.

  5. whooami
    Member
    Posted 5 years ago #

    you googled, did you use the search here?

    http://wordpress.org/support/topic/172272

  6. pkids
    Member
    Posted 5 years ago #

    I did use the search here, but I hadn't tried removing the problematic code. I did that and the blog displayed correctly, and I was able to get to the admin panel.

    I'm curious as to why it says i have 8 plugins that need updating, since I had deleted everything in the blog directory before uploading again. On the left side, I can click on "Widgets" and that works, but if I click on "Plugins" on the left side, I get a fatal error. I can click on "editor" under "Plugins" and that works OK, and I see just the 2 plugins that are in the wordpress directory, but there's still an "8" next to "Plugins", which is how many plugins I had that needed updating before I started the upgrade process. So somehow it's still picking up that number from somewhere.

    So my situation is improved -- thank you! -- but I'm not sure how to finish fixing the problem. Any suggestions?

  7. zeerebel
    Member
    Posted 5 years ago #

    I had the same bloody problem for my website http://www.fusionmma.com

    I spend 4 hours trying to re-install WordPress etc. Finally I gave up and edit the widget.php code. Is not perfect but at least I am able to log back in and export my WordPress site so that I can re-start from scratch.

    Here is the fix!!
    Is not perfect, but I will allow you to get into your admin. PS this is my 1st post --- I am by no mean an expert

    [huge chunk of code moderated - please use a pastebin]

  8. zeerebel
    Member
    Posted 5 years ago #

    Your widget will not be fully functional...but it gives you a chance to retrieve your file.

  9. e1klipse
    Member
    Posted 5 years ago #

    Go to wp-config.php

    Search:
    define('DB_CHARSET', 'utf8');

    Change for:
    define('DB_CHARSET', '');

    It's all.

  10. Fernsehformat
    Member
    Posted 5 years ago #

    @e1klipse: I just registered to say THANK YOU! You saved my ass, thanks so much.

Topic Closed

This topic has been closed to new replies.

About this Topic