WordPress.org

Ready to get started?Download WordPress

Forums

Upgrade: Error establishing a database connection (3 posts)

  1. ntresour
    Member
    Posted 6 years ago #

    My host has (finally!) added an auto upgrade option for WordPress to move from 2.3 to 2.6. Upon running their upgrade process I get this error (after an initial message saying the upgrade was successful):
    - - -
    Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at ntresour.dot5hostingmysql.com. This could mean your host's database server is down.
    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?
    - - -
    Since this comes from the f. url, I assume this is a WordPress error, not unique to my host isp's system:
    <http://******/blog/wp-admin/upgrade.php>
    - - -
    I filed a support ticket with my host, but they aren't the fastest responding, esp. on the weekend. And I know nothing about managing the database directly. I can access my web site, but not the blog; I can also access the vDeck control panel my host uses (v 3)--and I *think* CGI is already enabled (per the instructions on this forum); when I check the CGI page in vDeck there is no option to activate it, so I'm assuming it is already on. Checking my site via ftp shows the 2.6 files in place, so I assume the install is OK, but it's not synching with the database?

    Any suggestions greatly appreciated.

    Rod

  2. moshu
    Member
    Posted 6 years ago #

    It seems the joy about the automatic upgrade was a bit too early. They always suck...

    1. It's not that the install is not "synching" with the DB. It simply does NOT connect to the database.
    2. If the automatic upgrade overwrote your wp-config.php file... then you must enter the correct values into it manually!
    3. No, it is NOT a WP error - it is your blog/site's error. Can you answer with a sounding, 120% YES to all those 3 questions in the error message?
    4. You don't need CGI ever for WP to run.
    5. There is nothing to manage in the database. All you have to do: edit the wp-config .php file to have the correct data in it.

  3. ntresour
    Member
    Posted 6 years ago #

    OK, thanks. I'll explore that (tomorrow).

    As to your comment that CGI is not needed, then what is the point of this (seemingly official, locked) post at the head of this forum?

    http://wordpress.org/support/topic/181351?replies=1

    If you are installing WordPress through a vDeck 3.0 control panel such as used by iPower and others be aware you must enable CGI. This also enables PHP on the server which you must have to run WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic